Jump to content

dev botao

Acbrnfemonitor Não Imprimi O Danfe


jesusap
Go to solution Solved by jesusap,
  • Este tópico foi criado há 3566 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Estou Testando o ACbrNFeMonitor e tudo deu certo exceto uma coisa, a impressão do danfe, eu estou usando o metodo NFe.CriarEnviarNFe( cTextoIni, nNumLote, [ nImprimirDanfe ]) estou passando o parametro  [nImprimirDanfe ] com o valor 1 conforme a descrição lida no manual, ele transmite a NFe a mesma é autorizada porem não imprime o DANFE, ja olhei a chamada do metodo no tela de comandos processados do ACbeNfeMonitor e esta certo, o terceiro parametro esta com o valor 1 conforme passado no envio do comando NFe.CriarEnviarNFe( cTextoIni, nNumLote, [ nImprimirDanfe ]), estou usando o ACBrNFeMonitor 0.8.8.1 usando conexão por Socket. gostaria de sabe se estou fazendo alguma coisa errada, alguem poderia me ajudar com isto.

 

Obrigado.

Link to comment
Share on other sites

  • Moderadores

Bom dia! Veja também quantas linhas vc tem na observação. 
O Modelo Rave está limitado a um número que não lembro agora, talvez 6 ou 7 linhas na observação.
(Lembrando que cada ";" representa uma nova linha). Se ficar dúvida e for possível anexe o XML.


logoacbr.pngConheça o Portal do Projeto ACBr

Ajude o Projeto ACBr crescer - Assine o SAC ACBr
Assine um dos planos de longa duração do SAC ACBr, obtenha Descontos Especiais, Parcele no Cartão e ainda ganhe Brindes Exclusivos. Saiba mais aqui

Conheça o ACBrLib, o ACBr de forma nativa para qualquer linguagem de programação. Saiba mais aqui

 

 

 

 

Link to comment
Share on other sites

Tente configurar e veja se pelo menos a tela de preview é exibida.

Ola boa tarde, testei conforme sua sugestão, quando configuro para mostrar o preview antes funcionou, se tiro esta configuração não funciona.

 

que mais poderiamos tantar.

 

Obrigado.

Link to comment
Share on other sites

  • Moderadores

Se imprime pelo preview e não imprime diretamente só pode ser algum problema na configuração do nome da impressora ou da impressora padrão do windows.

Deixe o nome em branco nas configurações do ACBrNFeMonitor e veja se a impressão é enviada para a impressora padrão do windows.

djsystem-logo.png
 youtube.png facebook.png instagram.png linkedin.png
André Ferreira de Moraes | Analista de Sistemas
www.djsystem.com.br | www.djpdv.com.br
www.tefhouse.com.br | www.lambretinha.com.br
Link to comment
Share on other sites

  • 2 weeks later...
  • Solution

descobri o que estava errado, era o comando enviado, ao passar o parametro de  indica que deve imprimir o danfe estava colocando com quebra de linha, na verdade somente os parametro refente aos dados da NFe que deve ser enviado com quebra de linha.

 

Resolvido.

 

 

Obrigado pela atenção.

  • Like 1
Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

The popup will be closed in 10 seconds...