Jump to content

logo_acbr_paygo.png

Chegou o TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


botao_saibamais.png

beneficios.png

Curso Dominando o ACBrMonitor
Novo Módulo Soluções de Varejo
Assine o SAC ACBr em qualquer plano e tenha acesso

Saiba Mais

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba Mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Lucas L.

Erro ao compilar pacotes Fast Report

  • Este tópico foi criado há 723 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

Boa Tarde,

   Realizei a instalação do Trunk 2 em uma máquina sem versão prévia ACBR, com Delphi XE5 e Fast Reports 4, seguindo os passos do Como instalar o Trunk2 do ACBr - REGYS SILVEIRA, e tudo foi instalado com sucesso, o passo a passo é excelente.Mas hoje ao tentar instalar em uma máquina com uma versão prévia do ACBR  e com o Fast Reports 5.19, ocorreu o erro abaixo, pois não foi possível compilar os pacotes: 
-"ACBr_NFeDanfeFR.dpk"
-"
ACBr_CTeDacteFR.dpk"
-"ACBr_BoletoFR.dpk"
-"
ACBr_MDFeDamdfeFR.dpk"

Erro:

C:\Projetos\Delphi\Componente\XE5\Acbr\Fontes\ACBrDFe\ACBrMDFe\DAMDFE\Fast\ACBrMDFeDAMDFEFRDM.pas(43) Fatal: E2225 Never-build package 'frx19' must be recompiled
Compilation failure


***Como alternativa tentei recompilar manualmente os pacotes, mas não obtive sucesso.

Alguém poderia me propor uma alternativa, solução?

Fico no Aguardo!

Att, Lucas
 

Edited by Lucas L.

Share this post


Link to post
Share on other sites

Régys Silveira, obrigado pela ajuda. De fato havia pacotes antigos. Consegui instalar com sucesso, utilizando o ACBr Install. 

Share this post


Link to post
Share on other sites

Também estou com erro para instalar os reports pelo instalador. A máquina foi recém formatada, instalado fast 5.1.9, 

Borland Delphi Version 15.0
Copyright (c) 1983,2002 Borland Software Corporation
D:\PROJETOS\LIB\ACBr\trunk2\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fast\ACBrNFeDANFEFRDM.pas(76) Fatal: File not found: 'frx7.dcp'
Compilation failure

O aquivo que falta está em C:\Program Files (x86)\Borland\Delphi7\Projects\Bpl

Log do erro em anexo

 

 

log_Delphi_7.txt

Share this post


Link to post
Share on other sites

Adicione esse diretório no Library Path do Delphi

Obrigado Daniel, funcionou.

Eu não tinha adicionado pois o path $(DELPHI)\Projects\Bpl já estava na library path, mas agora foi de boa.

Share this post


Link to post
Share on other sites

Bom dia!

  Também estou com problema para instalar  o ACBR em anexo 

 

ACBr_MDFeDamdfeFR.dpk(56) Fatal: Could not compile used unit '..\..
\..\..\..\..\Fontes\ACBrDFe\ACBrMDFe\DAMDFE\Fast
\ACBrMDFeDAMDFEFRDM.pas'
Compilation failure
Erro ao compilar o pacote "ACBr_MDFeDamdfeFR.dpk"

log_Delphi_7.txt

Share this post


Link to post
Share on other sites
2 horas atrás, Cleomar Pacheco disse:

Bom dia!

  Também estou com problema para instalar  o ACBR em anexo 

 

ACBr_MDFeDamdfeFR.dpk(56) Fatal: Could not compile used unit '..\..
\..\..\..\..\Fontes\ACBrDFe\ACBrMDFe\DAMDFE\Fast
\ACBrMDFeDAMDFEFRDM.pas'
Compilation failure
Erro ao compilar o pacote "ACBr_MDFeDamdfeFR.dpk"

log_Delphi_7.txt

Fast Report 5.5


Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

Share this post


Link to post
Share on other sites

Estou com problemas para instalar os componentes 

C:\Acbr\Fontes\ACBrDFe\ACBrMDFe\DAMDFE\Fast\ACBrMDFeDAMDFEFRDM.pas(409) Error: E2003 Undeclared identifier: 'Quality'
ACBr_MDFeDamdfeFR.dpk(54) Fatal: F2063 Could not compile used unit 'ACBrMDFeDAMDFEFRDM.pas'
Compilation failure
Erro ao compilar o pacote "ACBr_MDFeDamdfeFR.dpk".

 

estou utilizando o FastReport nativo do XE2. Alguem podeira me ajudar?

Share this post


Link to post
Share on other sites

sim ele precisa ser usado o professional ou enterprise não o embarcado com o delphi


Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

Share this post


Link to post
Share on other sites

a minha instalacao do acbr tambem ta com problemas

instalou tudo normal , mas a parte de impressao do danfe no fast reporte nao instalou nada

meu delphi e o berlin no window 7 32 bits 

Share this post


Link to post
Share on other sites

estou com o mesmo erro

ACBr_MDFeDamdfeFR.dpk(54) Fatal: F2063 Could not compile used unit 'ACBrMDFeDAMDFEFRDM.pas'
Compilation failure
Erro ao compilar o pacote "ACBr_MDFeDamdfeFR.dpk".
 

Delphi XE3

segui log de erro

já coloquei a pasta no   library path,

log_Delphi_XE3.txt

Share this post


Link to post
Share on other sites
7 horas atrás, Jean Prado disse:

estou com o mesmo erro

ACBr_MDFeDamdfeFR.dpk(54) Fatal: F2063 Could not compile used unit 'ACBrMDFeDAMDFEFRDM.pas'
Compilation failure
Erro ao compilar o pacote "ACBr_MDFeDamdfeFR.dpk".
 

Delphi XE3

segui log de erro

já coloquei a pasta no   library path,

log_Delphi_XE3.txt

Versão do seu fast report é antiga e assim não tem as propriedades

Fast Report 5.5 ou superior

Está é a msg completa

C:\ACBR\Fontes\ACBrDFe\ACBrMDFe\DAMDFE\Fast\ACBrMDFeDAMDFEFRDM.pas(411) Error: E2003 Undeclared identifier: 'Quality'


Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

Share this post


Link to post
Share on other sites

Bom dia , estou com um problema e talvez vcs possam me ajudar, vou contar o que fiz, formatei meu computador e instalei o Delphi 7 com os componentes Acbr, FastReport e QuickReport. Até ai tudo bem, mas resolvi também instalar nessa máquina o Delph Xe8 porque estamos começando a mudar nosso programa, pois bem, instalei o componente FortReport e Acbr porém meus ícones nesses componentes não parecem a imagem correta . Olhem a barra do FortReport e vejam como estão os icones.

erro.jpg

Share this post


Link to post
Share on other sites
1 hora atrás, MARCOS ROBERTO RODRIGUES disse:

Bom dia , estou com um problema e talvez vcs possam me ajudar, vou contar o que fiz, formatei meu computador e instalei o Delphi 7 com os componentes Acbr, FastReport e QuickReport. Até ai tudo bem, mas resolvi também instalar nessa máquina o Delph Xe8 porque estamos começando a mudar nosso programa, pois bem, instalei o componente FortReport e Acbr porém meus ícones nesses componentes não parecem a imagem correta . Olhem a barra do FortReport e vejam como estão os icones.

erro.jpg

Caso não tenha lido as regras do fórum favor ler!

pode ser bloqueado por ficar postando a mesma coisa em vários locais!

já respondi no outro local que tu postou


Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

Share this post


Link to post
Share on other sites

Sim eu respondi lá no outro tópico que tu duplicou!

tu tem dois delphi vá no blog do isaque e leia como ter dois delphi  no mesmo S.O.


Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

Share this post


Link to post
Share on other sites
Em 24/09/2015 at 16:10, Régys Silveira disse:

Existe algum pacote antigo em algum lugar do PATH, precisa limpar todos os drives de disco.

olá Regis, sou novo em uso do ACBR e na última atualização que tentei fazer tive erros semelhantes ao do Lucas, porém não sei  qual o procedimento  para limpar os drivers de disco.Qual seria a sequência do procedimento por gentileza?

  • Like 1

Share this post


Link to post
Share on other sites
6 minutos atrás, D'aglê Anderson disse:

olá Regis, sou novo em uso do ACBR e na última atualização que tentei fazer tive erros semelhantes ao do Lucas, porém não sei  qual o procedimento  para limpar os drivers de disco.Qual seria a sequência do procedimento por gentileza?

Bom dia, D'aglê Anderson.

esse tópico é antigo. Sugiro que pesquise antes a sua dúvida, caso não encontre aqui no fórum, peço para que crie um novo tópico relatando o seu problema.


Equipe ACBr

Felipe Eduardo Resende Mesquita

Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

 

 

 

Share this post


Link to post
Share on other sites
  • Este tópico foi criado há 723 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui
Guest
This topic is now closed to further replies.

×
×
  • Create New...