Jump to content

dev botao

Analisar para Alterar S1200 natAtividade


EdmarFrazao
Go to solution Solved by EdmarFrazao,
  • Este tópico foi criado há 2231 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Quando estamos enviado o

    // o grupo abaixo corresponde apenas a trabalhadores cuja categoria não está sujeita ao evento de admissão
    // ou TSV-início
    evtRemun.ideTrabalhador.infoComplem.NmTrab       := DMeSocial.adst_FOCADAUT.FieldByName('NOME_AUT').AsString;
    evtRemun.ideTrabalhador.infoComplem.DtNascto     := DMeSocial.adst_FOCADAUT.FieldByName('DATA_NAS').AsDateTime;
    evtRemun.ideTrabalhador.infoComplem.codCBO       := '317110';
    //evtRemun.ideTrabalhador.infoComplem.qtdDiasTrab  := 30;

 

Este campo so deve ser informado

    //evtRemun.ideTrabalhador.infoComplem.NatAtividade := navUrbano;

 

Natureza da atividade, conforme opções abaixo:
1 - Trabalho Urbano;
2 - Trabalho Rural.
Validação: O campo deve ser preenchido apenas se atendida uma das
condições a seguir apresentadas:
a) a classificação tributária for igual a [06, 07, 08];
B) a classificação tributária for igual a [21,22] e exista remuneração para o
trabalhador vinculada a um CAEPF de atividade rural;
Valores Válidos: 1, 2.

Como fazer esta regra pces1200 linha, o campo "natAtividade" , sugestão, talvez deveria ter um opção de não informar.

assim teria  tpNatAtividade          = (navUrbano, navRural,NaoInformar);

 

Link to comment
Share on other sites

  • Consultores

Bom dia Edmar,

Desculpe, não consegui entender o que esta ocorrendo e qual é a sua sugestão, esta muito confuso.

Consultor SAC ACBr

Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Araraquara - A era dos Trólebus

Link to comment
Share on other sites

@Italo Jurisato Junior

tpNatAtividade          não pode ser informado quando:

Validação: O campo deve ser preenchido apenas se atendida uma das
condições a seguir apresentadas:
a) a classificação tributária for igual a [06, 07, 08];
B) a classificação tributária for igual a [21,22] e exista remuneração para o
trabalhador vinculada a um CAEPF de atividade rural;

 

Como a condição não esta na classe, acho que deveriamos ter uma outra propriedade para informar que não dever se preenchido.

assim teria:

  tpNatAtividade          = (navUrbano, navRural,NaoInformar);

Link to comment
Share on other sites

8 minutos atrás, EdmarFrazao disse:

@Italo Jurisato Junior

tpNatAtividade          não pode ser informado quando:

Validação: O campo deve ser preenchido apenas se atendida uma das
condições a seguir apresentadas:
a) a classificação tributária for igual a [06, 07, 08];
B) a classificação tributária for igual a [21,22] e exista remuneração para o
trabalhador vinculada a um CAEPF de atividade rural;

 

Como a condição não esta na classe, acho que deveriamos ter uma outra propriedade para informar que não dever se preenchido.

assim teria:

  tpNatAtividade          = (navUrbano, navRural,NaoInformar);

Bom dia.. Edmar tem razão, inclusive existem outros eventos como o 2206, 2300, 2306 que tbm usam o campo NatAtividade que só devem ser montados observando as validações.. Hoje esses campos são montados sempre, aí vai gerar inconsistências no esocial..

Edited by Joceandro Perin
Link to comment
Share on other sites

  • Consultores

Edmar e Joceandro,

O tipo tpNatAtividade agora tem o valor navNaoInformar.

Para que a tag <natAtividade> não seja gerada é preciso atribuir o valor acima ao campo respectivo campo.

Por favor atualizem os fontes e façam novos testes.

Consultor SAC ACBr

Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Araraquara - A era dos Trólebus

Link to comment
Share on other sites

3 minutos atrás, Italo Jurisato Junior disse:

Edmar e Joceandro,

O tipo tpNatAtividade agora tem o valor navNaoInformar.

Para que a tag <natAtividade> não seja gerada é preciso atribuir o valor acima ao campo respectivo campo.

Por favor atualizem os fontes e façam novos testes.

Obrigado Italo, vou sincronizar e fazer os testes..

Link to comment
Share on other sites

30 minutos atrás, Italo Jurisato Junior disse:

Edmar e Joceandro,

O tipo tpNatAtividade agora tem o valor navNaoInformar.

Para que a tag <natAtividade> não seja gerada é preciso atribuir o valor acima ao campo respectivo campo.

Por favor atualizem os fontes e façam novos testes.

Italo, não consegui sincronizar, deu um erro, aí tentei excluir todo o diretório e sincronizar novamente, o erro persiste..

Screenshot_1.png.71f4748f1ed4581660612dcab30979cb.png

Link to comment
Share on other sites

  • Solution

o site e social continua instável

a Tag foi gerada com "0"

faltou corrigir  linha 848, so gerar se não for "navNaoInformar "

if ideTrabalhador.infoComplem.natAtividade=navNaoInformar then
  else
   Gerador.wCampo(tcStr, '', 'natAtividade',  1,  1, 0, eSNatAtividadeToStr(ideTrabalhador.infoComplem.natAtividade));

 

pcesS1200.pas

Link to comment
Share on other sites

  • Consultores

Boa tarde Edmar,

Muito obrigado pela colaboração assim que possível estarei enviando para o repositório.

Consultor SAC ACBr

Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Araraquara - A era dos Trólebus

Link to comment
Share on other sites

  • 1 month later...

Bom dia,

Pelo que vi no manual as informações complementares não são obrigatórias, no meu caso não estou informando e o componente está gerando uma exceção, pois como não informo a propriedade 

pInfoComplCont é igual a NIL.

Ela só deveria ser obrigatória no caso do trabalhador não tivesse o vinculo empregatício TSVE como diz no manual.

image.thumb.png.a13f1bf7d16ad34bac08eeb226812237.png

 

image.png.2b140a0bccfd50c2b6dbd6eca568ee97.png

image.thumb.png.6cc732880be62ece39f90a5e5c7cb28b.png

Link to comment
Share on other sites

47 minutos atrás, Jonathan Fabricio Seibel disse:

Bom dia,

Pelo que vi no manual as informações complementares não são obrigatórias, no meu caso não estou informando e o componente está gerando uma exceção, pois como não informo a propriedade 

pInfoComplCont é igual a NIL.

Ela só deveria ser obrigatória no caso do trabalhador não tivesse o vinculo empregatício TSVE como diz no manual.

image.thumb.png.a13f1bf7d16ad34bac08eeb226812237.png

 

image.png.2b140a0bccfd50c2b6dbd6eca568ee97.png

image.thumb.png.6cc732880be62ece39f90a5e5c7cb28b.png

Bom dia Jonathan, peguei essa situação hj pela manhã e relatei neste tópico 

 Enviei as units de correção para o Italo subir ao SVN..

Link to comment
Share on other sites

  • Este tópico foi criado há 2231 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.