Jump to content

Delphi chamada_delphi.png acbr.png

C6 chamada_c6.png botao.png

NFC-e 4.00 - Dúvidas referente ao período de Produção e Desativação


  • Este tópico foi criado há 1449 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Bom dia a todos!

 

Estou com uma dúvida, possivelmente é questão de interpretação, mas se puderem me auxiliar, lhes agradeço.

 

Temos duas datas de período de desativação da versão 3.10.

 

 

Prazos para alteração

As alterações aplicam-se somente às NFC-es emitidas na versão 4.00 ou superior do XML. Haverá um período de concomitância entre as versões 1.00 e 2.00 do QR Code, no qual ambos os formatos poderão ser utilizados. Confira.

 

A Sefaz publicou novos prazos para entrada do NFC-e em produção e desativação do layout 3.10 através da NT2016.002_1.41.

Abaixo, segue o cronograma de migração para a NFC-e 4.0:

• AMBIENTE DE HOMOLOGAÇÃO – 20/11/2017: neste período ocorre o início dos testes para homologação dos programas emissores de NF-e. É nesta fase que as empresas especializadas em softwares de emissão de notas irão iniciar os testes de homologação da nova versão;

• AMBIENTE DE PRODUÇÃO – 04/12/2017: Início da emissão de NF-e pela versão 4.0. Aqui será possível emitir notas fi scais nas duas versões simultaneamente, ou seja, será opcional a migração para a nova versão;

Desativação da NFC-e 3.1
• DESATIVAÇÃO DA VERSÃO ANTERIOR – 02/07/2018: Data limite para migração de versão. A partir deste dia, só será possível emitir NF-e na versão 4.0, sendo o layout 3.1 desativado.

 

Manual de Especificações Técnicas do DANFE NFC-e e QR Code - Versao 5.0
Manual de Padrões Técnicos do DANFE-NFC-e e QR Code - Versão 5.0 - Fevereiro de 2018

  • 04/06/2018 - Início da homologação da versão 4.00 do XML para a NFC-e  

  • 02/07/2018 – Início da produção da versão 4.00 do XML para a NFC-e – início da concomitância com a versão 1.00 do QR Code (a versão 4.00 do XML da NFC-e aceitará as versões 1.00 e 2.00 do QR Code)

  • 01/10/2018 – Desativação da versão 3.10 do XML para a NFC-e  

  • 01/10/2018 – Fim da concomitância com a versão 1.00 do QR Code (a versão 4.00 do XML da NFC-e aceitará somente a versão 2.00 do QR Code)

 

Esse manual refere-se especificamente ao Qr Code, pois a desativação da NFC-e 3.10 prevalece a data de 02/07/2018? 

 

Foram essa a interpretações de vocês?

 

Desde já antecipo agradecimentos,

 

Nilton Olher

 

 

 

______________________________________________________

Nilton Olher Serafim
Analista de Sistema - Inovação Tecnologia 
Skype: nolher
Link to comment
Share on other sites

Em 07/03/2018 at 09:26, nolher disse:

Esse manual refere-se especificamente ao Qr Code, pois a desativação da NFC-e 3.10 prevalece a data de 02/07/2018? 

 

Foram essa a interpretações de vocês?

No meu entendimento, NFC-e 4.0 já está em produção a muito tempo (NT_2016_002_V1.41, produção 04/12/2017), apesar das SEFAZ não estarem cumprindo o prazo estipulado pelo próprio governo. Mas houveram pequenas modificações como a NT_2016_002_v1.42, onde essas modificações entraram em vigor em produção em 22/01/2018, agora estão modificando novamente a versão da NFC-e 4.0 (que já está em produção), com essa questão do QR-CODE 2.0, com novos prazos para essas modificações que é para entrar em produção em 02/07/2018, e ainda adiando o término da versão da NFC-e 3.10 para 01/10/2018.

O complicado que vejo nessa confusão toda é que a SEFAZ de MT já está se abraçando com a nova nota técnica para ter a desculpa que não tem ambiente de produção funcionando atualmente, que é um absurdo. Conforme esse entendi nesse post:

 

Link to comment
Share on other sites

  • 2 months later...

Utilizo ao ACBrMonitor PLUS e tenho a seguinte dúvida relacionada ao tópico que apresenta dúvidas sobre o período de produção e desativação da versão 3.10.

Supondo que eu decida utilizar a versão 4.0 somente para a emissão de NF-e e continue utilizando a versão 3.10 para NFC-e por mais algum tempo...
Configuro o campo "Versão NFe" do ACBr para 4.00.

Em minha aplicação como posso emitir uma NFC-e na versão 3.10 se o ACBr está configurado para 4.00?

Eu teria que modificar o arquivo ACBrMonitor.ini programaticamente, quando for emitir uma NF-e e uma NFC-e?

[WebService]
Versao=4.00

Desde já agradeço qualquer contribuição.

Link to comment
Share on other sites

  • Este tópico foi criado há 1449 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.