Jump to content

LANÇAMENTO
Curso Completo - Dominando o ACBrMonitor

Conheça o Curso

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Renan S

Distribuição de Documentos Fiscais | Erro no SSL/TLS

Recommended Posts

Boa tarde pessoal;

Estou realizando a implementação da Distribuição de Documentos Fiscais Eletrônicos; com o componente ACBrNFE está configurado para usar a SSL_Type LT_TLSv1_2; simplesmente é gerado uma excpetion com o erro de:
nfedfe.PNG.3696b573fbf066db4f08bd80243047be.PNG
Quando altero o SSL_Type para LT_SSLv2; funciona perfeitamente;

Alguém saberia me dizer se isso pode ser problema na Sefaz que não atualizou o servidor para aceitar o TLS ou pode ser algo no ACBr (menos provável);

 

Desde de já,
Obrigado a todos!

Edited by Renan Silva

Share this post


Link to post
Share on other sites
26 minutos atrás, Renan Silva disse:

Boa tarde pessoal;

Estou realizando a implementação da Distribuição de Documentos Fiscais Eletrônicos; com o componente ACBrNFE está configurado para usar a SSL_Type LT_TLSv1_2; simplesmente é gerado uma excpetion com o erro de:
nfedfe.PNG.3696b573fbf066db4f08bd80243047be.PNG
Quando altero o SSL_Type para LT_SSLv2; funciona perfeitamente;

Alguém saberia me dizer se isso pode ser problema na Sefaz que não atualizou o servidor para aceitar o TLS ou pode ser algo no ACBr (menos provável);

 

Desde de já,
Obrigado a todos!

Boa tarde, Renan Silva.

Verifique esse tópico:

 


Equipe ACBr

Felipe Eduardo Resende Mesquita

Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

 

 

 

Share this post


Link to post
Share on other sites
2 horas atrás, Felipe E. Resende Mesquita disse:

Boa tarde, Renan Silva.

Verifique esse tópico:

 

Não sei se entendi muito bem ao certo; mas o topico fala sobre o TLS 1.2 no OpenSSL; mas estou usando o WinCrypt com o componente configurado para a 4.00; 

Share this post


Link to post
Share on other sites

Qual a versão do Sistema Operacional? 

O Windows 7 e 8.1 precisam estar atualizados para o funcionamento da versão 4.0 com TLS 1.2 usando a WinCrypt.

Share this post


Link to post
Share on other sites

Apenas uma consideração. É possível que o webservice de distribuição ainda não esteja compatível com TLS 1.2. Tive os mesmos problemas aqui, atualmente estou usando WinCrypt  e pra resolver o problema tive que alterar o SSLType para LT_all quando tentar utilizar este serviço. Utilizo Windows 10 atualizado.

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...