Jump to content

Delphi Enterprise 
pela METADE DO PREÇO

botao_delphi.png

 

 

tp_550_logo.png Homologação ACBr Apresenta:
Nova  Impressora
TP-550

botao_saibamais.png

 

 

Curso Dominando o ACBrMonitor
Novo Módulo Soluções de Varejo
Assine o SAC ACBr em qualquer plano e tenha acesso

Saiba Mais

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba Mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Felipe Mesturini

NFS-e Retorno provedor IPM

  • Este tópico foi criado há 357 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

Boa tarde,

Estou fazendo a integração com o Webservice do provedor IPM, consegui autorizar as notas tudo certinho, meu problema está no retorno, pois para os outros provedores pego o XML através do componente, e ele me retorna o XML da nota para inputar no banco.

Para este provedor ele retorna o XML com tags HTML junto da nota, gostaria de saber se existe outra possibilidade para pegar somente o XML puro da NFS-e ou preciso montar este XML manualmente.

Obtenho o XML da nota usando a seguinte propriedade FNfse.ACBrNFSe.NotasFiscais.Items[0].NFSe.XML.

Tentei usar da forma abaixo mais o XML não fica completo, faltam algumas tags, no nó <nf>.

Obtenho o XML da nota usando a seguinte propriedade FNfse.ACBrNFSe.NotasFiscais.Items[0].XML.

Se alguém tiver uma ideia do que posso estar fazendo de errado.

Desde já agradeço.

 

Share this post


Link to post
Share on other sites

Bom dia, 

Assim como o colega Felipe mencionou acima estou enfrentando o mesmo problema com o provedor IPM.

A nota autoriza tudo certo, imprime, gera pdf no momento do envio, porém ao salvar o xml de retorno este não possui as tags de protocolo e código de verificação assim como aconte com a nfe e nfce.

Então quando é feito a reimpressão, pdf ou envio de e-mail a partir deste xml algumas informações como o código de verificação ficam em branco no DANFS-e.

Já trabalhei com o componente do acbr NFSe para o provedor Tecnos e sempre funcionou certo, acredito que seja um problema do provedor IPM.

Se alguém já passou por este problema ou possa nos ajudar, ficaria muito grato.

Share this post


Link to post
Share on other sites
  • Este tópico foi criado há 357 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...