Jump to content

Delphi chamada_delphi.png acbr.png

C6 chamada_c6.png botao.png

Acess Violation ao Assinar a NFC-e


  • Este tópico foi criado há 987 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Olá boa tarde pessoal do fórum, estou tendo problemas pra assinar a NFC-e no meu software, estava funcionando normalmente 

se eu colocar uma versão antiga do meu software funciona, mais na versão atual estou recebendo um acess violation na hora de assinar na linha: 

XmlAss := FSSLXmlSignClass.Assinar( ConteudoXML, docElement, infElement,
                                        SignatureNode, SelectionNamespaces,
                                        IdSignature, IdAttr);

na Unit: ACBrDFeSSL. 

 

 

Link to comment
Share on other sites

  • Moderadores
38 minutos atrás, CarvilhePedro disse:

Olá boa tarde pessoal do fórum, estou tendo problemas pra assinar a NFC-e no meu software, estava funcionando normalmente 

Boa tarde, informe as configurações que está usando no componente... e também a tua IDE, versão do Windows...

Att

Ricardo

Link to comment
Share on other sites

1 minuto atrás, RicardoVoigt disse:

Boa tarde, informe as configurações que está usando no componente... e também a tua IDE, versão do Windows...

Att

Ricardo

Delphi 10.3 Comunity Edition, Windows 10 pro, Versão mais atualizada da pasta ACBr do SVN. 

LibOpenSSL
LT_TLSv1_2
xsLibXml2
cryOpenSSL
httpOpenSSL

Certificado A1
Ambiente: Homologação
 

 

Link to comment
Share on other sites

11 minutos atrás, RicardoVoigt disse:

Boa tarde, informe as configurações que está usando no componente... e também a tua IDE, versão do Windows...

Att

Ricardo

Detectei o erro está ocorrendo na real na linha: 

SignResult := xmlSecDSigCtxSign(FdsigCtx, SignNode);

Na unit: ACBrDFeXsXmlSec

Link to comment
Share on other sites

  • Moderadores
16 minutos atrás, CarvilhePedro disse:

Detectei o erro está ocorrendo na real na linha: 

SignResult := xmlSecDSigCtxSign(FdsigCtx, SignNode);

Na unit: ACBrDFeXsXmlSec

Tente rodar novamente o instalador, verificando se estão DESMARCADAS as devidas opções  "Não utilizar OpenSSL", ... conforme tua necessidade... de repente ficou algo errado na instalação...  e tente também marcar a opção "Remover arquivos antigos..."

Att

Ricardo

  • Like 1
Link to comment
Share on other sites

  • Este tópico foi criado há 987 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.