Jump to content

Delphi Enterprise 
pela METADE DO PREÇO

botao_delphi.png

 

 

tp_550_logo.png Homologação ACBr Apresenta:
Nova  Impressora
TP-550

botao_saibamais.png

 

 

Curso Dominando o ACBrMonitor
Novo Módulo Soluções de Varejo
Assine o SAC ACBr em qualquer plano e tenha acesso

Saiba Mais

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba Mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Gr@c@

Delphi 10.3.2-Object Repository(copy)

  • Este tópico foi criado há 254 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

Não consigo dar copy em formulário salvo no Object Repository. Isso não ocorria no Delphi XE3. Já segui os passos do help da Embarcadero, mas ainda não encontrei o que tenho realmente que fazer. E o suporte da Embarcadero no Brasil é apenas para instalação do Delphi. O nome do form salvo no Object repository é Dangra.View.Cadastro.pas e não Dangra.View.pas, mas também ocorre com forms com nomes simples como FrmCadastro.pas. Alguma sugestão?  

 

Sem título.png

Share this post


Link to post
Share on other sites

parece ser um bug da IDE... verifique se não é o caso de Paths longos ou com espaços...

Em todo caso... Copy não seria uma má prática ? afinal você teria código repetido...

  • Like 2

Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Share this post


Link to post
Share on other sites

Coloquei todas as permissões na pasta Embarcadero. Agora consigo o inherit, use ou copy desde que o nome do form não contenha os pontos. Pelo jeito, o problema está na nomenclatura projeto.view.form.pas. Alterando para projetoviewform.pas dá certo. Apesar da permissão ter resolvido em parte, ainda parece haver um bug da IDE. 

  • Like 2

Share this post


Link to post
Share on other sites
  • Este tópico foi criado há 254 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...