Jump to content

click.png

click.png

click.png

acbr-logo.png


Somente este mês: Assine o ACBr Pro 
e Ganhe um DEV KIT do SAT-CARE

Saiba Mais

CARE_EFEITOS.png

 

Erro HTTP: 500 ao fazer o teste do status


Recommended Posts

  • Usuários SAC

ACBr MonitorPLUS Ver.1.3.0.330 - x64
Aguardando comandos ACBr
Monitorando Comandos TXT em: /opt/ACBrMonitor/ENT.TXT
Respostas gravadas em: /opt/ACBrMonitor/SAI.TXT
Log de comandos será gravado em: /opt/ACBrMonitor/LOG.TXT
EACBrDFeException - WebService Consulta Status serviço:
- Inativo ou Inoperante tente novamente.
Erro Interno: 0
Erro HTTP: 500
URL: https://nfe-homologacao.sefazrs.rs.gov.br/ws/NfeStatusServico/NfeStatusServico4.asmx
WebService Consulta Status serviço:
- Inativo ou Inoperante tente novamente.
Erro Interno: 0
Erro HTTP: 500
URL: https://nfe-homologacao.sefazrs.rs.gov.br/ws/NfeStatusServico/NfeStatusServico4.asmx

 

Esta é a saída completa do erro no console ele não gera nenhum log:

acbr.png

Link to post
Share on other sites
  • Fundadores

Não parece ser erro de carga da OpenSSL..

Como você configurou a DFeSSL ?
https://acbr.sourceforge.io/ACBrMonitor/Certificados.html

Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to post
Share on other sites
  • Usuários SAC

Alterando para TLSv1_2 , segue o mesmo erro:

 

Respostas gravadas em: /opt/ACBrMonitor/SAI.TXT
Log de comandos será gravado em: /opt/ACBrMonitor/LOG.TXT
EACBrDFeException - WebService Consulta Status serviço:
- Inativo ou Inoperante tente novamente.
Erro Interno: 0
Erro HTTP: 500
URL: https://nfe-homologacao.sefazrs.rs.gov.br/ws/NfeStatusServico/NfeStatusServico4.asmx
WebService Consulta Status serviço:
- Inativo ou Inoperante tente novamente.
Erro Interno: 0
Erro HTTP: 500
URL: https://nfe-homologacao.sefazrs.rs.gov.br/ws/NfeStatusServico/NfeStatusServico4.asmx

Link to post
Share on other sites
  • Fundadores

Verifique se Firewall, algum outro bloqueio, existe nessa máquina...

Verifique ainda, se há Proxy, e se sim, configure o mesmo, no ACBrMonitorPLUS

Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to post
Share on other sites
  • Usuários SAC

O erro no firefox era por conta do certificado segue o acesso a url no chome onde está o certificado instalado:

Obs: por eu instalar no ubuntu e ter gerado aqui o .deb, não teria quebrado alguma coisa?

Obrigado o retorno

 

 

 

os ultimos Logs:

 

18/11/2020 19:49:25 - Dados da Sw.House gravados com sucesso
18/11/2020 19:49:25 - Configuração geral gravada com sucesso
18/11/2020 19:49:25 - ACBr MonitorPLUS Ver.1.3.0.330 - x64
18/11/2020 19:49:25 - Aguardando comandos ACBr
18/11/2020 19:49:25 - Monitorando Comandos TXT em: /opt/ACBrMonitor/ENT.TXT
18/11/2020 19:49:25 - Respostas gravadas em: /opt/ACBrMonitor/SAI.TXT
18/11/2020 19:49:25 - Log de comandos será gravado em: /opt/ACBrMonitor/LOG.TXT
18/11/2020 19:49:38 - ACBr MonitorPLUS Ver.1.3.0.330 - x64
18/11/2020 19:49:38 - Aguardando comandos ACBr
18/11/2020 19:49:38 - Monitorando Comandos TXT em: /opt/ACBrMonitor/ENT.TXT
18/11/2020 19:49:38 - Respostas gravadas em: /opt/ACBrMonitor/SAI.TXT
18/11/2020 19:49:38 - Log de comandos será gravado em: /opt/ACBrMonitor/LOG.TXT
18/11/2020 19:49:55 - EACBrDFeException - WebService Consulta Status serviço:
- Inativo ou Inoperante tente novamente.
Erro Interno: 0
Erro HTTP: 500
URL: https://nfe-homologacao.sefazrs.rs.gov.br/ws/NfeStatusServico/NfeStatusServico4.asmx
18/11/2020 19:49:55 - WebService Consulta Status serviço:
- Inativo ou Inoperante tente novamente.
Erro Interno: 0
Erro HTTP: 500
URL: https://nfe-homologacao.sefazrs.rs.gov.br/ws/NfeStatusServico/NfeStatusServico4.asmx

 

 

 

 

 

 

 

ACBrMonitor.ini

Link to post
Share on other sites
  • Fundadores

Pode ser algo relacionado a OpenSSL 1.1.1...

Terei que debugar no Ubuntu... isso pode demorar alguns dias...

Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to post
Share on other sites
  • Fundadores

Ahh.. funcionou aqui... 

image.png

veja se você não tem algo errado na configuração do Certificado...

- Path e Case corretos
- Senha correta
- Acesso ao usuário (para efeito de testes, eu rodei como "root")
- Certificado Válido

Apenas para um teste rápido.. marque essa opção marcada abaixo.. e veja se a Razão Social do certificado, é exibida no Título da Janela

image.png

 

Encerre e abra novamente o ACBrMonitor, para que as configurações efetuadas, sejam lidas corretamente...

  • Like 1
Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to post
Share on other sites
  • Usuários SAC

Boa tarde fiz uma instalação zerada com o ubuntu 20.04 em outro pc, troquei o certificado, baixei novamente o instalador do site ...converti para .deb e aconte a mesma coisa. Voce me passa o intalador que usaste no teu sistema? existe suporte por acesso remoto? qual valor?

Obrigado

Captura de tela de 2020-11-19 17-24-00.png

Link to post
Share on other sites

Boa tarde, note que a versão do ACBrMonitor utilizado pelo Daniel é a mesma sua. O problema esta na comunicação e não no Aplicativo, pode ser algo com a lib OpenSSL do Linux ou algum bloqueio mesmo do SO.

Chegou a verificar a versão OpenSSL no Ubuntu?

Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to post
Share on other sites
  • Usuários SAC

Boa tarde fiz uma instalação zerada com o ubuntu 20.04 em outro pc, troquei o certificado, baixei novamente o instalador do site ...converti para .deb e aconte a mesma coisa. Voce me passa o intalador que usaste no teu sistema? existe suporte por acesso remoto? qual valor?

Obrigado

 

 

Mais um detalhe ....mandei rodar o teste de status no acbr e em paralelo rodei um netstat -a apareceu a seguinte saida , parecendo que a comunicação com o servidor de homologação está ok:

 

 

tcp        0      1 aurelio-Inspiron-:33790 nfe-homologacao.s:https ESPERA_FIN1
tcp        0      0 aurelio-Inspiron-:55478 stackoverflow.com:https ESTABELECIDA
tcp        0      0 aurelio-Inspiron-:52992 gru10s01-in-f130.:https ESTABELECIDA
tcp        0      0 aurelio-Inspiron-:47848 ec2-54-149-138-15:https ESTABELECIDA
tcp        0      0 aurelio-Inspiron-:48064 muc12s03-in-f3.1e:https ESTABELECIDA
tcp        0      0 aurelio-Inspiron-:56626 gru06s53-in-f2.1e:https ESTABELECIDA
tcp        0      0 aurelio-Inspiron-:51280 gru14s13-in-f2.1e:https ESTABELECIDA
tcp        0      0 aurelio-Inspiron-:57114 server-13-35-109-:https TIME_WAIT  
tcp        0      0 aurelio-Inspiron-:58938 eze03s36-in-f6.1e:https ESTABELECIDA
tcp        0      1 aurelio-Inspiron-:33762 nfe-homologacao.s:https ESPERA_FIN1
tcp        0      0 aurelio-Inspiron-:59390 172.217.192.154:https   ESTABELECIDA
tcp        0      0 aurelio-Inspiron-:50686 5.85.222.35.bc.goo:http TIME_WAIT  
tcp        0      0 aurelio-Inspiron-:33794 nfe-homologacao.s:https ESTABELECIDA

 

 

 

Link to post
Share on other sites
11 horas atrás, Aurelio Maica disse:

Voce me passa o intalador que usaste no teu sistema? existe suporte por acesso remoto? qual valor?

Acesso remoto não adiantaria visto que já está seguindo as recomendação de testes que estamos passando. O instalador a gente baixa do próprio fórum é o que todos usam... O que poderia fazer é disponibilizar sua VM do Ubuntu, para que possamos baixar aqui e tentar simular o problema por aqui, se se necessário instalar a IDE do Lazarus para depurar...

Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to post
Share on other sites
  • Usuários SAC

Boa tarde agradeço a atenção de todos. Problema solucionado. Acontecia que a libssl instalada do reposistorio (com apt-get) simplesmente não dava certo. Fiz outra instalação limpa do ubuntu 20.04Lts e instalei a lib ssl dos fontes neste link: https://www.howtoforge.com/tutorial/how-to-install-openssl-from-source-on-linux/

Obrigado

Link to post
Share on other sites
Guest
This topic is now closed to further replies.
×
×
  • Create New...