Jump to content

dev botao

Problema TACBrNFeDANFEFR.Create(nil);


Go to solution Solved by BigWings,
  • Este tópico foi criado há 1089 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Boa tarde

No meu sistema tenho um botão para visualizar a Danfe, e no meu computador está funcionando perfeitamente.

Coloquei no meu cliente, num computador com Windows Server 2012, e quando chega nessa linha:

NFeDANFEFR := TACBrNFeDANFEFR.Create(nil);

me retorna um Access Violation

Vi aqui no forum um problema assim de 2015, e foi solicitado que colocasse o componente no form ou no datamodule.

Acontece que a função acima está numa classe dentro de uma unit não visual, então eu adicionei as seguintes units manualmente:

ACBrNFeDANFEFR, ACBrDFeReport, ACBrDFeDANFeReport, ACBrNFeDANFEClass,
Mesmo assim retorna o Access Violation

Tentei colocar o componente no datamodule e tambem dá o access violation

Erro somente acontece no meu cliente, no meu computador funciona perfeitamente

Alguem sabe me dizer o motivo?

Obrigado

 

Link to comment
Share on other sites

  • Moderadores
  • Solution

Pode ser falta da MIDAS.DLL compatível na máquina.

Como esse componente usa o ClientDataSet, precisa distribuir a DLL ou adicionar a unit MidasLib no uses do seu projeto pra embeddar a mesma na sua aplicação.

  • Like 1
Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

  • Este tópico foi criado há 1089 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

The popup will be closed in 10 seconds...