Jump to content

dev botao

AcbrLib > Impressão > Preview NF-e


Go to solution Solved by Juliomar Marchetti,
  • Este tópico foi criado há 1063 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Boa tarde pessoa, estou com um problema na impressão de NF-e utilizando o preview do fortes, o problema em questão é idêntico ao desse tópico. Pelo que vi no tópico, parece ser a propriedade "AdjustableMargins" do próprio report que faz com a impressão não se ajuste as margens corretamente.

 

Isso está ocorrendo em apenas 1 cliente de nossos clientes, gostaria de saber se tem alguma coisa que possa fazer lá para resolver o problema.

Estou utilizando a compilação do acbrlib 0.4.6.102.

Desde já agradeço.

Link to comment
Share on other sites

  • Moderadores

Bom dia, 

No componente ou na lib essa configuração é feita através das configuraçoes de margem. Qual valor está configurado nas configurações ACBrLib.ini?

[DANFeNFe]

MargemInferior

Define a margem inferior da impressão.

MargemSuperior

Define a margem superior da impressão.

MargemEsquerda

Define a margem esquerda da impressão.

MargemDireita

Define a margem direita da impressão.

Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

2 horas atrás, José M. S. Junior disse:

Bom dia, 

No componente ou na lib essa configuração é feita através das configuraçoes de margem. Qual valor está configurado nas configurações ACBrLib.ini?

[DANFeNFe]

MargemInferior

Define a margem inferior da impressão.

MargemSuperior

Define a margem superior da impressão.

MargemEsquerda

Define a margem esquerda da impressão.

MargemDireita

Define a margem direita da impressão.

Bom dia, uso como padrão sempre 7 em todas as margens para  centralizar o DANFE no preview. O problema era que não estava acatando nenhum desses valores, independentemente do valor que informasse como margem.

Realizei mais alguns testes no cliente e a sugestão do Juliomar, de alterar a impressora padrão, funcionou perfeitamente.

Muito obrigado pessoal, tenham uma ótima semana.

Link to comment
Share on other sites

  • Este tópico foi criado há 1063 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

The popup will be closed in 10 seconds...