Jump to content

dev botao

Consulta de cadastro nao funciona, problemas com biblioteca OpenSSL


Go to solution Solved by antonio.carlos,
  • Este tópico foi criado há 499 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Olá a todos...

estou começando os estudo da NFe e estou utilizando o programa de exemplo.

porem estou com algumas duvidas:

eu peguei os arquivos de schema em:

http://svn.code.sf.net/p/acbr/code/trunk2/Exemplos/ACBrDFe/Schemas/NFe/

e gravei tudo em uma pasta SCHEMA dentro da pasta da aplicação:

image.thumb.png.f4eb88d47df594d42803ddfedc1334b7.png

(não tem um jeito mais fácil de baixar todos? Tem que ser um por um e salvar como?)

peguei as dll opensll em:

http://svn.code.sf.net/p/acbr/code/trunk2/DLLs/OpenSSL/1.1.1.10/X86/

e gravei na pasta da aplicação.

image.thumb.png.dd22bbcb20d4993759a85d0383c5e98b.png

peguei as dll em http://svn.code.sf.net/p/acbr/code/trunk2/DLLs/LibXml2/x86/

e gravei na pasta da aplicação

image.thumb.png.b6a90b1373de4ddae72406f4dffb019f.png

peguei o conteudo de http://svn.code.sf.net/p/acbr/code/trunk2/DLLs/Diversos/x86/ e gravei na pasta da aplicação:

image.thumb.png.ec2bb16170dc40ea2e9dc5ab683dd517.png

peguei a dll standcall e pus na pasta conforme o exemplo

image.png.2d4ed836690902575ea36e3b26ff4484.png

image.png.dd0b9c7d203bf5352a011b764f7c4790.png

 

as telas do DEMO estão assim:

image.thumb.png.f4a3a3bff67a12683884b17eb461bedc.png

image.thumb.png.743b85a8cd9ac29ebef8ec398e4d6133.png

image.thumb.png.9e78fad706f8a9ca9f8fbc1795782618.png

image.thumb.png.2ebf37aa0e0a31d02040cfd1a2306dd0.png

image.thumb.png.3dd965a305dfa963f1e600a8eefd05dc.png

image.thumb.png.2c0af92618a0c11a3b5fb1c25e2549da.png

Mas quando peço para consultar o cadastro, ele me pede a UF (SP) e o documento(20.412.065/0001-51) e quando confirmo ele me retorna isso:

image.png.45a83662a0b800fad2b12a42797b7c0f.png

o log tá assim:

12/10/22 20:59:40:139 - NFE_ConsultaCadastro(SP,20412065000151,False )
12/10/22 20:59:40:140 - Travar
12/10/22 20:59:40:144 - Destravar
12/10/22 20:59:40:145 -    SetRetorno(-10, 
Erro ao carregar bibliotecas do OpenSSL)
12/10/22 20:59:40:145 - LIB_UltimoRetorno
12/10/22 20:59:40:145 -    Codigo:-10, Mensagem:[CR][LF]Erro ao carregar bibliotecas do OpenSSL
12/10/22 21:01:49:101 - NFE_ConsultaCadastro(SP,20.412.065/0001-51,False )
12/10/22 21:01:49:101 - Travar
12/10/22 21:01:49:101 - Destravar
12/10/22 21:01:49:101 -    SetRetorno(-10, 
Erro ao carregar bibliotecas do OpenSSL)
12/10/22 21:01:49:101 - LIB_UltimoRetorno
12/10/22 21:01:49:101 -    Codigo:-10, Mensagem:[CR][LF]Erro ao carregar bibliotecas do OpenSSL

ontem, funcionou algumas vezes depois de dar esse mesmo erro. hoje já não funcionou mais....

onde estou errando?

Obrigado!

 

 

 

 

Edited by Marcelo Manoel da Silva
imagem errada
Link to comment
Share on other sites

9 horas atrás, Renato Rubinho disse:

Boa noite,

Nos dados do certificado preencha somente o caminho e a senha.

Não preencha dadosPfx e número de série.

Pesquise em todo o computador se tem outras dlls da OpenSSL espalhadas, pois podem estar sendo iniciadas por outra aplicação e gerando algum conflito.

Olá... sobre a questão dos certificados, fiz como vc falou e deu isso:

image.thumb.png.56d2b06dc82aa50105847a58fea968e3.png

e depois isso:

image.thumb.png.3787587532a7a90f35a9b80e7f1d3b57.png

 

 

Edited by Marcelo Manoel da Silva
Link to comment
Share on other sites

9 horas atrás, Renato Rubinho disse:

Boa noite,

Nos dados do certificado preencha somente o caminho e a senha.

Não preencha dadosPfx e número de série.

Pesquise em todo o computador se tem outras dlls da OpenSSL espalhadas, pois podem estar sendo iniciadas por outra aplicação e gerando algum conflito.

olha... pus o agente ransack para buscar e achei um monte:

image.thumb.png.ee10f52f93c79a1528873cab53dcf2a8.png

agora num sei se devo/posso apagar alguma delas... ou substituir...

e agora?

obrigado...

Link to comment
Share on other sites

  • Consultores
  • Solution
1 hora atrás, Marcelo Manoel da Silva disse:

olha... pus o agente ransack para buscar e achei um monte:

image.thumb.png.ee10f52f93c79a1528873cab53dcf2a8.png

agora num sei se devo/posso apagar alguma delas... ou substituir...

e agora?

obrigado...

Pode remover todas as dlls de dependências, mantenha as dllls de dependência junto com acbrlib que estiver utilizando e também na mesma versão.
ACBrLib x86, utilize as dlls dependências também em x86

Link to comment
Share on other sites

1 hora atrás, antonio.carlos disse:

Pode remover todas as dlls de dependências, mantenha as dllls de dependência junto com acbrlib que estiver utilizando e também na mesma versão.
ACBrLib x86, utilize as dlls dependências também em x86

Desculpe...
não entendi exatamente o que fazer.
(Tenho TEA (autismo) e às vezes preciso de explicações mais especificas)
Poderia tentar me explicar?

Quais dessas dll´s preciso apagar e quais devo manter?
apagando esas outras (avast, officce, one drive,) isso não vai atrapalhar outras aplicações?
quais dessas dll devem ficar e onde? dentro da pasta da aplicação ou junto com a ACBrNFe32.dll ?
Obrigado.

Link to comment
Share on other sites

vamos ver se entendi e  se fiz certo...

tirei as dll da pasta do DEMO e pus junto com a dll de nfe da acbr:

image.thumb.png.9bb0c6efb6dd3dbcfb02d478059c8d47.png

e mantendo tudo igual como estava antes, quando tento carregar os certificados aparece isso:

image.png.b0aa6518e40312d45c4c4be18fa711a4.png

e isso:

image.png.2bb13547ba2d1c5a2156b2663fe5e152.png

e quanto tento efetuar a consulta de cadastro aparece isso:

image.png.cb8088c57c6254bb8dc15ffb6424ff59.png

a senha é a de instalação do A1? pq ja ate reinstalei para ter certeza:
image.thumb.png.2955b8e70b76bc4aaa0870adee082fae.png

image.png.09869e72a719e0891861c7e8497b5161.png

image.png.4b79ea3f92391e2f136b3cf0d7f38da5.png

image.png.8211af1eb88ee7aa6900de9178415bda.png

image.png.3ebf6aed0be0833c0a947c8702b5a6e5.png

image.png.60cf28415c1879a7e7db06eb0385b43b.png

image.png.4cb1877bfdeda21a3f5d7da8e7f305cb.png

mesmo reinstalando para ter certeza da senha, o DEMO repete a mensagem de senha errada acima...

 

 

Link to comment
Share on other sites

Um detalhe...
os DADOS PFX, quando eu informo fica certinho...

image.thumb.png.4ebcff94c887e8318eb288ee8898353f.png

mas quando gravo, ele grava assim:

Citar

[DFe]
SSLCryptLib=1
SSLHttpLib=3
SSLXmlSignLib=4
UF=SP
TimeZone.Modo=0
TimeZone.Str=
URLPFX=
ArquivoPFX=
DadosPFX=DredeDesktopacbrNFEDEMOcertpfw==
Senha=GTgZSVA7Lw==
NumeroSerie=
VerificarValidade=1
 

image.thumb.png.e08e96dc5c08c91e3e69f0f5ff059f92.png

ele não ta gravando o caminho e o nome do arquivo corretamente...

 

Link to comment
Share on other sites

  • Consultores

se esta utilizando certificado A1, você vai apontar somente o caminho e a senha.
Não precisa preencher Dados PFX..
Mensagem de erro é clara, pode ser que tenha informado senha errada, apontou certificado a e colocou a senha do certificado b.

Fiz teste com programa exemplo, tudo certo:
image.png

Só mantive as dlls dependências junto com ACBrLibNFe, configurei certificado A1, apontando o caminho dele e a senha.
Apontei a pasta Schemas também..

  • Like 1
Link to comment
Share on other sites

  • Este tópico foi criado há 499 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.