Jump to content

hintz

Membros
  • Posts

    239
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

hintz's Achievements

Community Regular

Community Regular (8/14)

  • First Post
  • Collaborator Rare
  • Conversation Starter
  • Week One Done
  • One Month Later

Recent Badges

10

Reputation

5

Community Answers

  1. Estou implantado o meu sistema num windos 2012R. A intenção é acessar os terminais pela area remota do windows. No servidor tem uma impressora Elgin i9 instalada que funciona normalmente quando acessada pelo servidor. Tenho um pc com o win 10 onde esta insalada outra impressora Elgin i9. Compartilhei essa impressora instalei no win 2012 quando acesso a area de trabalho do win 2012 já esta configura. Quando emito uma NFCe nesse terminal tento imprimir com o seguinte comando: NFE.ImprimirDanfe(D:\ss\XML\NFCe\202204\NFCe\43220494428489000140650020000000371923716332-nfe.xml,\\Caixa2\Printer,1,,0,onLine,1) Só que em vez de imprimir na impressora que esta no terminal imprime na impressora que esta no servidor. Alguem pode me ajudar? Obrigado.
  2. Estou tentando homologar os boleto no Banco do Brasil: ACBrBoleto1.LayoutRemessa := c400 Quando informo a carteira 17 imprime 17/2, dai o banco do brasil rejeita. Como resolver? - - Outra questão: no boleto é impresso "Beneficiario Final" logo abaixo do Pagador. O banco do brasil que que imprima "Sacador/Avalista:" Com altero? Obrigado.
  3. Fiz isso tambem e não funcionou. with Imposto do begin if TabItensNota.FieldByName('nfIpiVlr').AsFloat <> 0 then begin pDevol := TabItensNota.FieldByName('nfIpiPerc').AsFloat; vIPIDevol := TabItensNota.FieldByName('nfIpiVlr').AsFloat; infAdProd := 'DEVOLUCAO MERCADORIA COM PROBLEMA'; end;
  4. Estou tentando fazer uma NFe de devolução (Empresa Simples Nacional) para outra empresa (NÃO Simples nacional). informo o seguinte: with Imposto do begin if TabItensNota.FieldByName('nfIpiVlr').AsFloat <> 0 then begin vIPIDevol := TabItensNota.FieldByName('nfIpiVlr').AsFloat; infAdProd := 'DEVOLUCAO MERCADORIA COM PROBLEMA'; end; e Total.IcmsTot.vIPIDevol := TabDadosNota.FieldByName('OutrasDesp').AsFloat; Porem no Item não grava as informações sobre o IPI. O que posso estar fazendo errado? Segue anexo o XML gerado. 43210192746882000157550010000077981140389261-nfe.xml
  5. Obs. Utilizo o comando append e post para gravar um item novo e o comando Edit e Post para atualizar a tabela de olho no imposto.
  6. Preciso de ajuda para um erro muito estranho. Já estou à quase uma semana tentando resolver o problema e não encontrei solução. Fiz muitas pesquisas na internet, mas nada resolveu. Uso o delphi xe8 com firebird 2.5.9. Estou usando o zeos 7.2.6-stable. Tenho um cadastro de produtos/itens que de vez em quando quando cadastro produtos, saio da tela de cadastro e o produto some. Quando vou atualizar a tabela de olho no imposto as vezes atualiza corretamente as vezes atualiza sómente alguns itens. Obs. quando estou atualizando e verifico num dbgrid, todos eles são atualizados. Se eu sair do programa e entrar novamente, somem praticamente todos.. propriedade do TZConnection: AutoCommit = true Protocol = firebird-2.5 TransactIsolationLevel = tiRepeatableRead - já usei o tiReadUncommitted e também não funcionou. Na TZQuery no Evento AfterPost: begin qItem.ApplyUpdates; qItem.CommitUpdates; end; Achei que era o Zeos e troquei para o Firedac. Aconteceu o mesmo problema. Achei que era o arquivo de dados corrompido: Criei um novo banco de dados e copiei as informações: O problema persiste. Alguem teria alguma ajuda??? Att. Hintz
  7. Essa eu não entendi.... No meu computador com win 10 a mesma versão funcionou. Compactei todo o diretorio AcbrMonitorPlus do meu computador e instalei no cliente, dai funcionou. Não entendi. Mas deu certo. Obrigado.
  8. Já fiz isso. Fiz uma nova instalação com pelo menos 3 versões diferentes e deu o mesmo problema.
  9. No caso é no Acbrmonitor Plus e a libxml2.exe esta no mesmo diretório. Só que no win 2012r da erro e no win 10 funciona normalmente.
  10. Após uma atualização do Acbrmonitor Plus no windows 2012 R Server começou a dar a seguinte mensagem de erro: Erro ao inicializar a Biblioteca LibXml2 Já apaguei tudo e instalei do zero novamente e o erro persiste. Já fiz todas as dicas que encontrei e mesmo assim não funcionou. Já rodei no modo administrador e também não funcionou. Fiz a mesma instalação no win 10 e deu certo. Acredito ser alguma coisa do windows 2012 r. O erro acontece quando vai validar uma NFCe. Alguém pode me ajudar??
  11. Não consegui nenhuma solução Pratica. Acabei alterando manualmente os campos da tabela. nas zQuery.
  12. Não. Eu ja tinha ele em delphi xe8 com win 10 em outra maquina, que deu problema. Comprei outro note e re-instalei tudo novamente.
  13. Encontrei: https://stackoverflow.com/questions/5679989/delphi-why-breakpoints-from-time-to-time-are-not-usable-green-highlighted-line No Delphi 2009, excluindo o arquivo .dproj, fiz os pontos de interrupção funcionarem novamente. Deu certo, também no XE8. Fiz isso também: As informações de depuração não estão presentes no arquivo. Verifique se você está usando a configuração de depuração. ( Project Managerarborize, expanda Build Configurations, verifique se Debugestá em negrito. Se não estiver, clique com o botão direito do mouse Debuge escolha Activateno menu de contexto.) Certifique-se de fazer uma compilação do seu projeto, não apenas uma compilação . Se isso ainda não funcionar, vá para Project->Optionso menu principal do IDE, clique em Compilingabaixo Delphi Compilere verifique a Debuggingseção na metade direita da janela. Certifique-se de que Debug Informatione Local Symbolsestão marcadas. Se você estiver tentando rastrear a origem do próprio VCL, verifique também Use debug .dcus(você deseja desativar isso e fazer uma compilação completa do seu projeto assim que terminar, pois fica irritante quando você está depurando normalmente ) Novamente, você desejará criar e não compilar. Se tudo isso falhar, outra possibilidade é que a unidade de código que você abriu no Editor de Código não seja a mesma que está sendo vista pelo compilador. Verifique se você não possui várias cópias do arquivo no seu computador em um local que o compilador possa encontrar primeiro. Se você não tiver certeza, exclua os arquivos .dcu com esse nome de unidade e faça uma compilação do seu projeto e verifique se o .dcu recém-criado está no local esperado. E deu certo. Obrigado.
  14. em qualquer lugar. Já testei vários lugares e em vários Forms inclusive no form principal onde obrigatoriamente esta ok. e em nenhum lugar funciona.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.