Jump to content

Fernando Kerber

Membros
  • Content Count

    73
  • Joined

  • Last visited

Community Reputation

31 Excellent

4 Followers

About Fernando Kerber

  • Rank
    Membro
  • Birthday 04/20/1993

Profile Information

  • Sexo
    Masculino
  • Localização
    Concórdia SC

Recent Profile Visitors

  1. Bom dia pessoal. Me desculpem por abrir o tópico novamente, mas agora o erro: Está dando na hora de transmitir também. Até ontem eu estava emitindo normal, hoje parou de funcionar. Alguém sofrendo com o mesmo problema ao tentar transmitir NFC-e do Ceará pelo integrador? Muito obrigado.
  2. Bom dia. Muito Obrigado @Daniel Simoes, e lembrando pra quem for implementar o MFE do Ceará sem o integrado. A opção de envio via DLL funciona apenas para Envio, Cancelamento e Inutilização, se foi enviar o pagamento POS tem que ter o integrador rodando pois ainda usa ele. Obrigado.
  3. Bom dia, A emissão segue igual à da NFC-e, a unica coisa que muda é que tem que associar o componente Integrador ao ACBrNFe a partir dai então ele usa o integrador para fazer a emissão.
  4. Muito Obrigado @Juliana Tamizou
  5. Bom dia. No Tópico (que já está fechado) Foi disponibilizado um PDF contendo a ER 02.06 com as mudanças marcadas em amarelo, porém o link não funciona mais. Alguém poderia me passar novamente?? Muito obrigado.
  6. Boa tarde @André Ferreira de Moraes Atualizei meus fontes e deu certo. Muito obrigado.
  7. Boa tarde @DanielSantos. Pois é então teria que rever com o SEFAZ do Ceará porque realmente se eu mudo para 4.00 funciona mas se eu deixo 1.00 da o retorno citado no tópico a cima. Obrigado pela compreensão mas o que está na documentação não é fiel com o que o servidor realmente está recebendo.
  8. Então, Debugando dentro do componente, descobri que meu erro foi que eu não estava alimentando a "NotasFiscais.add" antes de efetuar o cancelamento. Realmente o se eu coloco a versão 4.00 ali funciona. Obrigado @eduardo.mrj vamos aguardar se vão ajustar no componente.
  9. Bom dia. Estou com o mesmo problema. Mudei a versão de 1.00 para 4.00 e continua o mesmo erro, @eduardo.mrj você fez mais alguma alteração?
  10. Desculpem meu erro, mas corrigi o problema liberando o Firewall, as portas da minha rede e atualizando as DLLs na pasta do integrador, a minha confusão foi porque eu estava copiando apenas a IntegradorNFCE.dll e tem que copiar todas as DLLs do arquivo que esse link descreve: https://www.djpdv.com.br/como-emitir-nfc-e-usando-o-integrador-fiscal/ Obrigado.
  11. Boa tarde. No Exemplo do ACBr eu informo o componente do integrador no ACBrNFe, com o Integrador instalado e atualizado, a dll IntegradorNFCE.dll está na pasta "%APPDATA%\Integrador" e os dados no integrador estão corretos e está dando o mesmo problema. Poderia me explicar como proceder pra corrigir? Obrigado.
  12. Boa tarde pessoal. Fazendo alguns testes aqui consegui resolver o erro mudando a linha RespostaPagamentoMFe := TACBrSATMFe_integrador_XML(ACBrSAT1.SAT).EnviarPagamento(PagamentoMFe); para RespostaPagamentoMFe := ACBrIntegrador1.EnviarPagamento(PagamentoMFe); ai o access violation não acontece mais. Se caso queiram dar uma olhada no componente eu agradeço. Obrigado
  13. Boa tarde. Não estou conseguindo debugar porque ele só carrega a DLL se eu executo por fora do delphi. Usando Showmessage identifiquei que o Acess violation acontece quando vai alimentar o TRespostaPagamento com o retorno do TEnviaPagamento. procedure TForm1.btMFEEnviarPagamentoClick(Sender: TObject); var PagamentoMFe : TEnviarPagamento; RespostaPagamentoMFe : TRespostaPagamento; begin PagamentoMFe := TEnviarPagamento.Create; try with PagamentoMFe do begin Clear; ChaveAcessoValidador := '25CFE38D-3B92-46C0-91CA-CFF751A82D3D'; ChaveRequisicao := '26359854-5698-1365-9856-965478231456'; Estabelecimento := '10'; SerialPOS := InputBox('SerialPOS','Informe o Serial do POS','ACBr-'+RandomName(8)); CNPJ := edtEmitCNPJ.Text; IcmsBase := 0.23; ValorTotalVenda := 1530; HabilitarMultiplosPagamentos := True; HabilitarControleAntiFraude := False; CodigoMoeda := 'BRL'; EmitirCupomNFCE := False; OrigemPagamento := 'Mesa 1234'; end; RespostaPagamentoMFe := TACBrSATMFe_integrador_XML(ACBrSAT1.SAT).EnviarPagamento(PagamentoMFe); //Aqui ShowMessage(IntToStr(RespostaPagamentoMFe.IDPagamento)); finally PagamentoMFe.Free; end; end; A Função de Enviar pagamento passa normal o problema esta quando o "RespostaPagamentoMFe" recebe o que ela retorna. Poderiam verificar por favor? Muito obrigado.
  14. Boa tarde @Juliana Tamizou tudo bem? Estou com o mesmo problema citado a cima. Eu tenho o integrador instalado, ele está aberto e mesmo assim o erro acontece, estou utilizando a dll que o próprio integrador disponibiliza na pasta onde foi instalado: "C:\Program Files (x86)\SEFAZ-CE\Driver MFE\Biblioteca de funções\mfe.dll". O Drive que eu estou usando é a versão 01.05 (Comunicação direta) baixei direto da página de dowloads do SEFAZ-CE, porém esse drive não comunica com o integrador, para isso tem que usar a versão do drive 01.04 que não comunica com a DLL, eu não consigo utilizar as duas ferramentas juntas, teria alguma forma de fazer isso? Obrigado.
  15. Quando tento enviar imagem pelo ACBrMail acontece a mesma coisa, a imagem não vai, como eu faço essa questão do inline?
×
×
  • Create New...