Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

clube mobile


Cursos grátis para toda base ACBr
+ Promoção Clube Mobile para o ACBr Pro

Saiba mais

adriano santos

click.png

click.png

click.png

click.png

click.png

click.png

Mistral Sistemas

Usuários SAC
  • Content Count

    85
  • Joined

  • Last visited

Community Reputation

9 Neutral

About Mistral Sistemas

  • Rank
    Membro

Contact Methods

  • Website URL
    http://www.mistralsistemas.com.br
  • Skype
    desenvolvedor_mistral

Profile Information

  • Sexo
    Masculino
  • Location
    Rio de Janeiro

Recent Profile Visitors

919 profile views
  1. Solucionado. Entre uma modificação e outra talvez tenha ficado faltando reiniciar computador. Obrigado.
  2. Já fiz as modificações, amanhã iremos testar. Muito obrigado.
  3. Não Daniel, configuro direto no componente pq considerei padrão, então achei desnecessário. Mas se o problema pode ser decorrente disso, posso fazer essa configuração via código ao invés de direto no componente.
  4. Boa tarde. Componente <ACBRNFe>, <configuraçoes> <Arquivos> Em SepararPorAno, coloquei false, em SepararPorMes, coloquei true. Executando ficou NFe/202008 (mes de agosto, por exemplo). Até aí, nenhum mistério. O problema é que coloquei o MESMO executável em outra máquina, e o xml foi gravado em NFe/2020/08, como se eu tivesse colocado SepararPorAno igual a true. Desculpe ser repetitivo, mas o MESMO executpavel se comportou diferente em duas máquinas diferentes. A unica diferença é que uma está o delphi instalado, e a outra é a máquina do usuário. O que poderia ser?
  5. Olá pessoal, Tenho um cliente em São Paulo, e lá desde o inicio do problema de consumo indevido, eu diminui o numero de tentativas no componente para 3, e tem aparece "Lote em processamento", que é um controle de fila... quem tem seu xml atendido ele sai da fila para quem estiver esperando tenha seu xml processado. Vejam aqui nesse link sobre o numero de tentativas... https://acbr.sourceforge.io/ACBrMonitor/WebServices.html
  6. Já solucionei meu problema... eu ia excluir o tópico mas não achei como fazê-lo. Obrigado e desculpe pela perda de tempo de vocês.
  7. Bom dia. Atualizei hoje o acbr (19/11/2017) e ao compilar deu erro na funcão ObterNomeArquivo() que eu uso na linha: NomeArq := DMNFE.ACBrNFe.NotasFiscais.Items[0].NFe.procNFe.ObterNomeArquivo(); Ao analisar o erro, pesquisei primeiro e achei as seguintes linhas em um tópico de outro colega aqui no forum, como abaixo 15/11/2017 -- pcnProcNFe / pcnEventoNFe -- [*] Comentado a function GetVersaoEvento pois este retorna sempre uma versão pré-definida que pode não ser a versão atual do evento. Comentado também a function ObterNomeArquivo por não ter nenhuma uti
  8. Obrigado. Eu continuei pesquisando e vi que o fornecedor do certificado era VALID e vi que tinham alguns "senões" em sua instalação, converter para 1024 bits, etc. Achei bastante material aqui e acabou resolvendo. Muito obrigado.
  9. Bom dia. Um determinado cliente possui uma segurança super rígida em seu ambiente, "usuário padrão", não pode gravar nada, não pode instalar nada, etc. Instalei o certificado (preciso de acesso de administrador para fazer essa instalação), tudo funcionando (vc consegue por exemplo entrar no site da receita com o certificado). Quando estou com o usuário da máquina que irá fazer o envio das notas, acontecem alguns erros relacionados a ter certeza de que o certificado digital não existe (classe não registrada, etc.). Pois bem, o que gostaria de ajuda dos amigos, é qual caminho eu sigo:
  10. Complementando histórico... comentei as linhas que deram erro e o programa está funcionando. Mas se alguém tiver uma resposta mais técnica, agradeço. abs
  11. Bom dia. Tie um problema em minha máquina e precisei refazer a instalação do ACBR. Todo o processo de instalação ocorreu tranquilamente e sem problemas, porém ao compilar meu sistema, deu o seguinte erro: JwaWinNT.pas(9470) internal error:C1091 Pesquisando sobre o erro, cheguei ao tipo ULONGLONG. Em windows.pas só encontrei LONGLONG=int64. ULONGLONG seria do tipo Uint64 que não tem no delphi7 (que estou usando no momento). Já li sobre os problemas de compatibilidade que podem vir a acontecer, sei que preciso mudar a versão do delphi (já venho usando o XE7). A minha pergunta é: c
  12. Perfeito!! Pegando a resposta do André e a sua, fiz um debug, e foi exatamente isso. Eu não estava conseguindo abrir aqui para responder. Muito obrigado Andre e Italo. Eu sabia que era vacilo meu, só queria saber onde. Muito obrigado pela ajuda. Não tem jeito... eu configuro na geração da nota, mas não coloquei na carta. Realmente parabéns para o pessoal do desenvolvimento do componente. abs
  13. Italo, não entendi bem o que vc quis dizer com "configuração anterior", mas eu conferi. A chave da nota que usei, abri o XML e o modelo está 55, o arquivo XML desta nota está no diretório NFE, mas a carta de correção gravou no NFCE. Como reiniciei a máquina vou repetir o teste para verificar se como estou em teste, ambiente de homologação ele "se perdeu" por algum motivo. Até pensei se ele estaria pegando o primeiro diretório, mas eu deletei todos os diretório e deixei para o diretório: C:\NOTAS\EVENTO (é o que coloquei no componente, propriedade pathevento), e após a emissão correta da C
  14. Exatamente pq na mesma aplicação, eu faço NFe e NFCe. Modelo não é 55 ou 65? No caso, se a carta é de um modelo 55, pq ele não grava no diretório correspondente? Como eu resolveria isso? Porque acredito que se eu colocar falso, vai misturar NFe com NFCe, correto? Grato pela resposta
  15. Ao criar um evento de Carta de correção de uma NFe, o XML foi gravado em subdiretório de NFCe. Detalhes para análise. --- ACBRNFE. Configuracoes.Arquivo.PathEvento eu coloquei C:\NOTAS\EVENTO e na propriedade Salvarevento = true. Depois do processo que ocorre com sucesso, ele coloca o arquivo xml processado em: C:\NOTAS\EVENTO\NFCE\201608 Minha dúvida: o XML da nota estava em C:\NOTAS\PROC1\NFE\201608, por que ele gravaria o xml do evento em c:\notas\evento\nfce\201608 ? Já conferi todas as propriedades. O que posso ter deixado passar? Fiz um teste, colocan
×
×
  • Create New...