Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

clube mobile


Cursos grátis para toda base ACBr
+ Promoção Clube Mobile para o ACBr Pro

Saiba mais

adriano santos

click.png

click.png

click.png

click.png

click.png

click.png

StraightFree

Membros
  • Content Count

    27
  • Joined

  • Last visited

Community Reputation

6 Neutral

About StraightFree

  • Rank
    Membro

Recent Profile Visitors

933 profile views
  1. Boa tarde pessoal do ACBr, Venho solicitar a ajuda de vocês para resolver um problema na instalação do ACBr no lazarus no SO debian 10. Estou iniciando o desenvolvimento lazarus com linux e para isso fiz a instalação do lazarus 2.0.4 e do FPC 3.0.4 no debian 10. Após a preparação do ambiante, iniciei a instalação do ACBr conforme o tutorial do Messias no link: A instalação ocorreu sem nenhum problema na parte inicial, porém, quando fui instalar o ACBr_NFe_Danfe_RL ela me retorna esses dois erros: "Warning: other unit files search path (aka unit
  2. Daniel, bom dia! Obrigado pelo seu retorno. Fiz o que orientou e na propriedade ACBrSAT1.Config.XmlSignLib não aparece nenhuma outra opção. Será que ficou faltando instalar a libOpenSSL ou essa propriedade fica sem preenchimento mesmo? Mais uma vez agradeço a atenção.
  3. Boa noite, Fiz a instalação do lazarus e do ACBr no ubunto. Ao abrir o exemplo do ACBrSAT apareceu o seguinte erro: "Stream=TForm1: Root=:TForm1 Component Class: TACBrSAT Error reading ACBrSAT1.Config.XmlSignLib: Suporte a "xsMsXml" disponível apenas em MSWINDOWS Stream position: 47931" Após, uma rápida pesquisa vi que o sat funciona no linux. Esse erro é devido a propriedade XmlSingnLib estar setada com um valor que só pode ser usada no windows? Qual configuração devo usar? Qualquer ajuda será muito bem vinda. Obrigado!
  4. Boa noite, Fala pessoal do ACBr venho mais uma vez tirar uma dúvida com vocês. É possivel a emissão de NFe na versão 4.0 com ACBrNFe dentro do sistema operacional linux com a distribuição ubuntu 18.04? Além disso, é possivel utilizar o certificado a1 e a3 para essa emissão? Questiono sobre o certificado a3 pois fiz a instalação do lazarus no ubuntu e do ACBrNFe e ao clicar no botão sbtnGetCert1Click do Form1 ele acusa erro o ""LerCertificadosStore" não suportado em: TDFeSSLCryptClass." Esse erro é devido o certificado a3 não ser suportado no linux? Peço desculpas an
  5. Bom dia Daniel, Eu achava que a classe de resposta somente era preenchida ao enviar uma venda ou cancelamento. Não sabia que ela pegava o retorno da consulta também. Vou implementar essas mudanças. Vou analisar o log do SAT pra ver se acho alguma ocorrência de venda em que o SAT estava em processamento, talvez nesse momento pode ter acontecido da venda ser reenviada e quando o SAT volta em operação, acaba enviando as duas vendas. E vou sugerir colocar uma alimentação externa, para evitar mau funcionamento. Obrigado pela valiosa ajuda.
  6. Daniel, Obrigado pela ajuda. Conversando com o pessoal do caixa consegui levantar que as vezes acontece de ao finalizar uma venda, esta não passar pela rotina de emissão do CFe. Ai elas só conseguem fazer a emissão de novos CFe após reiniciar o PC. Estou achando que isso acontece por causa de alguma instabilidade na conexão USB entre o SAT e o PC. Inclui no fonte a verificação do retorno do SAT antes de enviar a venda, como você mencionou. Fiz da seguinte forma: if StrToInt(Quebra(dm_acesso.ACBrSAT1.ConsultarSAT,'|')[1]) = 8000 then begin dm_acesso.ACBrSAT1.EnviarDadosVe
  7. Verifiquei o LOG do ACBrSAT e lá a venda foi enviada várias vezes com uma diferença de tempo muito pequena, em alguns casos de milesegundos. Vou tentar analisar o LOG da DLL para ver se tenho uma luz do problema. Realmente, os números são diferentes sempre sequenciais. Quando você fala consultar o Status do SAT seria antes de enviar a venda consultar o Status do SAT ou o Status do ultimo CFe enviado? Hoje eu faço o seguinte, ao finalizar a venda eu verifico o retorno, caso seja diferente de 6000 eu emito um alerta ao usuario que aquela venda não foi emitida documento fiscal
  8. Bom dia galera do ACBr, Venho solicitar a ajuda de vocês em um problema que está acontecendo em um cliente. Esse cliente possui 2 equipamentos SAT da marca Elgin. Tudo funcionou perfeitamente por mais de 1 ano e meio. De repente, alguns CFes que eram emitidos passaram a ser duplicado, triplicados e em alguns casos até quadruplicados. O software manda apenas 1 vez a venda, porém o SAT emite diversas vezes o mesmo CFe com os mesmo itens e valores. Entrei em contato com a Elgin e eles me falaram que poderia ser a versão do software básico que está em 01.00.00 e a versã
  9. StraightFree

    Michel

    Presto consultoria nas áreas indicadas.
  10. Bom dia pessoal do ACBr, Estava com o problema e aparentemente não tinha solução.. Porém, ontem ao fazer uma nova atualização dos fontes do ACBr e compilar novamente o projeto ACBrMail, funcionou perfeitamente o envio pelo servidor próprio. O engraçado foi que não mexi em nada nem nos fontes atualizados, nem nas configurações de acesso. Isso me faz crer que era alguma coisa nos fontes que foi corrigida. Agora, está tudo funcionando perfeitamente. Achei pertinente avisar, para podermos colocar o tópico como resolvido! Obrigado a todos que colab
  11. Fernando, Obrigado pela resposta. Mas como citei acima, pelos provedores como Gmail, Yahoo, Terra, Hotmail não tenho problemas no envio. Todos acontece sem problemas. O problema só acontece quando tento enviar por provedor próprio. Tem alguma outra sugestão do que pode ser?
  12. BigWings, Obrigado pela resposta. A senha e o fornecimento de acesso SMTP estão corretas pois utilizo em outro software de envio de e-mails e tudo funciona perfeitamente. Quanto as configurações de TSL/SSL já tentei com todas as alternativas possiveis (Somente TSL, Somente SSL, com SSL TSL juntos e sem nenhum dos dois). Nenhuma das alternativas funcionou. Estou fazendo os testes utilizando o exemplo do ACBrMail. Por ele consigo enviar para outros servidores, mas para o servidor próprio não funciona. Inclusive utilizo o Gmail para enviar e receber e-mail desse provedo
  13. Bom dia a todos, Galera, desculpe a insistencia. Mas continuo com o problema acima citado. Consigo enviar e-mails usando Gmail,HotMail, Terra e outros, porém quando é servidor de domínio proprio retorna o erro SMTP Error: Unable to Login. Tenho uma outra aplicação que consegue enviar sem nenhum problema. Alguém tem alguma sugestão do que posso estar fazendo errado? Toda ajuda será bem vinda.
  14. Juliomar, Obrigado pela resposta. Já atualizei as dll. Exclui todas as versões anteriores e coloquei as atualizadas na pasta do ACBrMail e mesmo assim não funcionou. Tentei até atualizar o openssl para a versão 1.2, mas mesmo assim não adiantou. Rodo o Delphi XE8 num windows 7 64bits. Atualizei as dlls conforme está orientado no link : Tem alguma sugestão do que pode estar acontecendo?
  15. Bom dia galera do ACBr, Venho humildemente solicitar uma ajuda dos colegas. Já vasculhei o forum, mas nenhum dos tópicos me ajudou a resolver esse problema. Estou com um problema ao enviar e-mail por um servidor de domínio próprio. Pelo gmail e outros servidores de e-mail como yahoo e hotmail estão sendo enviados sem problemas. Porém, quando tento enviar pelo servidor próprio dá o erro - SMTP Error: Unable to Login. Já fiz atualização das DLLs, já reinstalei o ACBr. Fiz todos os procedimentos citados em todos os tópicos que falam sobre
×
×
  • Create New...