Ir para conteúdo
  • Cadastre-se

Juliano Menezes

Membros
  • Total de ítens

    16
  • Registro em

  • Última visita

Reputação

2 Neutro

Sobre Juliano Menezes

  • Rank
    Novato

Últimos Visitantes

357 visualizações
  1. Após muitos testes eu consegui. O problema está no ACBr. Na unidade "ACBrNFeWebServices" na função "procedure TNFeEnvEvento.DefinirURL", caso não seja evento de carta de correção ou cancelamento, ele define o ambiente nacional. Como o evento de prorrogação está ativo somente para algumas UFs (SP e ES), se for enviado para o ambiente nacional é retornado o erro "Rejeicao: O tpEvento informado invalido". Alterei o código de: if not (FEvento.Evento.Items[0].InfEvento.tpEvento in [teCCe, teCancelamento]) then Para: if not (FEvento.Evento.Items[0].InfEvento.tpEvento in [teCCe, teCancelamento, tePedProrrog1, tePedProrrog2, teCanPedProrrog1, teCanPedProrrog2]) Após essa alteração funcionou. Essa alteração pode ser reintegrada ao ACBr? Obrigado.
  2. Foi o que imaginei. Irei arrumar 2 clientes para emitir a NFe de um para o outro e assim manifestar e testar. Conseguindo ou não, posto. Obrigado pela ajuda.
  3. Obrigado pela ajuda Juliomar. Me tira uma dúvida. Quem pede a prorrogação seria quem emitiu a NFe ou quem recebeu e manifestou? Obrigado.
  4. Alguém poderia postar o XML enviado e aceito para poder comparar com o meu? Obrigado.
  5. Alguém consegue me dar uma ajuda? O cliente está me cobrando e eu não sei mais o que fazer. Consigo fazer os eventos Cancelamento, CCe sem problemas, mas esse não vai de jeito nenhum... Alguém que conseguiu poderia me enviar o XML que assim consigo comparar para verificar se houve alguma falha. A NFe tem que estar manifestada para conseguir enviar o evento com sucesso? A NFe tem que estar enviada a mais de 180 dias? Obrigado pela ajuda!
  6. Tentei novamente o envio e obtivo o mesmo resultado. Segue novo xml em anexo. 35160501307189000122550030000014521000003859_-ped-prorr.xml
  7. Obrigado Leão! Pelo que pude verificar, a produção somente irá funcionar à partir de 30/11/2016; A homologação 26/1/2015. Já tentei enviar para homologação sem sucesso... Não deveria estar funcionando? Será que tem algo de erro com meu XML ou o XML é isso memso? Obrigado.
  8. Bom dia! Há algum tempo que tento enviar com sucesso o evento de pedido de prorrogação do ICMS mas não consigo. Sempre é me retornado "Rejeicao: O tpEvento informado invalido". Alguém poderia me informar o que está de errado com meu XML? Obrigado. Envio: <?xml version="1.0" encoding="UTF-8"?><envEvento xmlns="http://www.portalfiscal.inf.br/nfe" versao="1.00"> <idLote>5785</idLote> <evento xmlns="http://www.portalfiscal.inf.br/nfe" versao="1.00"> <infEvento Id="ID1115003216041120059500014555001000009447100008040001"> <cOrgao>32</cOrgao> <tpAmb>2</tpAmb> <CNPJ>11200595000145</CNPJ> <chNFe>32160411200595000145550010000094471000080400</chNFe> <dhEvento>2016-04-13T14:51:11-03:00</dhEvento> <tpEvento>111500</tpEvento> <nSeqEvento>1</nSeqEvento> <verEvento>1.00</verEvento> <detEvento versao="1.00"> <descEvento>Pedido de Prorrogacao</descEvento> <nProt>332160000028651</nProt> <itemPedido numItem="1"> <qtdeItem>10.00</qtdeItem> </itemPedido> </detEvento> </infEvento> <Signature xmlns="http://www.w3.org/2000/09/xmldsig#"> <SignedInfo> <CanonicalizationMethod Algorithm="http://www.w3.org/TR/2001/REC-xml-c14n-20010315"/> <SignatureMethod Algorithm="http://www.w3.org/2000/09/xmldsig#rsa-sha1"/> <Reference URI="#ID1115003216041120059500014555001000009447100008040001"> <Transforms> <Transform Algorithm="http://www.w3.org/2000/09/xmldsig#enveloped-signature"/> <Transform Algorithm="http://www.w3.org/TR/2001/REC-xml-c14n-20010315"/> </Transforms> <DigestMethod Algorithm="http://www.w3.org/2000/09/xmldsig#sha1"/> <DigestValue>M2OX9C0prEvkQITBQeKw66f4MOs=</DigestValue> </Reference> </SignedInfo> <SignatureValue>R+7Jyufvuv0vtJ2RsrDt9r8jdwb+w1zMQlcjRRV5TJQ+3mqXJNDA3jOYGXXMkocq2W5zpimpOppNA5srOed8M6uHF/DuLpZQxldcZpyLHoNBxAFgajV7R4tFGL5D4XS3BgOQqHnupZpHn0o+2VxxP6ZZTq3Zts7GveJ2p2ILk1yxpB+6Nw7Y8UCsz8LpLS0OitwO/AzotVoajw+aygZ8OBUNzkQjVHQ1UZySL2vXw030Bfw4h9QntYxaaPD7zv9pCkgHNvrs4WIv3o7hyuwZ/cEmMgl8n+a77iBBYW41RSwm7OVHKCBreoDsNUlmY3fFcerfgZvMNd4/BDjeJPQqKg==</SignatureValue> <KeyInfo> <X509Data> <X509Certificate>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</X509Certificate> </X509Data> </KeyInfo> </Signature> </evento> </envEvento> Retorno: <?xml version="1.0" encoding="UTF-8"?><retEnvEvento versao="1.00" xmlns="http://www.portalfiscal.inf.br/nfe"> <idLote>5785</idLote> <tpAmb>2</tpAmb> <verAplic>AN_1.0.0</verAplic> <cOrgao>91</cOrgao> <cStat>128</cStat> <xMotivo>Lote de evento processado</xMotivo> <retEvento versao="1.00"> <infEvento> <tpAmb>2</tpAmb> <verAplic>AN_1.0.0</verAplic> <cOrgao>91</cOrgao> <cStat>491</cStat> <xMotivo>Rejeicao: O tpEvento informado invalido </xMotivo> <chNFe>32160411200595000145550010000094471000080400</chNFe> <tpEvento>111500</tpEvento> <xEvento>Pedido de Prorrogacao</xEvento> <nSeqEvento>1</nSeqEvento> <dhRegEvento>2016-04-13T14:52:16-03:00</dhRegEvento> </infEvento> </retEvento> </retEnvEvento>
  9. Bom dia! Há algum tempo que tento enviar com sucesso o evento de pedido de prorrogação do ICMS mas não consigo. Sempre é me retornado "Rejeicao: O tpEvento informado invalido". Alguém poderia me informar o que está de errado com meu XML? Obrigado. Envio: Anexe o arquivo Retorno: Anexe o arquivo
  10. Também estou com esse problema. Se abrir o WSDL pelo internet explorer abre de boa... Mas usando o ACBR retorna essa mensagem. Alguém sabe o que pode ser? Endereço: https://www.testegnre.pe.gov.br/gnreWS/services/GnreLoteRecepcao?wsdl
  11. Muito obrigado Juliomar! Irei pesquisar.
  12. Boa tarde Juliomar! Não setei essas propriedades não! Teria que fazer esse procedimento? Eu iria rodar o serviço no servidor do cliente. Teria então que setar o login do servidor correto? Obrigado.
×
×
  • Criar Novo...