Ir para conteúdo
  • Cadastre-se




O Melhor preço
da internet!

Comprar

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Comprar

Impressora de Etiquetas L42

Fabricada no Brasil. Benefícios exclusivos
Garantia de 18 meses   Visor na Tampa   Protocolos PPLA e PPLB
Portas USB e Serial   Baixo Custo de Manutenção   Financiamento através do BNDES

Saiba mais

Notícias do ACBr
daniel_mirassol

Erro Ao Enviar Email Nfe-2

Recommended Posts

Amigos,

Estou tentando enviar email da nfe2 (pelo prog acbrnfe_demo ) mas esta dando o seguinte erro: SMTP ERROR: Login: ??? - Other undefined Status, configuração que estou passando:

sevidor smtp : smpt@terra.com.br

porta : 587

usuário : xxxxx@terra.com.br

senha : ********

Smtp Conexão Segura : False

Assunto : teste

Mensagem : Teste Teste Teste

Alguem poderia me ajudar, pois perdemos nossa grande base de conhecimento onde tem vários topicos sobre este assunto.

Grato.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Tenho essa configuração que copiei do antigo fórum aprox. janeiro/2010, não sei se está atualizada mas talves te ajude:

(Mas no seu exemplo já tem um erro básico: sevidor smtp : smpt@terra.com.br o normal seria sem o @ smtp.terra.com.br ).

TERRA

É necessário saber a sigla da sua operadora Terra. Procure pelo campo “Operadora TERRA” nos seus dados cadastrais na central do assinante do Terra. Pegue esse valor e substitua-o onde for especificado sigla_da_operadora nas instruções abaixo.

Tendo a sigla da operadora em mãos, inicie o Thunderbird e crie uma conta para o Terra

Servidor SMTP : smtp.sigla_da_operadora.terra.com.br

Porta SMTP: 25

Servidor POP: pop.sigla_da_operadora.terra.com.br

Porta POP: 110

Usuario (Servidor POP e SMTP): preencha o seu email Terra, sem o @terra.com.br. Exemplo: XXXXXX

Senha (Servidor POP e SMTP): senha do e-mail

Nome remetente: nome do usuario

e-mail do remetente: e-mail do usuario

Requer conexão tsl: não

Requer autenticação: sim

Compartilhar este post


Link para o post
Compartilhar em outros sites

descula pelo erro o correto é smtp e smpt, mas no sistema esta correto foi somente na hora de digitar a mensagem, so para lembrar tentei outros email também da o mesmo erro, acho que esta faltando passar algum parametro para o campo smtp.login ...

Se alguem suber nos ajude, obrigado.

Compartilhar este post


Link para o post
Compartilhar em outros sites

amigo,

verifique as opções de firewall, e se for o caso adicione uma regra especifica para o seu programa.

comigo resolveu !

poste o resultado .. ok?!

abs

Compartilhar este post


Link para o post
Compartilhar em outros sites

ainda não consegui resolver quando o proverdor requer conexao segura. Da um erro smtp:login????.

Aqui em casa com o provedor da UOL funciona beleza sem marcar conexao segura.

Existe mais alguma dica?

Obrigado a todos!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Pessoal hoje um cliente também teve problema em enviar a Danfe por e-mail, embora outros não tiveram problema algum.

A versão é a 2.0 que estou utilizando.

Eu fiz uma alteração na procedure NotaFiscal.EnviarEmail da uint ACBrNFeNotasFiscais.

Comparei as duas procedures da versão 1.0 com a 2.0 e percebi que o comando

ThreadSMTP.smtp.AutoTLS estava true na 2.0 e na 1.0 estava SSL.

Eu comentei

//ThreadSMTP.smtp.AutoTLS := True;

E deixei o comando como estava na versão 1.0 e funcionou.

ThreadSMTP.smtp.AutoTLS := SSL;

Não sei se tem alguma atualização do ACBrNfePcn corrigindo este problema.

Mas sei que esta alteração deu certo para todos os clientes.

Atenciosamente

Júlio César

Compartilhar este post


Link para o post
Compartilhar em outros sites

Estou usando a versão 2.0 e tambem está tudo ok.

Obs:Ficaria legal se fosse retornado true ou false pra ter certeza que o e-mail foi enviado corretamente.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Eu uso Delphi 7, e a mesma falha de login acontece comigo na versão 2.0, será que é o problema está na versão da indy que acompanha o delphi7 em relação as versões mais novas do Delphi?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Prezados,

Fizemos a alteração que o juliobbi citou:

ThreadSMTP.smtp.AutoTLS := SSL;

e jogamos na pasta do sistema as dlls libeay32.dll e ssleay32.dll e isso resolveu o problema em vários clientes que não estavamo consguindo enviar email.

Marcello.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Aconteceu comigo isso, como resolvi? Simples, fui na maquina que envia e-mail e eliminei a conta do outlook, começou a enviar normalmente.

 

Desconfiei porque minha maquina enviava e a do cliente nao, entao foi so juntar as peças.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar Agora

  • Atenção !!  Este tópico está sem resposta há mais de 120 dias.

×