Jump to content

Problema Com Impressão Do Danfe Modelo Rave No Acbrnfemonitor


Kiko Fernandes
Go to solution Solved by Kiko Fernandes,
  • Este tópico foi criado há 3006 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Moderadores

Boa tarde!
 

Tenho notado que as últimas versões do ACBrNFeMonitor (CAPICOM) se a opção do modelo do DANFE estiver em  (o)Rave e selecionar qualquer XML para impressão tanto na opção [Testes] como ao enviar o comando NFe.ImprimirDanfe() o monitor fica com a informação "Gerando páginas xxx" e  fica nesta informação. 
Alguém mais tem encontrado este problema ou estão conseguindo imprimir em (o)Rave normal? 

A versão 0.7.7.4 está ok. 
 

Obs.:  Para visualizar a informação "Gerando páginas ... " a opção [ ] Mostrar Status na aba [DANFE/DACTE] deve estar marcada.

 


logoacbr.pngConheça o Portal do Projeto ACBr

Ajude o Projeto ACBr crescer - Assine o SAC ACBr
Assine um dos planos de longa duração do SAC ACBr, obtenha Descontos Especiais, Parcele no Cartão e ainda ganhe Brindes Exclusivos. Saiba mais aqui

Conheça o ACBrLib, o ACBr de forma nativa para qualquer linguagem de programação. Saiba mais aqui

 

 

 

 

Link to comment
Share on other sites

  • Moderadores

Eu não consegui descobri o que está ocorrendo. Mas instalei em outra pasta e tudo funcionou normal. 

Na pasta que tenho funcionando, ele continua dando este loop "Gerando páginas 9999999".

Eu ainda vou continuar tentando para ver se descubro. Se conseguir eu relato aqui para ficar registrado.


logoacbr.pngConheça o Portal do Projeto ACBr

Ajude o Projeto ACBr crescer - Assine o SAC ACBr
Assine um dos planos de longa duração do SAC ACBr, obtenha Descontos Especiais, Parcele no Cartão e ainda ganhe Brindes Exclusivos. Saiba mais aqui

Conheça o ACBrLib, o ACBr de forma nativa para qualquer linguagem de programação. Saiba mais aqui

 

 

 

 

Link to comment
Share on other sites

  • Moderadores

Eu não consegui descobri o que está ocorrendo. Mas instalei em outra pasta e tudo funcionou normal. 

Na pasta que tenho funcionando, ele continua dando este loop "Gerando páginas 9999999".

Eu ainda vou continuar tentando para ver se descubro. Se conseguir eu relato aqui para ficar registrado.

Geralmente este erro ocorre em notas que possuem muitas observações, mas se vc apenas muda de diretório e funciona deve estar relacionado a algum outro problema.

djsystem-logo.png
 youtube.png facebook.png instagram.png linkedin.png
André Ferreira de Moraes | Analista de Sistemas
www.djsystem.com.br | www.djpdv.com.br
www.tefhouse.com.br | www.lambretinha.com.br
Link to comment
Share on other sites

  • Moderadores
  • Solution

Evandro obrigado! 
Eu já tinha lido algo semelhante ao que vc falou, mas no meu caso utilizo somente o ACBrNFeMonitor (não programo em Delphi).

Consegui resolver instalando o ACBrNFeMonitor em outra pasta e funcionou sem problemas na pasta nova e na antiga o problema continuava. Fui alterando configurações no INI e na aba que configura as pastas dos arquivos para ver se era possível descobrir o que estava ocorrendo. O pior é que consegui ajustar na pasta antiga para que voltasse a funcionar e não consegui descobrir o que foi feito. 

André realmente nesta situação não foi o caso, pois usei XML que nem observação tinha. Pensei em  quantidade de itens e até com 1 o problema acontecia.
 

Tentei simular o problema novamente e não consegui mais.
Então por enquanto vou ter que deixar assim não sei o que ocorreu. Foi resolvido desta forma, mas não consegui reportar a solução.


 


logoacbr.pngConheça o Portal do Projeto ACBr

Ajude o Projeto ACBr crescer - Assine o SAC ACBr
Assine um dos planos de longa duração do SAC ACBr, obtenha Descontos Especiais, Parcele no Cartão e ainda ganhe Brindes Exclusivos. Saiba mais aqui

Conheça o ACBrLib, o ACBr de forma nativa para qualquer linguagem de programação. Saiba mais aqui

 

 

 

 

Link to comment
Share on other sites

Não utilizo o ACBrNFeMonitor e sim o componente ACBrNFe , e em um caso similar , já aconteceu comigo em tempos atraz este bug com Rave , quando não havia uma impressora padrão instalada no SO , o contador de paginas ficava infinito e nunca mostrava nada , instalava-se a impressora e tudo corria normal .

 

Não sei informar no momento maiores detalhes do Bug , tipo qual versão do SO (XP , 7) etc... da oportunidade de quando aconteceu este fato . 

Edited by marcelo_sp
Link to comment
Share on other sites

  • Moderadores

Não utilizo o ACBrNFeMonitor e sim o componente ACBrNFe , e em um caso similar , já aconteceu comigo em tempos atraz este bug com Rave , quando não havia uma impressora padrão instalada no SO , o contador de paginas ficava infinito e nunca mostrava nada , instalava-se a impressora e tudo corria normal .

 

Não sei informar no momento maiores detalhes do Bug , tipo qual versão do SO (XP , 7) etc... da oportunidade de quando aconteceu este fato . 

Obrigado Marcelo_sp! Mas esta situação eu também verifiquei e a impressora estava instalada. Eu encontrei no fórum também um relato sobre a falta da impressora, mas também não foi esta situação.


logoacbr.pngConheça o Portal do Projeto ACBr

Ajude o Projeto ACBr crescer - Assine o SAC ACBr
Assine um dos planos de longa duração do SAC ACBr, obtenha Descontos Especiais, Parcele no Cartão e ainda ganhe Brindes Exclusivos. Saiba mais aqui

Conheça o ACBrLib, o ACBr de forma nativa para qualquer linguagem de programação. Saiba mais aqui

 

 

 

 

Link to comment
Share on other sites

  • 6 months later...

Acabou de acontecer comigo, e foi depois que instalei uma impressora Zebra GC420t e a coloquei como impressora Padrão, na impressão da DANFE não termina de gerar a paginas.

 

Coloquei novamente como IMPRESSORA PADRÃO no Windows minha impressora anterior HP que era a "Deskjet F4100 series" e voltou a funcionar normalmente.

 

Alguém consegui resolver esse problema ? É que necessito deixar como padrão a impressora ZEBRA.

Link to comment
Share on other sites

  • Este tópico foi criado há 3006 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.