Jump to content

Assista click.png tectoy.png

C6 chamada_c6.png botao.png

Danfe Impresso Sem Autorização?!?!


Go to solution Solved by atlantisnanet,
  • Este tópico foi criado há 2625 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Olá pessoal,

 

Está acontecendo um problema estranho no meu ACBRNFeMonitor 0.8.12.0:

 

Após a nota ser autorizada, o danfe sai impresso sem a autorização da Sefaz,

mas não é sempre que isto acontece, se consulto novamente ele imprime corretamente,

mas às vezes imprime corretamente de primeira.

 

Infelizmente isto está acontecendo com muita frequencia aqui, o que será

que pode ser?

 

Desde já agradeço e FELIZ 2015!

Pablo Ferreira .·.

Programador Delphi/Visual Basic

Atlantis Informática

Link to comment
Share on other sites

  • Consultores

Boa tarde!

tentou atualizar para a última versão?

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

Olá pessoal,

 

Baixei a nova versão, mas ainda aconteceu, embora com freqüência muito menor,

a nota está autorizada, mas imprime o danfe sem autorização, de cada 10 impressões

uma sai sem autorização.

 

O que será que acontece? Estranho que acontece de vez em quando, não sempre,

quando consulta pela segunda vez ele imprime normalmente.

 

No aguardo,

Pablo Ferreira .·.

Programador Delphi/Visual Basic

Atlantis Informática

Link to comment
Share on other sites

Olá pessoal,

 

Acabou de acontecer o erro, está me parecendo que o problema é com o comando

"CriarEnviar", vejam no LOG1 que autorizou, mas imprime o danfe sem autorização,

conforme pdf também em anexo. No LOG2 vejam que consultei a nota, aí

a impressão do danfe saiu corretamente.

 

No aguardo, desde já agradeço.

LOG1.TXT

LOG2.TXT

41150103976538000124550010000007271000000011-nfe.pdf

Pablo Ferreira .·.

Programador Delphi/Visual Basic

Atlantis Informática

Link to comment
Share on other sites

  • Moderadores

Veja no LOG que a primeira vez que vc tentou enviar a nota com a chave 41150103976538000124550010000007271000000011 o retorno foi de "Duplicidade de NF-e [nRec:411000571162092]" e o número de recibo deste envio 411000571162110, ou seja, esta nota já foi enviada anteriormente.

Ao usar posteriormente o comando NFE.CONSULTARNFE("41150103976538000124550010000007271000000011") a consulta é realizada pela chave no SEFAZ, e como a nota já foi autorizada anteriormente o resultado é de "Autorizado o uso da NF-e", mas vc deve checar se o DigestValue da nota bate com o valor que está no SEFAZ.

Se vc usa vários terminais, talvez algum tenha usado o mesmo número de nota que o outro.

djsystem-logo.png
 youtube.png facebook.png instagram.png linkedin.png
André Ferreira de Moraes | Analista de Sistemas
www.djsystem.com.br | www.djpdv.com.br
www.tefhouse.com.br | www.lambretinha.com.br
Link to comment
Share on other sites

  • 3 weeks later...

Olá pessoal,

 

Podem me chamar de louco, mas o problema está ocorrendo novamente e com uma certa freqüência....

Estranho que isto não acontecia antes, outra coisa estranha é que sempre que é impresso sem autorização,

e em seguida consulto a situação na Receita, ele imprime corretamente autorizado. Mas não é sempre

que isto acontece, às vezes imprime autorizado de primeira... Segue em anexo LOG da última

vez que aconteceu este problema. Estou analizando aqui mas não consigo entender o que acontece.

 

P.S.: Já atualizei para a última versão do monitor 09020.

 

No aguardo desde já agradeço.

LOG.TXT

Pablo Ferreira .·.

Programador Delphi/Visual Basic

Atlantis Informática

Link to comment
Share on other sites

O problema persiste... Não consigo achar uma resposta.

 

Não estamos usando vários terminais, o programa está rodando em apenas um computador.

 

Estive analisando, fazem mais de 4 anos (22/09/2010) que estou usando o ACBr Monitor, e

NUNCA tinha ocorrido um problema tão estranho, sempre funcionou muito bem. Já revirei o

código do meu programa e não acho nada...

 

O pessoal está reclamando muito...

 

Conto com a ajuda dos amigos, LOG no post anterior.

Pablo Ferreira .·.

Programador Delphi/Visual Basic

Atlantis Informática

Link to comment
Share on other sites

Olá Regys,

 

Segue em anexo PDF da NF-e 529, sem autorização, em seguida ela foi consultada

aí autorizou.

 

P.S.: Ás veses está acontecendo de uma nota consultada imprimir sem autorização também.

 

Muito obrigado!

41150112596179000170550010000005291000000014-nfe(4).pdf

Pablo Ferreira .·.

Programador Delphi/Visual Basic

Atlantis Informática

Link to comment
Share on other sites

  • Moderadores

Percebi que está nota foi gravada dentro de um diretório que esta dentro de arquivos de programas, o diretório arquivos de programa geralmente tem restrições de escrita, talvez seja esse o problema.

Você poderia fazer um teste trocando este diretório por outro na raiz do disco, com por exemplo "C:\NFes".

Equipe ACBr

Régys Borges da Silveira

http://www.regys.com.br

certificacao delphicertificacao delphi
Link to comment
Share on other sites

Realmente faz sentido Régys, no último cliente onde aconteceu este erro, o usuário usado não era o administrador,

até o meu programa teve problemas para gravar um arquivo dele (PC com Windows 7). Em um computador aqui com Windows XP

este problema realmente nunca aconteceu. Ontem no meu computador com Windows 7 aconteceu o problema e estava

com o administrador... Mas acho que você tem razão vou fazer uns testes.

 

Muito obrigado amigo!

Pablo Ferreira .·.

Programador Delphi/Visual Basic

Atlantis Informática

Link to comment
Share on other sites

  • 3 weeks later...

Olá pessoal,

 

Fiz uma grande alteração no meu programa, retirei a base de dentro de arquivos de programas, e mudei para um diretório raiz,

conforme a dica do Régys, deu bastante trabalho, mas após fazer os testes, percebi que o problema continua...

 

No teste, autorizei a nota, mandei imprimir, e imprimiu autorizada normalmente. O problema acontece quando eu consulto

a nota, após aparecer autorizado o uso e imprimir, ela imprime sem autorização, é sempre na primeira consulta que isto

acontece, na segunda consulta ele imprime autorizada normalmente.

 

Desculpem insistir neste assunto, mas é que o pessoal aqui está reclamando muito.

 

Desde já agradeço, LOG em anexo.

LOG.TXT

Pablo Ferreira .·.

Programador Delphi/Visual Basic

Atlantis Informática

Link to comment
Share on other sites

  • Consultores

Olá Pablo,

  Não é preciso se desculpar por insistir em um assunto. O problema é que parece que não temos dados suficientes para um diagnóstico preciso e eficaz, resolvendo de uma vez o seu problema.

  Como você mesmo disse, o erro é muito estranho. Não parece ser possível reproduzi-lo utilizando o programa de exemplo do ACBrNFe. Se houvesse um passo a passo para reproduzir o problema, isso facilitaria muito encontrarmos onde está o problema.

 

  Algumas coisas que você pode tentar verificar:

  • Será que pode ser alguma demora após a autorização? Se for o caso, talvez adicionando alguma espera (sleep) antes de fazer a consulta e impressão possa resolver. Verifique quanto tempo passa entre a primeira e a segunda consulta.
  • Eu encontrei muitos erros do tipo "Exception: Cannot open file "C:\ACBrNFeMonitor\ENTNFE.TXT". O arquivo já está sendo usado por outro processo". Isso pode indicar algum antivírus bloqueando o acesso aos arquivos. Se for o caso, adicione tanto o seu executável como o executável do monitor na lista de exceções do antivírus.
  • Procure no log por "ERRO:" e você verá que acontecem erros variados. Como não sei exatamente qual a NFe que teve problema, não sei se estão relacionados ao seu problema. Mas são muito variados como "ERRO: Arquivo 0010000001251000000012-nfe.xml-nfe.xml não encontrado", "ERRO: Arquivo C:\Atlantis\8\Dados\-cte.xml não encontrado.", "ERRO: Arquivo C:\Atlantis\8\Dados\41101114115020529433700017257001000000170100000170401-ProcEventoCTe.xml não encontrado.", "ERRO: Erro ao criar o arquivo PDF"

  Acho que isso é um começo por onde procurar.

 

  Nota: Por favor, faça uma limpeza no seu log. Ele tem informações abrangendo desde 2013 e mais de 155000 linhas. Quando anexar ele, informe exatamente em qual nota aconteceu o problema e por volta de que horas aconteceu.

  • Like 1

[]'s

Consultor SAC ACBr

Elton
Profissionalize o ACBr na sua empresa, conheça o ACBr Pro.

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Um engenheiro de Controle de Qualidade(QA) entra num bar. Pede uma cerveja. Pede zero cervejas.
Pede 99999999 cervejas. Pede -1 cervejas. Pede um jacaré. Pede asdfdhklçkh.
Link to comment
Share on other sites

Olá EMBarbosa muito obrigado pelas dicas,

 

O que fiz, foi na aba Webservice o campo "Aguardar" do Retorno de Envio de NFe mudar de 0 para 5,

e aparentemente o problema foi resolvido, não quero cantar vitória muito cedo mas em 10 testes que

fiz não ocorreu mais o problema como antes.

 

Fiz a limpeza do meu LOG, deixei o teto para 10000 linhas.

 

Quanto aos erros que descreveu eram do meu sistema mesmo, mas foram corrigidos.

 

Vamos aguardar, vou fazer mais testes, mas talvez você seja o gênio que encontrou a solução!

 

Abraço e muito obrigado à todos!

  • Like 1

Pablo Ferreira .·.

Programador Delphi/Visual Basic

Atlantis Informática

Link to comment
Share on other sites

Olá pessoal,

 

Realizei muitos testes, e aparentemente o que resolveu o problema foi marcar a opção

conforme imagem em anexo.

 

Vou continuar testando, mas parece que agora vai!

 

Abraço e muito obrigado à todos!

post-2349-0-56325300-1425556855.jpg

  • Like 1

Pablo Ferreira .·.

Programador Delphi/Visual Basic

Atlantis Informática

Link to comment
Share on other sites

  • Consultores

Agradecemos seu retorno.

[]'s

Consultor SAC ACBr

Elton
Profissionalize o ACBr na sua empresa, conheça o ACBr Pro.

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Um engenheiro de Controle de Qualidade(QA) entra num bar. Pede uma cerveja. Pede zero cervejas.
Pede 99999999 cervejas. Pede -1 cervejas. Pede um jacaré. Pede asdfdhklçkh.
Link to comment
Share on other sites

  • 2 weeks later...

Olá pessoal,

 

Infelizmente o problema continua acontecendo...

 

MEUS CLIENTES ESTÃO FURIOSOS!

 

Vejam abaixo um e-mail que acabei de receber:

 

Bom Dia

Foi feita uma reclamação de reparo do sistema, onde ocorre que,

Uma NFe já emitida e autorizada, se acessada em outro momento ela sai no arquivo enviado por email e na impressão como NFe não autorizada.

Nunca se tem certeza de como ela vai sair, pois na consulta da NFe ela aparece autorizada.

Este reparo ainda não foi feito.

Isto esta nos causando custo de papel e constrangimento com o cliente. 

Peço reparo URGENTE

 

Já fiz de tudo aqui, desabilitei o antivírus, configurei o monitor, mas nada dá certo...

 

Como eu já disse pessoal, uso o ACBR há muitos anos, e nunca ocorreu este problema antes,

parece que começou quando foi introduzida a NFC-e no monitor.

 

Log em anexo, POR FAVOR ME AJUDEM, estou tendo sérios problemas com isto...

LOG.TXT

Pablo Ferreira .·.

Programador Delphi/Visual Basic

Atlantis Informática

Link to comment
Share on other sites

Pessoal,

 

O problema começou com a versão 0.8.12.0 do ACBRNfeMonitor, então tentei baixar aqui, pelo

sac, a versão 0.8.11.4, que é a versão anterior. Fazendo os testes aqui, a autorização e impressão

sai corretamente, mas quando consulto a NF-e, também o danfe sai sem autorização na impressão,

a diferença é que quando consulto, retorna este erro:

 

ERRO: Autorizado o uso da NF-e

 

E a impressão sai sem autorização. A diferença entre esta versão e a atual, é que esta

retorna como erro, mas assim como na versão atual, o danfe sai sem autorização na

impressão.

 

Quem sabe isto ajude a esclarecer alguma coisa.

 

Segue novo LOG em anexo.

 

Aguardo ansiosamente uma resposta pessoal!

LOG.TXT

LOG.TXT

Pablo Ferreira .·.

Programador Delphi/Visual Basic

Atlantis Informática

Link to comment
Share on other sites

  • Solution

Passei o dia ansioso esperando uma resposta...

 

Fiz uma gambiarra aqui, ao consultar, o sistema faz duas consultas consecutivas, aparentemente assim

o problema foi resolvido.

 

Muito Obrigado.

Edited by atlantisnanet
  • Like 1

Pablo Ferreira .·.

Programador Delphi/Visual Basic

Atlantis Informática

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.