Jump to content

logo_acbr_paygo.png

Chegou o TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


botao_saibamais.png

beneficios.png

Curso Dominando o ACBrMonitor
Novo Módulo Soluções de Varejo
Assine o SAC ACBr em qualquer plano e tenha acesso

Saiba Mais

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba Mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

hcn

Cabecalho - Versao Do Arquivo Xml Nao Suportada

  • Este tópico foi criado há 1921 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

Olá, Uso a versão já compilada, 0.8.12.3,   Já coloquei versão 3.1   mas o xml gera com 2.0, Alguem pode ajudar? Obrigado.

Share this post


Link to post
Share on other sites

Olá !

 

Novas Tags a serem informadas

 

Use a busca do forum que ira encontrar farto material para estudo ( ex: layout nfe versão 3.1 txt ini )

 

Abs


by IMATECH
[email protected]
Goiânia - GO.

Share this post


Link to post
Share on other sites

Recebi o mesmo erro dos colegas, setei a versão 310 no DFM.

Usuário usava o sistema e após algumas notas/operações mudava para versão 200 "automaticamente". Ou seja, passavam várias notas ok e sem EU mudar nada na programação alterava para versao 200, dando mensagem de erro de não aceite. Instrui os usuários a fecharem e reabrirem o sistema, onde normaliza por algum tempo.

Ressalto que no meu código não havia como mudar a versão.

Para resolver, antes do ENVIO sempre estou setando manualmente a versão para 310

 

Ainda não achei qual operação troca a versão...

Share this post


Link to post
Share on other sites

Olá lmdsistemas !

 

Para usuários dos componentes basta setar as propriedades antes de gerar o Documento ( Além de informar as novas Tags )

ACBrNFe1.Configuracoes.Geral.ModeloDF:=moNFe;
ACBrNFe1.Configuracoes.Geral.VersaoDF:=ve310;

Para usuários do monitor devem ser informadas as novas Tags no arquivo INI

 

Abs

Edited by IMATECH

by IMATECH
[email protected]
Goiânia - GO.

Share this post


Link to post
Share on other sites

Descobri o meu meu problema.

Sempre que carrego alguma nova versão 2.0 (imprimir, consulta, cancelar), o componente atualiza as configurações:

linha 806            FConfiguracoes.Geral.VersaoDF := StrToVersaoDF(OK, Versao);

 

conforme comentado, para funcionar sem complicações basta setar a versão 310 sempre que enviar algum documento novo.

Share this post


Link to post
Share on other sites

Sou de SP e cheguei a ter essas mensagens de cabeçalho inválido em 4 clientes nossos, apenas trocamos os schemas pela última versão disponível e tudo voltou a funcionar sem problemas, tente isso amigo.

  • Like 1

Share this post


Link to post
Share on other sites

Alguem conseguiu resolver a questao : 1SP_NFE_PL_006q239Rejeição: Cabeçalho - Versão do arquivo XML não suportada. Estou tendo o mesmo problema desde o 1/04/2015.

 

 

Já enviei o xml da seguinte forma:

 

 <?xml version=\"1.0\" encoding=\"UTF-8\"?>
<consStatServ xmlns="http://www.portalfiscal.inf.br/nfe"versao="2.00"
<tpAmb>1</tpAmb>
<cUF>35</cUF>
<xServ>STATUS</xServ>
</consStatServ>
 
 
e para 3.10
 
 <?xml version=\"1.0\" encoding=\"UTF-8\"?>
<consStatServ xmlns="http://www.portalfiscal.inf.br/nfe"versao="3.10"
<tpAmb>1</tpAmb>
<cUF>35</cUF>
<xServ>STATUS</xServ>
</consStatServ>
 
 
E o erro persiste para as duas.
 
 

Obrigada

Edited by Gabriela Rocha

Share this post


Link to post
Share on other sites

Tiago, mesmo com os schemas corretos acontece o problema, não creio que seja este o problema, no meu caso é esporádico, no mesmo emissor após enviar N notas uma retorna este problema. Ou seja não são em todos os envios de NFe.

Share this post


Link to post
Share on other sites

SP, e o interessante no caso é que após a consulta o xml que é retornado é apresentado na versão 2.0 e não 3.10, se apago o xml que retornou e tento reenviar a NFe as vezes ela é enviada, em outros casos retorna Duplicidade, no caso de duplicidade somente faço a consulta da mesma e consigo imprimir o DANFE.

 

Mas lembrando, não são todas as NFe e tambem não são todos meus clientes.

Share this post


Link to post
Share on other sites

SP tem mostrado instabilidade na versão 3.10, aqui no paraná(onde estão os clientes da empresa em que trabalho) não tivemos relatos de problemas, vc está usando o modo Assíncrono na emissão?

Share this post


Link to post
Share on other sites

Então Tiago, como trabalhamos somente com pequenas empresas, fazemos o envio de Nota a Nota, nem temos a opção de gerar lote, e sempre verificamos e tratamos o retorno logo que a NFe e enviada, então não sei te dizer como esta esta questão em Hard Users, tipo sera que com envio de lotes grandes estão tendo a mesma dificuldade, agora cedo parece estar melhor não temos ainda nenhum chamado no suporte a respeito disso, Vamos verificar no decorrer do dia se aparece mais alguma ocorrência, pois dai teremos logs para analisar melhor.

  • Like 1

Share this post


Link to post
Share on other sites
  • Este tópico foi criado há 1921 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...