Jump to content

Delphi chamada_delphi.png acbr.png

C6 chamada_c6.png botao.png

Erro ao instalar ACBr_NFeDanfeRL.dpk


  • Este tópico foi criado há 2480 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Olá a todos,

Por sugestão do Regys estou migrando do trunk para o trunk2, mas estou recebendo o seguinte erro na tentativa de instalação do mesmo:

ACBr_NFeDanfeRL.dpk(75) Fatal: Required package 'FortesReportCE_Win32_D7_vcl' not found
Compilation failure

Desde já agradeço a atenção de todos.

Abraços

Link to comment
Share on other sites

  • Consultores

Boa tarde

conforme também post dele informou que o trunk2 está compativel com o Fortes Report Community Edition!

baixe o mesmo do github do pessoal da fortes report e instale antes do ACBr

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

  • Membros Pro

Valeu Juliomar, reparei lá que não tem o DANFE em QuickReport no Trunk2... É isso mesmo?

Outra dúvida, estão presentes o DANFE NFC-e? Se sim, foi resolvido aquela questão do troco e da Via do Consumidor????

Link to comment
Share on other sites

  • Consultores

Veja conforme também foi anunciado não será dado manutenção para Quick e Rave somente fast e fortes

se alguém quiser fazer vai ser por conta ou se algum commiter quiser também fazer então não sei lhe precisar algo sobre quickreport!

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

  • Membros Pro

Entendi Juliomar, já estava ciente. Minhas dúvidas do troco e viaconsumidor e empresa foram sobre o Fortes. Antes não funcionavam e você, em outro post, havia me informado que seriam resolvidos. Agora no trunk2 já estão funcionando?

Edited by doidopb
Link to comment
Share on other sites

  • Membros Pro

Olá Juliomar, 

Removi o Fortes que tinha, o 3.72B, e baixei o Report Community Edition. Não consigo compilar de jeito nenhum. Ao abrir o pacote para Delphi 7 dá o erro em anexo, mas abre a janela para compilhar, onde me retorna o seguinte erro na hora da compilação:

[Error] RLUtils.pas(903): Undeclared identifier: 'CharInSet'

Sei que foge do tópico, mas fiz uma busca na net e na lista de discussão do Fortes no yahoo e não achei nada. Você por acaso sabe do que se trata esse erro?

Desde já agradeço a atenção

 

erro.bmp

Edited by doidopb
Link to comment
Share on other sites

  • Membros Pro

Então meu amigo,

Eu baixei até novamente agora no https://github.com/fortesinformatica/fortesreport-ce.

No diretório Packages do componente, realmente existem esses *.res para algumas versões do delphi, outras não, como não tem para o Delphi7. 

Apesar do tal erro, ele prossegue com a tela com Compile, mas ao tentar compilar dá o tal erro "Undeclared identifier: 'CharInSet'".

Sobre esse erro do Undeclared até achei um texto a respeito, mas muito antigo que pede para configurar uma variável desse projeto, mas ela já se encontra configurada da forma correta. Link: http://www.devmedia.com.br/forum/fortes-report-no-delphi-2006/391852

Aí como não achei mais nada, estou empacado aqui sem conseguir programar :-/ Por isso fugi um pouco do tópico do componente, mas preciso disso para fazer o trunk2 funcionar aqui e poder ver como funciona essas impressões em ESCPOS, pois vários clientes meus só tem impressoras desse tipo.

Desde já agradeço a atenção

 

Link to comment
Share on other sites

  • Membros Pro

Olá meu amigo, 

Consegui resolver com a dica do topico em http://www.projetoacbr.com.br/forum/topic/22849-problema-na-instalação-do-fortes-report/

Agora com o FortesReport Community Edition, o erro mudou, mas ainda dá erro :-(

C:\ACBR\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fortes\ACBrNFeDANFeRLRetrato.pas(1) Error: Illegal character in input file: 'ï' ($EF)
C:\ACBR\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fortes\ACBrNFeDANFeRLClass.pas(126) Fatal: Could not compile used unit '..\..\..\..\..\..\..\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fortes\ACBrNFeDANFeRLRetrato.pas'
Compilation failure

Está dando erro no CT-e também, mas não uso esse componente.

Será que podem me ajudar?

Link to comment
Share on other sites

  • Consultores

Boa noite

uma das situações pode ser que tenha ainda path no library para a versão antiga do fortes

ou tenha sobrado arquivos da outra versão em locais que o delphi está vendo!

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

  • Membros Pro

Boa noite

uma das situações pode ser que tenha ainda path no library para a versão antiga do fortes

ou tenha sobrado arquivos da outra versão em locais que o delphi está vendo!

Olá amigo,

Acabo de instalar o Windows em uma máquina nova, nova instalação do Delphi 7 do zero.

Instalei o pacote do Fortes 4, do repositório do Rafael https://github.com/rftd/fortesreport-ce, conforme o tópico http://www.projetoacbr.com.br/forum/topic/22849-problema-na-instalação-do-fortes-report/. Instalação ok, sem erros.

Todos os meus projetos que usam o Fortes funcionando normal, mas ainda recebo o mesmo erro!!!

Link to comment
Share on other sites

  • Membros Pro

Descobri o erro.

Encontra-se nos arquivos ACBrNFeDANFeRLPaisagem.pas e ACBrNFeDANFeRLRetrato.pas, presente em C:\ACBR\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fortes.

É no inicio da primeira linha de ambos os arquivos, realmente existe esse caracter inválido. Só removi, salvei e finalmente consegui compilar.

Está marcado no print em anexo.

Abraços

caracter_invalido.JPG

Link to comment
Share on other sites

  • Fundadores

Isso já foi corrigido a alguns dias no SVN... esses caracteres no inicio do arquivo, são a marcação para arquivo usando o Encoding UTF8

Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

doidopb , sobre o problema 

Agora com o FortesReport Community Edition, o erro mudou, mas ainda dá erro :-(

C:\ACBR\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fortes\ACBrNFeDANFeRLRetrato.pas(1) Error: Illegal character in input file: 'ï' ($EF)
C:\ACBR\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fortes\ACBrNFeDANFeRLClass.pas(126) Fatal: Could not compile used unit '..\..\..\..\..\..\..\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fortes\ACBrNFeDANFeRLRetrato.pas'
Compilation failure

Se você abrir 

 

http://www.projetoacbr.com.br/forum/topic/23290-delphi-7-abrrnfedanferlpaisagempas-solucao/ 

tem sua resposra

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.