Jump to content

2 Dia do ACBr

Ingressos esgotados! Agradecemos a todos os inscritos.
Site do Evento

Nova Loja Oficial
loja.projetoacbr.com.br
Ajude o projeto a crescer, com estilo

Comprar

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

FabioMachado

Erro ao instalar, utilizando o instalador

Recommended Posts

Boa tarde, baixei a pouco toda a pasta do trunk2 mas quando rodo o instalador apresenta o erro "Pacote ACBr_synapse.dpk" não encontrado, efetue o download do repositório.

erronoinstalador.jpg

 

Edited by FabioMachado

Share this post


Link to post
Share on other sites

Bom, fiz até remover o meu XE8 e instalar tudo de novo e mesmo assim não funcionou o instalar, insisti tanto que perdi todo o path, rsrsrsrsrs mas consegui instalar manualmente os componentes.

Share this post


Link to post
Share on other sites

Boa tarde

Sinceramente é algo simples de se rodar e tudo mais, evita dor de cabeça, tenho nos micros da empresa usando o instalador, tenho meu notebook no desktop de casa e em todos funciona 100% !

Next>Next>Install>Finish


Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP

Share this post


Link to post
Share on other sites

Eu tive o mesmo problema. Então resolvi executar o ACBrInstall_Trunk2.exe que foi baixado do repositório (de dentro do diretório criado) e funcionou.

Edited by silvamv

Share this post


Link to post
Share on other sites

Boa noite,

 

Estou tendo problemas na instalação do Extato do SAT ESCPOS, esta dando erro ao encontrar PCN2 (Fatal: E2202 Required package 'PCN2' not found Compilation)

Alguém passou por isso e conseguiu solucionar?

 

Limpei library path, removi arquivos de instalação anterior, atualizei fontes, executei como administrador o acbr install.. e esse bendito não instala!!


--

Thiago Filiano 

[email protected]

11 98507-1103

Share this post


Link to post
Share on other sites

Acabei de baixar o ACBrInstall_Trunk2.exe e está dando o erro:

---------------------------
Erro.
---------------------------
Pacote "ACBr_synapse.dpk" não encontrado, efetue novamente o download do repositório
---------------------------
OK   
---------------------------
 

E o pacote está lá.

- É uma VM nova, limpa com Windows 10 32-bit

- Delphi 10 Seattle

- Não existe referências ao ACBr nesta instalação.

 

 

 

Cancelei a instalação, executei a versão baixada do repositório e está funcionando.

Share this post


Link to post
Share on other sites
3 horas atrás, Juliomar Marchetti disse:

Sim é isso mesmo!

ela tem correção que adiciona uma "\" ao final do endereço que fica os fontes no micro ..

isso é que causa o erro

 

Tem um erro no pacote "ACBr_NFeDanfeFR.dpk" na unit "ACBrNFeDANFEFR.pas"

C:\Projetos\Componentes\ACBrTrunk2\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fast\ACBrNFeDANFEFR.pas(475) Error: E2070 Unknown directive: 'TACBrNFeDANFEFR'

O erro é no método anterior, falta um "end;" no final da "procedure TACBrNFeDANFEFR.ImprimirDANFEPDF(NFE: TNFe);"

Aqui o log completo do erro:

C:\Projetos\Componentes\ACBrTrunk2\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fast\ACBrNFeDANFEFR.pas(475) Error: E2070 Unknown directive: 'TACBrNFeDANFEFR'
C:\Projetos\Componentes\ACBrTrunk2\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fast\ACBrNFeDANFEFR.pas(475) Error: E2029 Declaration expected but '.' found
C:\Projetos\Componentes\ACBrTrunk2\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fast\ACBrNFeDANFEFR.pas(486) Error: E2070 Unknown directive: 'TACBrNFeDANFEFR'
C:\Projetos\Componentes\ACBrTrunk2\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fast\ACBrNFeDANFEFR.pas(486) Error: E2029 Declaration expected but '.' found
C:\Projetos\Componentes\ACBrTrunk2\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fast\ACBrNFeDANFEFR.pas(513) Error: E2070 Unknown directive: 'TACBrNFeDANFEFR'
C:\Projetos\Componentes\ACBrTrunk2\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fast\ACBrNFeDANFEFR.pas(513) Error: E2029 Declaration expected but '.' found
C:\Projetos\Componentes\ACBrTrunk2\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fast\ACBrNFeDANFEFR.pas(524) Error: E2070 Unknown directive: 'TACBrNFeDANFEFR'
C:\Projetos\Componentes\ACBrTrunk2\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fast\ACBrNFeDANFEFR.pas(524) Error: E2029 Declaration expected but '.' found
C:\Projetos\Componentes\ACBrTrunk2\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fast\ACBrNFeDANFEFR.pas(551) Error: E2029 ';' expected but '.' found
C:\Projetos\Componentes\ACBrTrunk2\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fast\ACBrNFeDANFEFR.pas(553) Error: E2029 Declaration expected but end of file found
C:\Projetos\Componentes\ACBrTrunk2\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fast\ACBrNFeDANFEFR.pas(100) Error: E2065 Unsatisfied forward or external declaration: 'TACBrNFeDANFEFR.ImprimirEVENTO'
C:\Projetos\Componentes\ACBrTrunk2\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fast\ACBrNFeDANFEFR.pas(101) Error: E2065 Unsatisfied forward or external declaration: 'TACBrNFeDANFEFR.ImprimirEVENTOPDF'
C:\Projetos\Componentes\ACBrTrunk2\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fast\ACBrNFeDANFEFR.pas(102) Error: E2065 Unsatisfied forward or external declaration: 'TACBrNFeDANFEFR.ImprimirINUTILIZACAO'
C:\Projetos\Componentes\ACBrTrunk2\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fast\ACBrNFeDANFEFR.pas(103) Error: E2065 Unsatisfied forward or external declaration: 'TACBrNFeDANFEFR.ImprimirINUTILIZACAOPDF'
C:\Projetos\Componentes\ACBrTrunk2\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fast\ACBrNFeDANFEFRReg.pas(1970) Fatal: F2063 Could not compile used unit 'ACBrNFeDANFEFR.pas'
Compilation failure
Erro ao compilar o pacote "ACBr_NFeDanfeFR.dpk".

 

Share this post


Link to post
Share on other sites
17 minutos atrás, cesarliws disse:

Eu corrigi aqui e já instalei, valeu!

Com certeza quando for fazer update o svn vai marcar esse item como não atualizável e dai não vai mais baixar!

faça um revert nos fontes


Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP

Share this post


Link to post
Share on other sites
8 minutos atrás, Juliomar Marchetti disse:

Com certeza quando for fazer update o svn vai marcar esse item como não atualizável e dai não vai mais baixar!

faça um revert nos fontes

Tranquilo, faço isto quando for atualizar novamente.

Share this post


Link to post
Share on other sites
Em 16/09/2015 at 01:13, Juliomar Marchetti disse:

Está falando do trunk ou trunk2?

Trunk2

 

Atualizei hoje novamente, e o mesmo erro.. 

"ACBr_SATExtratoESCPOS.dpk(32) Fatal: E2202 Required package 'PCN2' not found
Compilation failure
Erro ao compilar o pacote "ACBr_SATExtratoESCPOS.dpk"."

 

Eu consigo instalar manual, mas o ideal era fazer tudo pelo instalador, alguma ideia de como resolver?

 

 

Abraço

 

 


--

Thiago Filiano 

[email protected]

11 98507-1103

Share this post


Link to post
Share on other sites
10 horas atrás, Thiago Filiano Rosa disse:

Regys, retifico eu post.

Na versão mais recente do instalador, tem uma opção que ao selecionar faz a limpeza de arquivos antigos, ao que indica, ela vai mais a fundo doque o .bat que tem na pasta, e ao instalar com essa opção, foi SUCESSO.

Sim, eu coloquei essa opção para limpar o ACBr em todos os drives de disco, ao contrario do .bat que precisa ser rodado em cada um separadamente, se você tem mais de um drive de disco essa foi a diferença.


Equipe ACBr

Régys Borges da Silveira

http://www.regys.com.br

certificacao delphicertificacao delphi

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...