Jump to content

click.png click.png click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

Arquivo de schema não informado


  • Este tópico foi criado há 1528 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Boa tarde,

Hoje migrei  a  NFCe para o trunk 2, mas estou com o problema do erro:

Arquivo de schema não informado.

ja defini no componente,  informei em tempo de execução e nada, da o erro e não gera o xml.

EX: acbrnfe1.Configuracoes.arquivos.Pathschemas:=edit_chemas.Text;

Alguém tem alguma sugestão.

Obrigado

 

Link to comment
Share on other sites

Bom dia Regys,

sim eu utilizo um arquivo de configurações .INI como no exemplo do acbr, logo que abro a aplicação passo os parametros ao componente,

tentei até mesmo na hora de gerar a NFE informando novamente a pasta, mas não resolveu, da mesma forma faço na NFe e não da problemas,

apenas na NFCe. ja tentei assim

acbrnfe1.configuracoes.arquivos.pathschemas:='c:\centcons\schemas\ve310';

também não acatou...

criei um display para ver se o componente estava recebendo o path, e me mostrou o path normal..

utilizei os esquemas da pasta ...\exemplos\schemas\nfe  como o Ítalo citou em outro topico

o erro ocorre no fonte AcbrDfeSSL na linha 343

function TDFeSSL.Validar(const ConteudoXML: String; ArqSchema: String;
  out MsgErro: String): Boolean;
begin
  if EstaVazio(ArqSchema) then
    raise EACBrDFeException.Create('Arquivo de Schema não especificado');

utilizo capicom, delphi7 e windows7 profissional original

 

Edited by centuryinf
Link to comment
Share on other sites

  • Membros Pro
36 minutos atrás, centuryinf disse:

o erro ocorre no fonte AcbrDfeSSL na linha 343

function TDFeSSL.Validar(const ConteudoXML: String; ArqSchema: String;
  out MsgErro: String): Boolean;
begin
  if EstaVazio(ArqSchema) then
    raise EACBrDFeException.Create('Arquivo de Schema não especificado');

utilizo capicom, delphi7 e windows7 profissional original

 

Bom dia.

É certo que não é um problema no componente. Eu uso tanto na NFe e NFCe e não tenho problemas, e o demo é uma prova concreta que essa parametrização do caminho dos Schemas funciona corretamente. 

  • Like 1
Equipe ACBr Sérgio Assunção
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

[email protected]

Link to comment
Share on other sites

Bom dia senhores, o meu problema consegui identificar, no próprio fonte em determinado lugar ele estava setando o componente para usar a versao 3.0 e nao 3.1, após isso passou a validar normalmente. Um detalhe besta que de tanto checar o fonte acaba passando desapercebido.

Obrigado pela ajuda.

Link to comment
Share on other sites

  • 1 year later...
  • Este tópico foi criado há 1528 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.