Jump to content

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png click.png click.png

Dúvida com frete


  • Este tópico foi criado há 1969 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Boa noite, estou testando a integração do meu sistema com o ACBR Monitor Plus. 

Eu havia conseguido emitir algumas NFCe anteriormente mas agora está me retornando o seguinte erro:

CStat=753
XMotivo=Rejeição: NFC-e com Frete

Não consegui enxergar o erro.

Em anexo segue o arquivo log.txt onde eu passo um ini com modFrete=9 (ou seja, sem frete), mas depois o XML gerado pelo ACBR está com o valor 0 (zero)

Estou anexando tanto o log quanto o XML gerado.

alguma dica?

Obrigado

log.txt

35160406055666000123650010000000021000000028-nfe.xml

Link to comment
Share on other sites

Boa noite Régys

Estou usando a versão ACBRMonitorPlus 0.3.04.1 - ACBR 0.9.0a

Fiz algumas mudanças e testes com outros produtos, a mensagem de retorno até muda pois dá problema na validação antes, que é o caso abaixo. Mas como acredito que o problema seja o mesmo estou deixando neste tópico.
O que acredito ser problema, ou pelo menos não estou sabendo como proceder, é que eu jogo um arquivo *.ini mas o XML gerado e enviado pelo ACBRMonitorPlus não está condizente em alguns campos.
Se for problema de nome de no arquivo INI existe algum documento que me mostre a nomenclatura correta para todas as partes??

Por exemplo, no caso abaixo, estou setando o CRT para 1 pois meu cliente é Simples Nacional. No log do próprio ACBR dá pra ver que chega o campo como 01, mas no XML gerado fica como 3 que é para regime normal. 
Mesmo comportamento para modFrete em que coloco 9 no INI e sai 0 no XML.
Estou anexando o log e o XML gerado (informado) pelo log.

Esta versão eu compilei na terça-feira pelo Lazarus e joguei o exe na pasta que tinha do meu ACBRMonitorPlus. Existe algum outro procedimento pra fazer???

Desde já obrigado!
 

log.txt

35160406055666000123650010000000121000000121-nfe.xml

Link to comment
Share on other sites

  • Consultores

Há tá!

então sugiro a entrar na sessão de downloads já que é do SAC e faça o download da versão última com o instalador e refaça seus testes

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil
Link to comment
Share on other sites

  • Moderadores
Em 15/04/2016 at 22:21, tiagopicon disse:

[...]
Estou usando a versão ACBRMonitorPlus 0.3.04.1 - ACBR 0.9.0a

Fiz algumas mudanças e testes com outros produtos, a mensagem de retorno até muda pois dá problema na validação antes, que é o caso abaixo. Mas como acredito que o problema seja o mesmo estou deixando neste tópico.
O que acredito ser problema, ou pelo menos não estou sabendo como proceder, é que eu jogo um arquivo *.ini mas o XML gerado e enviado pelo ACBRMonitorPlus não está condizente em alguns campos.
[...]

Boa tarde!

O campo para preenchimento do código CRT para Simples Nacional deve ser preenchido conforme abaixo

CRT=1   e não CRT=01  

Quanto ao frete (visualizado no log2, você continua informando o modFrete=9.
Teste sem informar este campo.

Quanto a rejeição do log1 "XMotivo=Rejeição: CFOP não permitido para o CST informado [nItem:1]" 
É porque você preencheu cfop 5102 (Venda normal com tributação pelo ICMS e no CST vc informou CST=101 (Aqui a Sefaz entende que é com cobrança de subst. tributária, logo estaria errado o CFOP). 

Corrija o CRT e não informe o frete e tente como simples nacional e poste caso encontre novo problema.


logoacbr.pngConheça o Portal do Projeto ACBr

Ajude o Projeto ACBr crescer - Assine o SAC ACBr
Assine um dos planos de longa duração do SAC ACBr, obtenha Descontos Especiais, Parcele no Cartão e ainda ganhe Brindes Exclusivos. Saiba mais aqui

Conheça o ACBrLib, o ACBr de forma nativa para qualquer linguagem de programação. Saiba mais aqui

 

 

 

 

Link to comment
Share on other sites

Boa noite Kiko. 

Fiz conforme sugeriu, mas agora o ACBR não está montando o XML para envio. Pelo menos na pasta Logs nada é criado (nas outras vezes era)

Acertei o CRT e retirei o modFrete. Sobre o CFOP foi justamente o que a contadora do meu cliente passou, mas testei com outro produto e outra CFOP agora. Porém o erro não está chegando nesta parte de rejeição de CFOP. Recebo o erro abaixo: 

ERRO: Falha na validação dos dados da nota: 12004

Element '{http://www.portalfiscal.inf.br/nfe}ICMSSN' is unexpected according to content model of parent element '{http://www.portalfiscal.inf.br/nfe}ICMS'.
Expecting: {http://www.portalfiscal.inf.br/nfe}ICMS00, {http://www.portalfiscal.inf.br/nfe}ICMS10, {http://www.portalfiscal.inf.br/nfe}....
 

Vale ressaltar que já fiz alterações do tipo CSOSN ao invés de CST, já cheguei a testar sem o campo origem e algumas outra variações...

Em anexo o arquivo de log do ACBR com o INI passado dentro do comando e o respectivo erro abaixo.

Qualquer dica, orientação é bem-vinda

Obrigado

log.txt

Link to comment
Share on other sites

  • Moderadores

Bom dia @tiagopicon, observe que vc passou para CRT=1, Simples Nacional, logo vc precisa informar o CSOSN.

[ICMS001]
Origem=0
CST=102    //Informação errada. Deve informar CSOSN=
ValorBase=391,97 //Não deve constar.
Aliquota=0             //Não deve constar.
Valor=0                 //Não deve constar. 

Forma correta:

Citar

[ICMS001]
Origem=0
CSOSN=102
[TOTAL]
...

 

 


logoacbr.pngConheça o Portal do Projeto ACBr

Ajude o Projeto ACBr crescer - Assine o SAC ACBr
Assine um dos planos de longa duração do SAC ACBr, obtenha Descontos Especiais, Parcele no Cartão e ainda ganhe Brindes Exclusivos. Saiba mais aqui

Conheça o ACBrLib, o ACBr de forma nativa para qualquer linguagem de programação. Saiba mais aqui

 

 

 

 

Link to comment
Share on other sites

Boa noite Kiko. Tentei sua sugestão, mas sem sucesso. No log em anexo existem 2 tentativas, uma informando na seção Total os seguintes campos

BaseICMS=391,97
ValorICMS=0,00

 

e uma outra tentativa (ultima) sem os campos. O resultado é o mesmo de ontem, no mesmo campo inclusive.

Qualquer dica é bem-vinda

Obrigado
 

log.txt

Apenas para complementar tentei agora também sem os campos que estavam em branco na forma de pagamento.

Mas o resultado foi o mesmo, em anexo o ultimo log

log.txt

Link to comment
Share on other sites

  • Consultores

Boa noite

Acho que deva ter algum problema em sua instalação do Monitor!

Sugiro efetuar um backup da pasta, desinstalar, excluir completamente e baixar novamente e instalar no seu micro e refazer os testes!

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil
Link to comment
Share on other sites

  • Moderadores

Boa noite!

O arquivo deste último logo está mais próximo do correto. Acrescente as aspas que irá gerar o arquivo.

Citar

NFE.CriarEnviarNFE("[Identificacao]
....
....
tpag=1
vpag=391,97
")

Fazendo esta alteração, você conseguirá gerar o arquivo. 

Depois vc tem que ver outras situações, exemplo: Vc está informando CFOP 5405 (Prod. Subst. Trib) neste caso o CSOSN é 500 e não 102.
 


logoacbr.pngConheça o Portal do Projeto ACBr

Ajude o Projeto ACBr crescer - Assine o SAC ACBr
Assine um dos planos de longa duração do SAC ACBr, obtenha Descontos Especiais, Parcele no Cartão e ainda ganhe Brindes Exclusivos. Saiba mais aqui

Conheça o ACBrLib, o ACBr de forma nativa para qualquer linguagem de programação. Saiba mais aqui

 

 

 

 

Link to comment
Share on other sites

  • Moderadores

Agora vc alterou algo que não devia.

No grupo ICMS para o produto 1 o correto é [ICMS001]  você alterou por [ICMS102] (Isto não estava no teu log anterior. Não tem que mexer aqui.

o Grupo ICM fica assim 

[ICMS001]
Origem=0
CSOSN=500   // Lembrando que 500 é para produtos com subst. tributária. (cfop 5405) e 102 para produtos tributados  (cfop 5102) 


Exemplo com produto tributado. CFOP 5102
[ICMS001]
Origem=0
CSOSN=102

 

Obs.: Se vc não tivesse alterado o nome do grupo [ICMS001]  para [ICMS102] já teria criado o teu XML.
Por favor corrija apenas o nome do grupo desta vez e teste. Do contrário vc vai ficar criando outras situações. 

Boa sorte!

 


logoacbr.pngConheça o Portal do Projeto ACBr

Ajude o Projeto ACBr crescer - Assine o SAC ACBr
Assine um dos planos de longa duração do SAC ACBr, obtenha Descontos Especiais, Parcele no Cartão e ainda ganhe Brindes Exclusivos. Saiba mais aqui

Conheça o ACBrLib, o ACBr de forma nativa para qualquer linguagem de programação. Saiba mais aqui

 

 

 

 

Link to comment
Share on other sites

Boa noite Kiko.

Apenas para reportar, fiz o que você falou e de primeira não foi pois ele reclamou do frete novamente. Daí fiz outro teste adicionando o modFrete=9, daí foi. 

Portanto o modFrete=9 (que significa sem frete) é obrigatório informar.

Em anexo o log apenas caso queira conferir, mas da minha parte deu certo.

Obrigado pela ajuda e paciência

 

log.txt

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.