Jump to content

Promoção de Natal SAC Mensal

Contrate e ganhe 1 Kit agenda + Caneta
Saiba mais

LANÇAMENTO
Curso Completo - Dominando o ACBrMonitor

Conheça o Curso

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Soft Design

Criptografia '24' Certificado A3

Recommended Posts

Boa tarde pessoal,

Já passei por esta situação com o certificado A1, porém olhando o fórum resolvi sem problemas, fazendo a instalação no XP e exportando com as chaves, porém acaba de me acontecer com um cliente o mesmo erro "Não há suporte para o tipo de Provedor de Serviços de Criptografia '24'" porém ele está com um certificado A3. 

Liguei na certificado e falaram que todos os certificado agora tem que ser com cadeia de 2048 e que agora só será feito assim.

Alguém já passou por esta situação e pode auxiliar?

Share this post


Link to post
Share on other sites
44 minutos atrás, Soft Design disse:

Boa tarde pessoal,

Já passei por esta situação com o certificado A1, porém olhando o fórum resolvi sem problemas, fazendo a instalação no XP e exportando com as chaves, porém acaba de me acontecer com um cliente o mesmo erro "Não há suporte para o tipo de Provedor de Serviços de Criptografia '24'" porém ele está com um certificado A3. 

Liguei na certificado e falaram que todos os certificado agora tem que ser com cadeia de 2048 e que agora só será feito assim.

Alguém já passou por esta situação e pode auxiliar?

Tente usar a nova opção de biblioteca de assinatura de XML:

ACBrNFe1.Configuracoes.Geral.SSLLib := libWinCrypt;
ACBrNFe1.Configuracoes.Geral.SSLXmlSignLib := xsLibXML2;

Tópicos relacionados:

 


Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites
1 hora atrás, Soft Design disse:

Obrigado BigWings.

Mas o SSLXmlSignLib não aparece a opção de setar xsLibXML2.

Atualizei os fontes do ACBr e mesmo assim não apareceu...

Tudo normal aqui...

Está instalado pelo ACBrIntall_Trunk2?

Tentou marcar a opção de remover arquivos antigos do disco?


Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites
35 minutos atrás, BigWings disse:

Tudo normal aqui...

Está instalado pelo ACBrIntall_Trunk2?

Tentou marcar a opção de remover arquivos antigos do disco?

Esta sim..

Inclusive já foi instalado o trunk2 direto nesta maquina que é nova, então não tem arquivos antigos...

Share this post


Link to post
Share on other sites
36 minutos atrás, Soft Design disse:

Esta sim..

Inclusive já foi instalado o trunk2 direto nesta maquina que é nova, então não tem arquivos antigos...

Deve ter algo errado aí na instalação...

Em qual revisão está o fonte do ACBr?

Você disse que a opção não aparece, imagino que esteja tentando fazer via Object Inspector...

libxml2.png

Tentou fazer via código?


Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites
1 hora atrás, BigWings disse:

Deve ter algo errado aí na instalação...

Em qual revisão está o fonte do ACBr?

Você disse que a opção não aparece, imagino que esteja tentando fazer via Object Inspector...

libxml2.png

Tentou fazer via código?

Exato, tentei pelo Object Inspector e via código.. 

Como faço para ver em qual revisão esta? (Apesar que mandei hoje mesmo atualizar).

 

Mas, alterando as configurações para a seguinte:

  SSLLib: libWinCrypt
  SSLCryptLib: cryWinCrypt

  SSLHttpLib: httpWinHttp

  SSLXmlSignLib: xsMsXml

 

Ele começou acessar o certificado, pedindo PIN, porém o erro altera para:

  O atributo ‘Algorithm’ tem valor ‘http://www.w3.org/2001/04/xmldsig-more#rsa-sha256‘ que não corresponde ao valor fixo ‘http://www.w3.org/2000/09/xmldsig#rsa-sha1‘ no DTD ou no esquema.

 

Já pesquisei e fiz de tudo e o erro persiste. 

  - Coloquei as dll msxml5 tanto na pasta do sistema quanto no System32, registrei, reiniciei o pc e persiste o erro.

 

De qualquer forma travo em um dos dois...

Share this post


Link to post
Share on other sites
8 minutos atrás, Soft Design disse:

Exato, tentei pelo Object Inspector e via código.. 

Como faço para ver em qual revisão esta? (Apesar que mandei hoje mesmo atualizar).

Se você for no "Show log" a revisão atual deve estar em negrito.

Abra a unit ACBr\Fontes\ACBrDFe\ACBrDFeSSL.pas e verifique a declaração do tipo, se estiver atualizado deve estar assim:

  TSSLXmlSignLib = (xsNone, xsXmlSec, xsMsXml, xsMsXmlCapicom, xsLibXml2);

 


Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites
20 minutos atrás, BigWings disse:

Se você for no "Show log" a revisão atual deve estar em negrito.

Abra a unit ACBr\Fontes\ACBrDFe\ACBrDFeSSL.pas e verifique a declaração do tipo, se estiver atualizado deve estar assim:

  TSSLXmlSignLib = (xsNone, xsXmlSec, xsMsXml, xsMsXmlCapicom, xsLibXml2);

 

Abrindo este .pas esta exatamente como citou, mas vi que o .dcu que esta no Lib esta com a versão anterior, pode ser isso? Não estou encontrando a nova, mando atualizar e também não atualiza...

Pelo o que vi não esta pegando deste arquivo as configurações...

Share this post


Link to post
Share on other sites
1 hora atrás, Soft Design disse:

Abrindo este .pas esta exatamente como citou, mas vi que o .dcu que esta no Lib esta com a versão anterior, pode ser isso? Não estou encontrando a nova, mando atualizar e também não atualiza...

Pelo o que vi não esta pegando deste arquivo as configurações...

O .dcu é compilado no momento da instalação.

Se você realmente mandou apagar os arquivos antigos ele deveria ter sido apagado e recriado na compilação pelo ACBrInstall_Trunk2.exe.


Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites
5 minutos atrás, BigWings disse:

O .dcu é compilado no momento da instalação.

Se você realmente mandou apagar os arquivos antigos ele deveria ter sido apagado e recriado na compilação pelo ACBrInstall_Trunk2.exe.

Reinstalei o ACBr e esta parte da configuração OK.

Agora quando vou testar no cliente mudou o erro.

Erro ao emitir agora: "Falha em obter Provedor de Criptografia do Certificado. Erro: 8009001B , erro $8009001B"

Share this post


Link to post
Share on other sites
2 horas atrás, Soft Design disse:

O atributo ‘Algorithm’ tem valor ‘http://www.w3.org/2001/04/xmldsig-more#rsa-sha256‘ que não corresponde ao valor fixo ‘http://www.w3.org/2000/09/xmldsig#rsa-sha1‘ no DTD ou no esquema.

 

cara eu tive esse erro quando atualizei os componentes do Acbr mas não atualizei as DLL´s  msxml5.dll e a msxml5r.dll, verifique se você está usando a versão mais recente delas.

 

Edited by edsonsimao2

Share this post


Link to post
Share on other sites
46 minutos atrás, Soft Design disse:

Reinstalei o ACBr e esta parte da configuração OK.

Agora quando vou testar no cliente mudou o erro.

Erro ao emitir agora: "Falha em obter Provedor de Criptografia do Certificado. Erro: 8009001B , erro $8009001B"

Quanto a isso não vou poder ajudar.

Tem outros tópicos com erro parecido, talvez não se aplique ao seu caso já que está usando a nova biblioteca, mas faça uma busca.


Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites
11 minutos atrás, BigWings disse:

Quanto a isso não vou poder ajudar.

Tem outros tópicos com erro parecido, talvez não se aplique ao seu caso já que está usando a nova biblioteca, mas faça uma busca.

Ok.. Estou procurando porém não encontrei nada até o momento.

 

Obrigado.

Share this post


Link to post
Share on other sites
12 minutos atrás, shennamo disse:

No meu caso, quando passei por isso, consegui resolver instalando um Software do certificado ( instaladorvalid24 )

Com certificado A3?

Conhecia essa solução apenas para A1.


Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Share this post


Link to post
Share on other sites
Em 06/12/2017 at 17:00, BigWings disse:

Quanto a isso não vou poder ajudar.

Tem outros tópicos com erro parecido, talvez não se aplique ao seu caso já que está usando a nova biblioteca, mas faça uma busca.

Acbrnfe não suporte criptografia com 2048 bits? Segundo o suporte do certificado A3 essa mensagem de erro de "Falha em obter provedor de cryptografia do certificado 8009001B" se refere a isso! Alguma solução? Já estou usando wincrypt com xml2

Share this post


Link to post
Share on other sites
7 minutos atrás, gutopmc disse:

Acbrnfe não suporte criptografia com 2048 bits? Segundo o suporte do certificado A3 essa mensagem de erro de "Falha em obter provedor de cryptografia do certificado 8009001B" se refere a isso! Alguma solução? Já estou usando wincrypt com xml2

Bom dia, gutopmc.

Os fontes estão atualizados? Já tentou fazer um teste do certificado para ver se o mesmo está funcionando?


Equipe ACBr

Felipe Eduardo Resende Mesquita

Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

 

 

 

Share this post


Link to post
Share on other sites
4 minutos atrás, Felipe E. Resende Mesquita disse:

Bom dia, gutopmc.

Os fontes estão atualizados? Já tentou fazer um teste do certificado para ver se o mesmo está funcionando?

Bom dia! Consulta de status do serviço funciona, somente na hora de assinar que da o erro.

Share this post


Link to post
Share on other sites
1 minuto atrás, gutopmc disse:

Bom dia! Consulta de status do serviço funciona, somente na hora de assinar que da o erro.

Tente desinstalar o certificado e realizar a instalação novamente com o instalador da Prodemge:
https://wwws.prodemge.gov.br/images/Aplicativos/INSTALADORES_PRODEMGE/instalador_prodemge_cliente_A3_v1.4.exe


Equipe ACBr

Felipe Eduardo Resende Mesquita

Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

 

 

 

Share this post


Link to post
Share on other sites
1 minuto atrás, gutopmc disse:

Verifiquei que o windows não esta atualizado. Pode ser isso?

Sugiro também que instale todas as atualizações do windows.


Equipe ACBr

Felipe Eduardo Resende Mesquita

Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...