Jump to content

dev botao

Erro NFe 4.00 + TLS 1.2


Go to solution Solved by BigWings,
  • Este tópico foi criado há 2245 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Olá a todos,

Estou implementando a NFe 4.00 em minha aplicação, para tal estou realizando os testes no ambiente de Homologação com as seguintes especificações:

SSLCryptLib = cryWinCrypt
SSLHttpLib = httpWinHttp
SSLLib = libWinCrypt
SSLXMLSignLib = xsMsXml

Se eu coloco o SSL_Type como "LT_all" o envio da NFe autoriza normalmente, mas se eu coloco como "LT_TLSv1_2" recebo o erro em anexo.

erro.JPG

Estou testando no Windows 7 ... Alguém poderia me ajudar?

Desde já agradeço a atenção de todos

Edited by doidopb
posicionar melhor imagem de erro
Link to comment
Share on other sites

  • Membros Pro
53 minutos atrás, André Ferreira de Moraes disse:

Em outros estados vc consegue usar a configuração TLS 1.2 ?

Então André... Eu atuo no Rio e os certificados que possuo para testes são todos do Rio, por isso só consumo o WebService do Rio para envio das NFes.

Posso usar o de outro Estado ???

Link to comment
Share on other sites

  • Membros Pro
5 minutos atrás, André Ferreira de Moraes disse:

Vc pode testar o status de serviço de qualquer estado.

Testei o status do RJ... Dá o mesmo erro... Na verdade todos os estados dão o mesmo erro, em Produção e Homologação. É essa opção mesmo que tenho que marcar para a versão 4.00 (LT_TLSv1_2)????

Link to comment
Share on other sites

  • Membros Pro
5 horas atrás, José M. S. Junior disse:

Bom dia, a configuração recomendada seria:

image.png

O Windows precisa estar atualizado... WinCrypt utiliza DLLs nativas do Windows...

Oi José, tudo bom?

Vamos lá... Formatei um micro com Windows 7 Ultimate 32 Bits, máquina mais comum entre meus clientes... Logo em seguida mandei atualizar TUDO pelo Windows Update, inclusive atualizações opcionais de drivers. Segue print em anexo.update.jpg

Também segui a sua dica, colocando as especificações acima, o que me fez descobrir algo... Se eu marcar o XML Sign Lib como xsLibXml2, simplesmente o componente REMARCA sozinho o SSL Lib como libCustom, pode testar ai, ele não deixa mudar,  minha revision é a 14572.

Pois bem, com todas as opções seguindo a sua dica, exceto a SSL Lib conforme já expliquei, continuo recebendo o mesmo erro, lembrando que se eu marco SSLType como LT_all funciona.

Edited by doidopb
posicionar melhor a imagem no texto
Link to comment
Share on other sites

  • Moderadores

Olá. Mesmo ficando como Custom, pode alterar para WinCrypt.... Por aqui realizando a consulta de Status com UF: RJ utilizando TLS 1.2 está obtendo retorno... Experimentou configurando como OpenSSl?

Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Membros Pro
5 horas atrás, José M. S. Junior disse:

Olá. Mesmo ficando como Custom, pode alterar para WinCrypt.... Por aqui realizando a consulta de Status com UF: RJ utilizando TLS 1.2 está obtendo retorno... Experimentou configurando como OpenSSl?

Então José...Esqueci de mencionar, ao marcar o SSLLib de libCustom para libWinCrypt, o componente automaticamente muda o SSLXMLSignLib para xsMsXml. Daí ao mudar o SSLXMLSignLib para xsLibXml2 ele automaticamente muda o SSLLib para libCustom e por aí vai. O componente não deixa colocar como você sugeriu. Tal comportamente é repetido inclusive nos Combobox do ACBrNFe_demo que fazem referência a tais configurações.

Usando o OpenSSL conforme sugeriu eu consegui enviar a NFe 4.00 sem problemas marcando o SSL_Type = LT_TLSv1_2. O mesmo vale para a consulta, usando o ACBrNFe_demo, se marcar o OpenSSL +LT_TLSv1_2 consulta sem nenhum erro, já se marcar Wincrypt + LT_TLSv1_2 dá o mesmo erro citado no início do tópico

E o problema é que no cliente que vou implantar não posso usar OpenSSL, pois o mesmo usa certificado A3.

 

 

Edited by doidopb
Link to comment
Share on other sites

  • Moderadores
  • Solution
10 horas atrás, doidopb disse:

Então José...Esqueci de mencionar, ao marcar o SSLLib de libCustom para libWinCrypt, o componente automaticamente muda o SSLXMLSignLib para xsMsXml. Daí ao mudar o SSLXMLSignLib para xsLibXml2 ele automaticamente muda o SSLLib para libCustom e por aí vai. O componente não deixa colocar como você sugeriu. Tal comportamente é repetido inclusive nos Combobox do ACBrNFe_demo que fazem referência a tais configurações.

Isso acontece por você estar com os fontes desatualizados.

O padrão libWinCrypt foi alterado para definir SSLXmlSignLib como xsLibXML2 e não mais xsMsXML como está pra você.

A configuração SSLLib não é importante, ela serve apenas de "atalho" para definir as outras três, então mesmo ficando em libCustom deveria funcionar, apesar de o ideal para fazer testes seria estar com os fontes atualizados.

10 horas atrás, doidopb disse:

Usando o OpenSSL conforme sugeriu eu consegui enviar a NFe 4.00 sem problemas marcando o SSL_Type = LT_TLSv1_2. O mesmo vale para a consulta, usando o ACBrNFe_demo, se marcar o OpenSSL +LT_TLSv1_2 consulta sem nenhum erro, já se marcar Wincrypt + LT_TLSv1_2 dá o mesmo erro citado no início do tópico

Você já testou usando o ACBrMonitorPLUS? Seria uma forma de identificar se o problema está no ambiente (Windows/certificado) ou na compilação/distribuição.

Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

  • Membros Pro

Olá BigWings, tudo bom?

Atualizei os componentes conforme sugeriu e RESOLVEU o problema.

Sobre o padrão libWinCrypt, após a atualização realmente alterou o padrão do SSLXMLSignLib para xsLibXML2 conforme você disse. Quanto ao  SSLLib, ele sempre muda para libCustom sozinho, tanto no componente quanto nos Combobox do ACBrNFe_demo.

Obrigado pela ajuda.

Abraços

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.