Jump to content

Delphi chamada_delphi.png acbr.png

C6 chamada_c6.png botao.png

Out of memory na geracao ReInf


jmcsoftware
  • Este tópico foi criado há 1452 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

italo fiz o teste com o demo do acbr e ocorre o mesmo de te out of memory

O erro acontece na seguinte situacao:

1) envio o arquivo de alteracao do registro r1000 para eliminar os dados. ( ai retorna que o arquivo foi enviado e recebido normalmente )

2) sem fechar a tela eu gero o xml do r1000 / r2010 / r2099 e quando tento enviar demora muito e retorna o erro de out of memory

ACBR Atualizado com a versao 15210

 

ERRO_REINF.png

Link to comment
Share on other sites

  • Consultores

jmcsoftware,

Favor atualizar os fontes e faça novos testes.

Pois fiz o mesmo que você e não tive problemas com out of memory.

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • Membros Pro

italo apos a atualizacao 15217 ja consegui enviar e nao deu mais o erro.

Consegui ate pegar o protocolo com o envio , mas esta com seguinte erro:

Parâmetro Número de Inscrição do Contribuinte obrigatório não informado

Segue anexo arquivo enviado se puder analisar agradeco pela ajuda.

 

20180528091329-env-lot.xml

20180528091332-rec-soap.xml

Link to comment
Share on other sites

  • Membros Pro

sim estava em processamento e depois eu consultei o protocolo e me retornou:

 Evento: R5011
   Id...........: ID1570996228
   Cód Retorno..: 1
   Descrição....: ERRO
 **Ocorrencias
   Tipo............: 1
   Local Erro Aviso: 
   Código Resp.... : MS0008
   Descricao Resp..: Parâmetro Número de Inscrição do Contribuinte obrigatório não informado.

Link to comment
Share on other sites

  • Membros Pro

italo mais uma duvida na consulta protocolo.

Nao estou conseguindo pegar o retorno do infocrTom , o q estou fazendo de errado ? Da erro de acess violation no xml em anexo no for do infocrtom..count 

            with InfoTotalContrib do begin
               for i := 0 to InfoTotalContrib.RTom.Count -1 do begin


                  for z:= 0 to InfoTotalContrib.RTom.Items.infoCRTom.Count -1 do begin


                     qryReciboCNPJCRTom.AsString:=infoTotalContrib.RTom.Items.infoCRTom.Items[z].CRTom;
                     qryReciboCNPJVlrCRTom.AsFloat:=InfoTotalContrib.RTom.Items.infoCRTom.Items[z].VlrCRTom;
                     qryReciboCNPJVlrCRTomSusp.AsFloat:=InfoTotalContrib.RTom.Items.infoCRTom.Items[z].VlrCRTomSusp;
                  end;
               end;
            end;
 

Reinf-sit.xml

Link to comment
Share on other sites

  • Consultores

Bom dia,

Fiz uma alteração, acredito que agora vai funcionar, aguarde mais um pouco, pois vou ver se tem mais alguma coisa para ser feita ai envio tudo de uma vez.

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • Este tópico foi criado há 1452 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.