Jump to content

Assinatura Invalida - Erro 142 - Lote transmitido com sucesso sem processamento com sucesso


Flavio Ramires
Go to solution Solved by Flavio Ramires,
  • Este tópico foi criado há 1358 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Caros boa tarde.

Estou na batalha de alterar sistema para envio do eSocial, estou com o seguinte cenário:
1 - A geração do XML é feita atraves do sistema próprio;
2 - Com XML gerado, estou mandando para o exemploEsocial - ACBR, o XML gerado ( botão Carregar XML );
3 - O exemploEsocial carrega perfeitamente o arquivo, ai clico em Enviar;
3.1 - O exemploEsocial, assina, gera lote, envelopa o lote e transmite no Ambiente Homologação;
3.2 - Recebo um nº de protocolo de Lote recebido com sucesso;
4 - Ao consultar o Nº do protocolo vem o retorno : 142 - Assinatura de Evento Invalido.

No XML não tem acentos, nem cedilhas ou qualquer caracter especial;

Caso alguem tenha alguma ideia ou solução.

Link to comment
Share on other sites

  • Consultores

Bom dia Flávio,

Faça um teste usando somente o programa exemplo do componente.

Use ele para gerar, assinar, validar e enviar o XML do evento.

Depois consulte para ver se vai ocorrer o mesmo erro.

Se não ocorrer, com certeza o XML gerado pela sua aplicação esta incluindo algo no mesmo que não deveria.

  • Like 2
Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • Solution
15 horas atrás, Amarildo de Matos disse:

boa noite.. porque nao tenta fazer, com que o proprio acbr , assine o xml.

Então, a assinatura, envolopamento (SOAP) e transmissão estou fazendo com ACBR, apenas o XML que é gerado em sistema próprio.

3 horas atrás, Italo Jurisato Junior disse:

Bom dia Flávio,

Faça um teste usando somente o programa exemplo do componente.

Use ele para gerar, assinar, validar e enviar o XML do evento.

Depois consulte para ver se vai ocorrer o mesmo erro.

Se não ocorrer, com certeza o XML gerado pela sua aplicação esta incluindo algo no mesmo que não deveria.

Resolvido - o XML que o sistema proprio esta gerando estava com o Enter logo apos a UTF8....

Alterei a geração do XML e foi processado com sucesso...

 

  • Like 1
Link to comment
Share on other sites

  • Este tópico foi criado há 1358 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.