Jump to content

Assista click.png tectoy.png

C6 chamada_c6.png botao.png

Falha ao compilar ACBrMonitor PLUS 1.2.0.56


Rubinho
Go to solution Solved by José M. S. Junior,
  • Este tópico foi criado há 1113 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Boa tarde, pessoal!

Montei um ambiente limpo com Win7 e Lazarus apenas para compilar o ACBrMonitor e estou recebendo o erro abaixo:

"Suporte a "xsXmlSec" foi desativado por compilação {$DEFINE DFE_SEM_OPENSSL} ou {$DEFINE DFE_SEM_XMLSEC}"

Segui a risca todos os passos de instalação dos componentes. Ele compila, mas ao executar continua apresentando o erro acima.

Encontrei no forum uma dica que falava para comentar a linha: {.$DEFINE DFE_SEM_XMLSEC} do arquivo ACBr.inc, compila normalmente, mas ao testar e enviar algum arquivo de requisição (ENT.TXT) ele trava o Monitor e não faz nada.

Já procurei no fórum e não achei algo que pudesse me ajudar.

Se baixo o ACBrMonitor  compilado do site, tudo volta a funcionar normalmente.

Como posso resolver?

Link to comment
Share on other sites

  • Moderadores
26 minutos atrás, Rubinho disse:

Encontrei no forum uma dica que falava para comentar a linha: {.$DEFINE DFE_SEM_XMLSEC} do arquivo ACBr.inc, compila normalmente, mas ao testar e enviar algum arquivo de requisição (ENT.TXT) ele trava o Monitor e não faz nada. 

Já debugou pra ver exatamente em que ponto ele trava?

  • Like 1
Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

  • Fundadores

Verifique se você está usando as DLLs corretas ..

No Script do InnoSetup (ACBrMonitorPLUS.iss) você poderá ver quais DLLs copiamos para o instalador

  • Like 1
Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Membros Pro
22 minutos atrás, José M. S. Junior disse:

Boa tarde

Utilize as dlls da pasta do repositório em: C:\ACBr\DLLs\XMLSec\MinGW\32

Descomente a Diretiva: {$DEFINE USE_MINGW} neste caso...

Funcionou!

Muito obrigado, galera!!!

JR, valeu pela dica, obrigado!

  • Like 2
Link to comment
Share on other sites

  • Este tópico foi criado há 1113 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.