Jump to content

Compre o Delphi
Com até 30% de desconto
e parcelado em até 12x sem juros

Saiba Mais

Balança SM100 performance surpreendente

Tecnologia Japonesa   Teclado e Visor resistentes a água
Consumo inteligente de etiquetas   Baixo custo de manutenção
Comunicação Ethernet e WIFI independentes

Saiba mais

Impressora de Etiquetas ELGIN - L42 PRO

Protocolos PPLA, PPLB, ZPL, EPL (automático)
Porta USB padrão Opcionais: Ethernet, Serial, Paralela
Sensor de Etiquetas Móvel Garantia de 18 meses

Saiba mais

Marcelo Simon

BPe autorizado mas retornando erro

Recommended Posts

Boa tarde,
Por algumas vezes em meus testes estou recebendo este erro no envio do BPe:
 

Erro Interno: 0
Erro HTTP: 503
URL: https://hbpe.fazenda.mg.gov.br/bpe/services/BPeRecepcao

Porém o BPe é autorizado.

Sugerem alguma mudança nas configurações iniciais do componente (anexo imagem)?
Devo adotar por padrão quando receber um erro (503 por exemplo) consultar se o BPe foi autorizado? Normalmente como estão procedendo?

Vou anexar um caso desse onde o BPe foi emitido porém o erro 503 foi o retornado.

Obs.: Estou utilizando o ambiente de homologação.

Screenshot from 2019-05-28 16-34-36.png

Screenshot from 2019-05-28 16-31-23.png

31190519339415000112630290000000011000029055-bpe.xml 31190519339415000112630290000000011000029055-sit.xml 31190519339415000112630290000000011000029055-sit-soap.xml 31190519339415000112630290000000011000029055-ped-sit.xml 31190519339415000112630290000000011000029055-ped-sit-soap.xml 1-env-lot.xml 1-env-lot-soap.xml

Share this post


Link to post
Share on other sites
4 minutos atrás, ancker disse:

 

Boa tarde, ancker.

Tente alterar a propriedade SSLType para TLSv 1.2, aumente também o TimeOut.


Equipe ACBr

Felipe Eduardo Resende Mesquita

Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

 

 

 

Share this post


Link to post
Share on other sites

Bom dia!

Mesmo mudando o que foi recomendado tive o mesmo erro interno.
Quem está usando em produção está com este problema? Já notaram isso? Como procedem?


 

Share this post


Link to post
Share on other sites
59 minutos atrás, Marcelo Simon disse:

 

Bom dia, Marcelo Simon.

A SEFAZ de MG está sempre com problemas.  Esse erro geralmente é instabilidade na SEFAZ ou com a sua conexão.


Equipe ACBr

Felipe Eduardo Resende Mesquita

Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

 

 

 

Share this post


Link to post
Share on other sites

Bom dia Marcelo,

Pela mensagem de erro, me parece ser um problema no aguardo do retorno do envio.

O envio do BP-e é unitário, ou seja, é enviado um BP-e por vez, logo não existe a figura de Lote.

A modo de envio é síncrono, portanto temos o resultado do processamento já no retorno.

Se ao consultar é retornado que o BP-e foi processado com sucesso, ou seja, é retornado o protocolo de autorização, isso significa que o erro que esta ocorrendo é no retorno, por algum motivo a SEFAZ não esta realizado o retorno.

Sobre o erro 503.

Se ocorrer esse erro, você deve carregar o XML do BP-e com o LoadFromFile e em seguida executar o método Consultar, desta forma se o BP-e foi autorizado o XML que esta assinado recebera o protocolo de autorização, por fim basta imprimir o DABPE.

  • Like 1

Consultor SAC ACBr Italo Jurisato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...