Jump to content

Assista click.png tectoy.png

C6 chamada_c6.png botao.png

BP-e Problemas de Emissão entre 23:00 e 23:59


Go to solution Solved by Italo Giurizzato Junior,
  • Este tópico foi criado há 889 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Encontrei mais um problema na emissão:
Quando o BP-e é enviado entre: 23:00 até 00:00, retorna o erro de VALIDADE DO BP-e, Conforme Retorno abaixo:

OK: C:\sicaf\ACBrBPe\Logs\11191207835038000204630010000000201112314116-bpe.xml
Rejeicao: BP-e Normal com data de validade diferente de 1 ano da data de emissao
[Envio]
CStat=506
CUF=11
Msg=Rejeicao: BP-e Normal com data de validade diferente de 1 ano da data de emissao
NProt=
NRec=
TMed=0
VerAplic=RS20191021100423
Versao=RS20191021100423
XMotivo=Rejeicao: BP-e Normal com data de validade diferente de 1 ano da data de emissao
tpAmb=2

 

Agora o .INI: Observem que NO .INI, as datas são exatamente 1 ANO, porém, acredito que pelo motivo da UTC, ele deve comparar "Lá" no Portal, onde o horário É DIFERENTE!
Daí, gera o erro... PORÉM, onde o cliente está, pelo motivo do horário, deveria ser validado!
Confirmei ser isso, pois, gerei um .INI, onde a data de validade, coloquei ja PRÓXIMO DIA, e VALIDOU.... rsrs... "Claro, que no cliente, não poderia ser assim né?"


18/12/2019 23:13:32 - NFe.Versao
18/12/2019 23:13:32 - OK: 1.3.0.211
18/12/2019 23:14:11 - BPE.CriarEnviarBPe([infBPe]
versao=1.00
[Ide]
cUF=11
tpAmb=2
modelo=63
serie=01
nBP=000000020
cBP=11231411
modal=1
dhEmi=18/12/2019 23:14:11
tpEmis=1
.
.
.
[infPassagem]
cLocOrig=1100205
xLocOrig=PORTO VELHO                             
cLocDest=1300144
xLocDest=APUI
dhEmb=20/12/2019 21:30
dhValidade=18/12/2020
[infPassageiro]
xNome=MAGNO SANTANA TESTE BPE
CPF=14512382828
tpDoc=1
nDoc=4705912345
dNasc=
fone=1105912345
[email protected]
[infViagem001]
cPercurso=0
xPercurso=APUI-AM  X  PORTO VELHO-RO
tpViagem=00
tpServ=1
tpAcomodacao=1
tpTrecho=1
dhViagem=20/12/2019 21:30
dhConexao=

image.png.eba328d8e6fd377852a7ffb466e1dba5.pngimage.png.fdb5ee87246a919a93805b147ac982fb.png

4 minutos atrás, magnusistemas disse:

Encontrei mais um problema na emissão:
Quando o BP-e é enviado entre: 23:00 até 00:00, retorna o erro de VALIDADE DO BP-e, Conforme Retorno abaixo:

OK: C:\sicaf\ACBrBPe\Logs\11191207835038000204630010000000201112314116-bpe.xml
Rejeicao: BP-e Normal com data de validade diferente de 1 ano da data de emissao
[Envio]
CStat=506
CUF=11
Msg=Rejeicao: BP-e Normal com data de validade diferente de 1 ano da data de emissao
NProt=
NRec=
TMed=0
VerAplic=RS20191021100423
Versao=RS20191021100423
XMotivo=Rejeicao: BP-e Normal com data de validade diferente de 1 ano da data de emissao
tpAmb=2

 

Agora o .INI: Observem que NO .INI, as datas são exatamente 1 ANO, porém, acredito que pelo motivo da UTC, ele deve comparar "Lá" no Portal, onde o horário É DIFERENTE!
Daí, gera o erro... PORÉM, onde o cliente está, pelo motivo do horário, deveria ser validado!
Confirmei ser isso, pois, gerei um .INI, onde a data de validade, coloquei ja PRÓXIMO DIA, e VALIDOU.... rsrs... "Claro, que no cliente, não poderia ser assim né?"


18/12/2019 23:13:32 - NFe.Versao
18/12/2019 23:13:32 - OK: 1.3.0.211
18/12/2019 23:14:11 - BPE.CriarEnviarBPe([infBPe]
versao=1.00
[Ide]
cUF=11
tpAmb=2
modelo=63
serie=01
nBP=000000020
cBP=11231411
modal=1
dhEmi=18/12/2019 23:14:11
tpEmis=1
.
.
.
[infPassagem]
cLocOrig=1100205
xLocOrig=PORTO VELHO                             
cLocDest=1300144
xLocDest=APUI
dhEmb=20/12/2019 21:30
dhValidade=18/12/2020
[infPassageiro]
xNome=MAGNO SANTANA TESTE BPE
CPF=14512382828
tpDoc=1
nDoc=4705912345
dNasc=
fone=1105912345
[email protected]
[infViagem001]
cPercurso=0
xPercurso=APUI-AM  X  PORTO VELHO-RO
tpViagem=00
tpServ=1
tpAcomodacao=1
tpTrecho=1
dhViagem=20/12/2019 21:30
dhConexao=

image.png.eba328d8e6fd377852a7ffb466e1dba5.pngimage.png.fdb5ee87246a919a93805b147ac982fb.png

Só pra exemplificar, esse ini abaixo, foi validado, embora as datas estejam diferentes:
 

image.png.188780656100a3774377dd4e202e506a.png

Link to comment
Share on other sites

  • Consultores
  • Solution

Bom dia Magnu,

Primeiramente, peço que anexe o arquivo INI em vez colocar como parte da postagem.

Anexando a postagem fica mais curta e com o arquivo INI em anexo temos como realizar testes.

Segundo, o problema é que você não esta informando a hora da validade somente a data.

Veja:

dhEmb=20/12/2019 21:30   ===> aqui esta correto você esta informando a data e hora de embarque conforme o campo dhEmb pede.

dhValidade=19/12/2020     ===> aqui esta errado você esta informando somente a data da validade sendo que o campo dhValidade pede data e hora

Toda vez que o nome do campo começar com dh significa que temos que informar a data e hora.

Como você não informou a hora o monitor tomou como base o seguinte horário: 00:00:00

O correto seria:

dhEmb=20/12/2019 21:30

dhValidade=19/12/2020 21:30

Espero ter ajudado.

  • Like 1
Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • Membros Pro
2 horas atrás, Italo Jurisato Junior disse:

Bom dia Magnu,

Primeiramente, peço que anexe o arquivo INI em vez colocar como parte da postagem.

Anexando a postagem fica mais curta e com o arquivo INI em anexo temos como realizar testes.

Segundo, o problema é que você não esta informando a hora da validade somente a data.

Veja:

dhEmb=20/12/2019 21:30   ===> aqui esta correto você esta informando a data e hora de embarque conforme o campo dhEmb pede.

dhValidade=19/12/2020     ===> aqui esta errado você esta informando somente a data da validade sendo que o campo dhValidade pede data e hora

Toda vez que o nome do campo começar com dh significa que temos que informar a data e hora.

Como você não informou a hora o monitor tomou como base o seguinte horário: 00:00:00

O correto seria:

dhEmb=20/12/2019 21:30

dhValidade=19/12/2020 21:30

Espero ter ajudado.

Bom dia! Entendi sim Italo, vou ajustar! Deveria dar um erro ou retorno avisando néh, mas tranquilho, galho fraco esse. Obrigado!
Sobre o .INI, enviarei sim na próxima vez, sem problemas!

  • Like 2
Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.