Jump to content

click.png

click.png

click.png

click.png

click.png

click.png

click.png click.png click.png

click.png

click.png

click.png

Seja-Profissional-Saiba-mais.png Beneficios_banner.png

 

ACBrLib Danfe-NFe 1ª Nota corta margem direita


andersoncamilo
  • Este tópico foi criado há 510 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Bom dia

Estou tendo um problema na impressão dos danfes da NFe com a ACBrLib, a primeira impressão corta parte da margem direita, da segunda nota em diante sai tudo normal.

Sequencia de comandos.

NFE_Inicializar   (Somente na entrada nas opções de NFe)

NFE_CarregarXML

Se for impressão direta:
NFE_Imprimir

Se for gerar o PDF 
NFE_ImprimirPDF

Depois do primeiro DANFE todos saem certos,  mas se eu usar o NFE_Inicializar novamente o primeiro sai errado.

 

Abaixo seguem as configurações do ACBrLib.ini   e os dois arquivos gerados a primeira nota e a segunda nota.

Nas margens já utilizei o default que o ACBlib gera :

MargemInferior=8
MargemSuperior=8
MargemEsquerda=6
MargemDireita=5,1

E os que os ACBrMonitor Gera:

MargemInferior=0,8
MargemSuperior=0,8
MargemEsquerda=0,6
MargemDireita=0,51

Utilizo XHARBOUR, a ACBrLibr versão 0.4.6.92

Obrigado

Anderson Camilo

 

ACBrLib.INI 20200811103652_certo.pdf 20200811103638_errado.pdf

Edited by andersoncamilo
Link to comment
Share on other sites

  • Consultores

Pelo log mostra que esta ocorrendo a configuração do componente de impressão antes do mesmo ser impresso.

Vou fazer testes para ver se consigo reproduzir mas é bem provável que não ocorra visto que as margens são passadas para o componente de impressão antes de imprimir.

  • Like 1
Consultor SAC ACBr Rafael Dias
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Desenvolvedor ACBrLib.

 

Link to comment
Share on other sites

  • Membros Pro

Boa tarde 

Depois que você me enviou os teste, eu fiz testes em outras duas máquinas diferentes uma com windows 7 64 bits e outra com windows server 2018, deram certo, agora na minha máquina que é windows 10 acontece o problema.

Vou fazer mais testes se descobrir algo eu posto.

Mas obrigado pela atenção.

 

Anderson Camilo

 

  • Like 1
Link to comment
Share on other sites

  • Administradores

Tópico fechado por falta de retorno do usuário

Consultora SAC ACBr

Juliana Tamizou
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil


Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

Link to comment
Share on other sites

  • Este tópico foi criado há 510 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.