Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

consultoria_sticker.png

Conteúdo para desenvolvedores
 ao vivo de terça a quinta!
Saiba mais

dev.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


botao.png

beneficios.png

ACBrLib Danfe-NFe 1ª Nota corta margem direita


  • Este tópico foi criado há 183 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

Bom dia

Estou tendo um problema na impressão dos danfes da NFe com a ACBrLib, a primeira impressão corta parte da margem direita, da segunda nota em diante sai tudo normal.

Sequencia de comandos.

NFE_Inicializar   (Somente na entrada nas opções de NFe)

NFE_CarregarXML

Se for impressão direta:
NFE_Imprimir

Se for gerar o PDF 
NFE_ImprimirPDF

Depois do primeiro DANFE todos saem certos,  mas se eu usar o NFE_Inicializar novamente o primeiro sai errado.

 

Abaixo seguem as configurações do ACBrLib.ini   e os dois arquivos gerados a primeira nota e a segunda nota.

Nas margens já utilizei o default que o ACBlib gera :

MargemInferior=8
MargemSuperior=8
MargemEsquerda=6
MargemDireita=5,1

E os que os ACBrMonitor Gera:

MargemInferior=0,8
MargemSuperior=0,8
MargemEsquerda=0,6
MargemDireita=0,51

Utilizo XHARBOUR, a ACBrLibr versão 0.4.6.92

Obrigado

Anderson Camilo

 

ACBrLib.INI 20200811103652_certo.pdf 20200811103638_errado.pdf

Edited by andersoncamilo
Link to post
Share on other sites

Pelo log mostra que esta ocorrendo a configuração do componente de impressão antes do mesmo ser impresso.

Vou fazer testes para ver se consigo reproduzir mas é bem provável que não ocorra visto que as margens são passadas para o componente de impressão antes de imprimir.

  • Like 1
Consultor SAC ACBr Rafael Dias
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Desenvolvedor ACBrLib.

 

Link to post
Share on other sites

Boa tarde 

Depois que você me enviou os teste, eu fiz testes em outras duas máquinas diferentes uma com windows 7 64 bits e outra com windows server 2018, deram certo, agora na minha máquina que é windows 10 acontece o problema.

Vou fazer mais testes se descobrir algo eu posto.

Mas obrigado pela atenção.

 

Anderson Camilo

 

  • Like 1
Link to post
Share on other sites

Realmente muito estranho isso.
So um pergunta você usa fontes maiores que o padrão ? Senão me engano o Fortes Report tem um bug quando o dpi é diferente do padrão.

Consultor SAC ACBr Rafael Dias
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Desenvolvedor ACBrLib.

 

Link to post
Share on other sites
  • Este tópico foi criado há 183 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui
Guest
This topic is now closed to further replies.
×
×
  • Create New...