Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

consultoria_sticker.png

Conteúdo para desenvolvedores
 ao vivo de terça a quinta!
Saiba mais

dev.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


botao.png

beneficios.png

Erro ao tentar consultar NFse Campinas


Go to solution Solved by Italo Giurizzato Junior,
  • Este tópico foi criado há 126 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

Anexar log gerado pelo componente e os xml gerados pelo soap se possível

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
http://www.juliomarmarchetti.com.br
Embarcadero MVP
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil
Link to post
Share on other sites

Juliomarc , desculpe no log só chega estas informações  em branco 

 

Inicio TNFSeConsultarNFSe
Método........ : Consultar NFS-e
Recebimento... : 
Protocolo..... : 
Provedor...... : IssDSF

ERRO: 
Inicio TNFSeConsultarNFSe
Método........ : Consultar NFS-e
Recebimento... : 
Protocolo..... : 
Provedor...... : IssDSF

ERRO: 
 

Link to post
Share on other sites

Boa tarde Brito,

No programa exemplo tem um campo que você ativa para salvar os arquivos Soap.

Faça isso, repita os testes e anexa os arquivos "*-soap.xml"

  • Like 1
Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to post
Share on other sites

Brito,

Veja o retorno:

<ns1:RetornoConsultaNotas xmlns:ns1=&quot;http://localhost:8080/WsNFe2/lote&quot; xmlns:tipos=&quot;http://localhost:8080/WsNFe2/tp&quot; xmlns:xsi=&quot;http://www.w3.org/2001/XMLSchema-instance&quot; xsi:schemaLocation=&quot;http://localhost:8080/WsNFe2/lote http://localhost:8080/WsNFe2/xsd/RetornoConsultaNotas.xsd&quot;>
	<Cabecalho>
		<CodCidade>6291</CodCidade>
		<CPFCNPJRemetente>22433224000120</CPFCNPJRemetente>
		<InscricaoMunicipalPrestador>003399230</InscricaoMunicipalPrestador>
		<dtInicio>2020-10-20</dtInicio>
		<dtFim>2020-10-20</dtFim>
		<Versao>1</Versao>
	</Cabecalho>
	<Notas />
</ns1:RetornoConsultaNotas>

A consulta não encontrou nenhuma nota dentro do período informado.

A tela em branco que aparece é porque o componente não esta realizando o tratamento do retorno da forma correta.

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to post
Share on other sites

Italo boa tarde , no periodo exeiste a NFse conforme o relatorio na pagina da prefeitura , existe alguma configuração para o exemplo .... não encontro onde possa haver erro no processo , só não trás as informações   

imagem_2020-10-22_175347.png

Link to post
Share on other sites

Italo bom dia , desculpe não consegui encontrar o erro , todo e qualquer periodo que coloco e não tras nenhuma nota , estou seguindo apenas as rotinas de exemplo  sem modifica-las , poderia verificar  se existe para alguma correção para esta prefeitura , ou alguem que ja tenha feito para esta prefeitura poderia dar uma dica. Não estou encontrando solução para este caso .    Obrigado 

 

Link to post
Share on other sites
  • Solution

Bom dia Brito,

O que você pode tentar fazer é informar o numero inicial da nota como sendo 00010164 em vez de 10164.

Nunca se sabe né.

Se isso não resolver, a saída vai ser entrar em contato com a prefeitura e pedir uma explicação para o problema.

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to post
Share on other sites

Prezado Italo , Obrigado pela resposta , tambem ja executei  desta forma , té trocando o formato de data , mas mesmo assim sem sucesso , vou tentar o suporte da prefeitura mas não sei se terão uma resposta plausivel , mesmo assim obrigado pela ajuda , vou fazer a tentativa 

 

 

  • Like 1
Link to post
Share on other sites

Prezado Italo , bom dia  estou com problema para conseguir funcionamento nas cidade que tem o provedor IssDSF , tenho empresas em campinas e sorocaba sen ambas deste mesmo provedor só que mesmo tentando apenas consulta no exemplo do ACBr tenho sempre o mesmo erro para estas cidades (erro ja relatado  anteriormente ) , sera que existe alguem que tenha feito aplicação para estas cidade que possa dar uma luz , para que eu possa ver onde esta o erro , estou com o exemplo do ACBr  de NFSe sem alterar umalinha apenas fazendo a configuração colocando o certificado e tentando pesquisar notas em produção .  Desde ja agradeço a atenção 

 

 

Link to post
Share on other sites

Italo fiz a substituição do pas que voce enviou  em C:\Componentes\ACBr\Fontes\ACBrDFe\ACBrNFSe\PCNNFSe

 

 

ScreenHunter 71.png

ScreenHunter 72.png

ScreenHunter 73.png

ScreenHunter 74.png

ScreenHunter 75.png

ScreenHunter 76.png

ScreenHunter 77.png

Ja cheguei a trocar o metodo de acesso ao certificado mo assim o mesmo erro aparece 

Link to post
Share on other sites

Boa tarde Brito,

Comparando 4 cidades atendidas pelo provedor ISSDSF notei que a cidade de Campinas e Sorocaba, na montagem do Envelope é utilizado o mesmo NameSpace, por outro lado as cidades de Teresina e São Luiz os NameSpace são diferentes.

Eu não me conformo com essa falta de padronização de um provedor perante as cidades que eles atende.

Você acerta o arquivo INI do provedor para uma determinada cidade, ao fazer testes com uma outra não funciona, pois o NameSpace é diferente.

Fiz uma alteração no arquivo INI, favor testar com ele.

ISSDSF.ini

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to post
Share on other sites

Italo Tentei com este novo arquivo e o erro é o mesmo , parece que ele não sofreu alteração , testei com as configurações de certificado LibWinCrypt  e também com OpenSSL retirando  a serie do certificado  mesmo assim nada , italo sei que não é normal mas sera que poderia enviar a voce as informações deste cliente em PVT para que voce possa testar , sei que não é normal solicitar isso mas esta estranho demais coloquei em funcionamento em  Osasco sem nenhum problema , São Paulo nenhum problema , Florianopolis utilizando metade da rotina com ACBr e deu tudo certo , somente estas cidades não funcionam , devo estar cometendo um  erro grotesco de configuração , acho que se estivesse totalmente com problemas outros que estão utilizando a mesma cidade estariam reclamando , sera que é possivel ???

Link to post
Share on other sites
×
×
  • Create New...