Jump to content

Delphi chamada_delphi.png acbr.png

C6 chamada_c6.png botao.png

TAG ICMS SAT


brunor1989
Go to solution Solved by José M. S. Junior,
  • Este tópico foi criado há 253 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Olá,

Estou atualizando meu ACBR para a versão 1.4.0.49.

A parte de NFCe está ok. Porém quando eu tento enviar um Cupom via SAT ele está dando erro Erro de Validacao de Conteúdo.

Eu analisei o Xml e verifiquei que no retorno do Xml que salva no Arqs do ACBR a TAG ICMS está vazia (imagem em anexo). Porém eu mando as Informações certas assim como na NFCe.

Alguém consegue me ajudar??

acbr.png

Link to comment
Share on other sites

  • Administradores

Boa tarde.

Queira por favor anexar o XML assim o ini e o log do ACBrMonitorPlus.

Att.

Consultora SAC ACBr

Juliana Tamizou
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil


Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

Link to comment
Share on other sites

  • Membros Pro
14 minutos atrás, Sérgio Assunção disse:

@brunor1989 confere o regime tributário da empresa configurado no monitor se está correto com o regime da empresa na SEFAZ. Isso pode gerar diferença nessas tags no XML retornado.

Sim, está correto.

Regime Normal e estou mandando o CST 00.

 

Se eu volto o ACBR versão mais antiga, transmite para receita.

8 minutos atrás, José M. S. Junior disse:

Verifique também se a tag CST na seção ICMS está preenchido com código correto.

Regime Normal e estou mandando o CST 00.

 

Se eu volto o ACBR versão mais antiga, transmite para receita.

Link to comment
Share on other sites

  • Membros Pro
1 minuto atrás, José M. S. Junior disse:

Como está passando a seção no .ini? Está assim:

[ICMS001]

Orig=0

CST=00   

Anexe o seu arquivo com os dados se persistir       

Não entendi ini .ini.

 

Eu mando a TAG ICMS00

Orig=0

CST=00

Link to comment
Share on other sites

  • Consultores

Ok, você esta gerando o XML pela sua aplicação e utilizando o ACBr apenas para transmitir correto? Deve ter algo fora do padrão no XML por isso não está lendo a tag... Se possível mande o arquivo de log doa ACBrMonitor: "Log.txt" para verificação.

Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Membros Pro
1 hora atrás, José M. S. Junior disse:

Ok, você esta gerando o XML pela sua aplicação e utilizando o ACBr apenas para transmitir correto? Deve ter algo fora do padrão no XML por isso não está lendo a tag... Se possível mande o arquivo de log doa ACBrMonitor: "Log.txt" para verificação.

Isso mesmo.

O mais estranho, é que sem alteração da aplicação, se eu tentar mandar pela versão 1.4.0.49 acontece esse problema, se mandar pela versão mais antiga (1.2.0.9) vai normal.

Link to comment
Share on other sites

  • Consultores
  • Solution

Como está lendo o xml já gerado é necessário informar também no XML o regime tributário <cRegTrib>0</cRegTrib>, pois o ACBr remonta o XML validando as tags, como não está definido cRegTrib este não pode validar o grupo ICMS, por isso não está sendo preenchido.

Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Membros Pro
2 horas atrás, José M. S. Junior disse:

Como está lendo o xml já gerado é necessário informar também no XML o regime tributário <cRegTrib>0</cRegTrib>, pois o ACBr remonta o XML validando as tags, como não está definido cRegTrib este não pode validar o grupo ICMS, por isso não está sendo preenchido.

Vou verificar isso.

Mas teve alteração referente a essa validação nas novas versões?

Link to comment
Share on other sites

  • Membros Pro
2 horas atrás, José M. S. Junior disse:

Como está lendo o xml já gerado é necessário informar também no XML o regime tributário <cRegTrib>0</cRegTrib>, pois o ACBr remonta o XML validando as tags, como não está definido cRegTrib este não pode validar o grupo ICMS, por isso não está sendo preenchido.

Eu adicionei a TAG conforme foi orientado e transmitiu o CFe.

Obrigado.

Link to comment
Share on other sites

  • Consultores

A versão anterior que estava utilizando era bem antiga, provavelmente houve melhorias, neste caso de leitura do xml não pode gerar baseado na configuração do componente e sim apenas o que está no xml.

Obrigado por reportar.

Consultor SAC ACBr

José Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Este tópico foi criado há 253 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.