Jump to content

Delphi chamada_delphi.png acbr.png

C6 chamada_c6.png botao.png

Erro instalação ACBR Fast Report


Go to solution Solved by Daniel Simoes,

Recommended Posts

  • Consultores

O Erro está na instalação do seu fast reports, possivelmente está faltando libpath.

rode o instalador do fastreport e o recompile;

Consultor SAC ACBr

Victor H Gonzales - Pandaaa
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

"Aprender é a única coisa que a mente nunca se cansa, nunca tem medo e nunca se arrepende” - Leonardo da Vinci

"Ter sucesso é falhar repetidamente, mas sem perder o entusiasmo"

Link to comment
Share on other sites

  • Fundadores

Sim.. quando o ACBr tenta usar o Fast, o erro ocorre... veja:

Citar

C:\Componentes\Acbr\Fontes\ACBrDFe\ACBrNFe\DANFE\NFe\Fast\ACBrNFeDANFEFRDM.pas(46) Fatal: E2225 Never-build package 'frxDB19' must be recompiled
Compilation failure

A reinstalação do Fast, deve resolver...

Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Membros Pro

Já reinstalei o Fast. Os programas demos na pasta do FastReport todos abrem normalmente e compilam.

Só dá problema quando instala o ACBR

Edited by brajan
Link to comment
Share on other sites

  • Membros Pro
1 hora atrás, BigWings disse:

Acrescente "Vcl" ao Unit scope names nas opções de projeto do pacote.

Já fiz isso também, mas apresenta o erro : Never-build package 'frxDB19' must be recompiled.

Quando compila os demos do Fast funciona normal, só não funciona quando compila os pacotes do ACBR ou usa o AcbrInstall

 

Edited by brajan
Link to comment
Share on other sites

  • Consultores
15 horas atrás, BigWings disse:

Veja se tem mais de uma versão dessa bpl na sua máquina.

O Fast tem a mania chata de colocar as bpl no system32, pode ter mais de uma versão espalhada por aí.

ué minhas não faz isso e tenho o instalador

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

  • Moderadores
14 minutos atrás, Juliomar Marchetti disse:

ué minhas não faz isso e tenho o instalador

Aqui só carrega se estiver no system32 ou no syswow64.

Como a minha licença não dá direito aos fontes fico dependente do instalador.

Inclusive o recompile.exe precisa de acesso no system32, pra quê?

image.png

Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

  • Membros Pro

O instalador do ACBR passou todos os processos sem erros. Mas quando vou no delphi, só consigo instalar um pacote.

Quando instalo o Nfe, o boleto, Ct-e e Mdfe não funcionam. Quando desinstalo o nfe consigo instalar um dos outros, mas somente 1 deses.

im.png.36a5e0ca5f3b04c4c3e924a9eb742c69.png

 

Link to comment
Share on other sites

  • Fundadores
  • Solution

Parece que os Packages foram modificados.. (provavelmente pela IDE)...

Você precisará reverter as modificações nos Packages do ACBr (ou baixar novamente)... e rodar novamente o instalador do ACBr...

Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Membros Pro

Está dando esse erro agora quando vou instalar o pacote manualmente.

Cannot load package 'ACBrNFeDanfeFRpkg.'  It contains unit 'frxRC4', which is also contained in package 'frxe19'.

Link to comment
Share on other sites

  • Consultores

Bom dia

Parece que voce tem .pas no seu libpath e está tendo modificações.

a sugestão é fazer uma limpeza e instalação limpa.

remover do libpath todo o componente do FastReport, e da ACBr

apagar da maquina todos os dcu, bpl desses projetos.

Instalar o FastReport pelo instalador, se necessário use o recompile para traduzir o mesmo, (não inserir codigo fonte no libpath) deixe só a compilação.

Depois instale o ACBr pelo ACBrInstall

Consultor SAC ACBr

Victor H Gonzales - Pandaaa
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

"Aprender é a única coisa que a mente nunca se cansa, nunca tem medo e nunca se arrepende” - Leonardo da Vinci

"Ter sucesso é falhar repetidamente, mas sem perder o entusiasmo"

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.