Jump to content

dev botao

ACBrBal - Erro no MGV6


bnobre
Go to solution Solved by EliasCesar,
  • Este tópico foi criado há 537 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Consultores

Olá @doidopb,

Comparando o log e o arquivo txt, parece que ele está lendo os dados de posições diferentes das geradas pelo modelo "modToledoMGV5". 

Veja nesse trecho de linha, por exemplo:
010002481001199000MELÃO REDINHA

Esse texto destacado é o Código do item("002481"), porém o log diz: "Item código 248100: Dias de Validade não é numérico"

Aparentemente ele está esperando as informações na mesma posição que o arquivo quando é gerado pelo modelo "modToledo".

Consultor SAC ACBr

Elias César Vieira
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil
Assine o
SAC

 
Link to comment
Share on other sites

  • Membros Pro
3 minutos atrás, EliasCesar disse:

Olá @doidopb,

Comparando o log e o arquivo txt, parece que ele está lendo os dados de posições diferentes das geradas pelo modelo "modToledoMGV5". 

Veja nesse trecho de linha, por exemplo:
010002481001199000MELÃO REDINHA

Esse texto destacado é o Código do item("002481"), porém o log diz: "Item código 248100: Dias de Validade não é numérico"

Aparentemente ele está esperando as informações na mesma posição que o arquivo quando é gerado pelo modelo "modToledo".

Oi meu amigo... Tudo bom?

Então é algo errado no MGV6 do cliente?

Link to comment
Share on other sites

  • Membros Pro
1 hora atrás, EliasCesar disse:

Tente gerar o arquivo selecionando o modelo 'modToledo' no componente ACBrCargaBal.

Por exemplo:

    ACBrCargaBal1.Modelo := modToledo;

 

A princípio parou de dar o erro...

Mas só vou poder testar a balança amanhã pra ver se deu a carga corretamente... Aí aviso aqui...

Mas porque que com Toledo parou de dar o erro e com o modelo MGV6 no ACBrBal o erro persistiu??? 

 

Link to comment
Share on other sites

  • Consultores

Pelo erro do log, deu pra entender que ele estava buscando o campo código na posição incorreta. 

Aparentemente ele está esperando o arquivo no layout mais antigo.

Veja como o componente preenche o arquivo conforme as versões:
image.png

A "(versão = 0)" é o modToledo e o else é o modToledoMGV5.

  • Like 1
Consultor SAC ACBr

Elias César Vieira
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil
Assine o
SAC

 
Link to comment
Share on other sites

  • Membros Pro
1 hora atrás, doidopb disse:

A princípio parou de dar o erro...

Mas só vou poder testar a balança amanhã pra ver se deu a carga corretamente... Aí aviso aqui...

Mas porque que com Toledo parou de dar o erro e com o modelo MGV6 no ACBrBal o erro persistiu??? 

 

Consegui testar amigo... Foi... Valeu

  • Like 1
Link to comment
Share on other sites

  • Este tópico foi criado há 537 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.