Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

consultoria_sticker.png

Conteúdo para desenvolvedores
 ao vivo de terça a quinta!
Saiba mais

dev.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


Saiba mais

beneficios.png

João Teixeira

Usuários SAC
  • Content Count

    24
  • Joined

  • Last visited

Community Reputation

7 Neutral

About João Teixeira

  • Rank
    Novato

Profile Information

  • Sexo
    Masculino
  • Location
    Barretos

Recent Profile Visitors

785 profile views
  1. Depois que reinicie o computado e refiz o procedimento utilizando a configuração sugerida pelo Rafael, incluindo apenas na cláusula Uses ‘AJBarcode’, consegui gerar o código de barra em ‘bcCode_2_5_interleaved’ Para atribuir ao componente de imagem fiz baseando nas linhas de código que o Daniel passou e o exemplo ‘\ACBr\Exemplos\ACBrDiversos\ACBrBarCode\Lazarus ‘ também é muito útil. Além de abordar as questões acima, mostra também com atribuir os tipos de código de Barra em um ComboBox Obrigado pela ajuda Rafael e Daniel, solucionado! Abraços!
  2. para a questão do problema do ACBrBarcode com typ ‘bcCode_2_5_interleaved’ é melhor abrir um novo tópico?
  3. oi Daniel, seria a minha vontade, mas já utilizo a alguns anos e o layout está todo desenhado no QuickReport.
  4. oi Rafael, tentei utilizar o ACBrBarcode com typ ‘bcCode_2_5_interleaved’, mas é estranho o comportamento do componente com essa opção, por exemplo: Se definir a propriedade text com um conteúdo com mais de 13 dígitos da a seguinte mensagem ‘Numero Invalido para EAN13’, mesmo definindo a propriedade typ com ‘bcCode_2_5_interleaved’. Outra coisa que achei estranho é que todas as opções ficam parecendo escrito em negrito e quando define a opção ‘bcCode_2_5_interleaved’ parece que fica diferente. Verifiquei várias vezes se não estava fazendo alguma coisa errada, mas parece que está
  5. Boa tarde! Tenho um cliente que a formatação do boleto é em formato de carnê (são impressos 12 boletos ) e está em QuickReport e estou trocando o componente antigo pelo ACBrBoleto. Já acertei praticamente o relatório todo para o componente ACBrBoleto. Só não estou sabendo como obter a imagem do código de barra para passar para o componente “qrImagem” do QuickReport para imprimir. Meu problema é mesmo a impressão do código de barra no boleto, porque os dígitos consigo pela função MontarCodigoBarras() do ACBrBoleto, Abracos!!!
  6. Fiz o seguinte procedimento: Executei o arquivo bath "apagarAcBr.bat" e limpei a instalação de todos os Delphi E a cada versão do Delphi fui instalando o AcBr e configurando o Path da seção "User Override", conforme o tutorial. Trabalhando perfeitamente agora obrigado ao Solivan, Juliomar, EMBarbosa e ao Daniel abraços!!!
  7. oi Daniel, muito bom o tutorial e bem objetivo, deu tudo certo!!!
  8. Excelente" Vou instalar nos 2 Delphi's. Pensei que o AcBr do Trunk2 não era compatível com Delphi 7 Nesse projeto do Delphi 7 não emito NFe, por isso que não me preocupei... Gente! Por enquanto obrigado, vou fazer isso.
  9. oi Juliomar, não entendi o que você disse, desculpa quando você fala de "não tenha sido migrado a parte do delphi 7"?
  10. mas do Delphi 7 não tem que ser o componentes antigos da "Trunk" e para a versão do Delphi 2010 os componetes da "Trunk2"?
  11. Obrigado Solivan, Juliomar e EMBarbosa. Sim, tenho o Delphi 7 e o Delphi 2010 na mesma máquina. Estou tentando atualizar (na realidade incluir um componente que não havia instalado) somente no Delphi 2010, porque o Delphi 7 tem que ser o Trunk "1", é isso? Quando executei o arquivo bat "apagarAcbr.bat", ai consegui instalar sem problemas, mas perdi o AcBr do Delphi 7 Fiz a restauração da máquina e tentei executar o arquivo bat (tirando o "cd\" ) somente na pasta onde está o AcBr para o Delphi 2010, mas o erro permaneceu. Não sei se ajudaria, mas tenho uma pasta AcBr_t
  12. Boa tarde! Após atualizar os componentes do AcBr, passou a dar as seguintes mensagens das figuras abaixo quando abro o Delphi (vrs 2010) e acredito que repete para todos os componente que selecionei para instalar. Desculpa se já tinha algum tópico aberto, mas não consegui localizar O Delphi é a versão 2010
  13. Boa tarde! Tenho acompanhado o tópico e preciso sanar uma dúvida: - Para o processo de homologação pela AT&M foi necessário fazer algum ajuste (via código) no componente ANE além dos mencionados durante todo o tópico (Cód. ATM, Usuário e senha)? Já obtive as credenciais para homologação porém me é retornada a mensagem 904 - Acesso não autorizado. Conversando com o suporte da AT&M eles mencionaram que o acesso está ok (tendo como análise os arquivos Soap que enviei que foram gerados pelo AcbrANE) e que eu deveria confirmar se o WSDL de consumo era o apropriado para
  14. Boa tarde! Ao colocar minha aplicação no ambiente Windows 7/2008, percebi que em algumas chamadas realizadas pelo componente ACBRMDFe, programa trava ou é fechado "do nada" sem informar mensagem de erro ou algo do gênero, mesmo usando try/exception (Delphi XE). Percebi que esse evento ocorre ao invocar as funções de Envio/Consulta/Encerramento do XML, não sempre mas uma vez ou outra. Alguém já passou por isso e conseguiu resolver? É relacionado a DLL Capicom, e para evitar tal possível conflito, devo atualizar a mesma? Att, João.
  15. Bom dia, Gostaria de saber qual a configuração correta do componente ACBRECF com impressoras não fiscais. Encontrei alguns tópicos úteis aqui no fórum sobre utilizar o componente no modelo como 'Não fiscal' e configurar o arquivo INI gerado e deu tudo certo, porém, ao solicitar uma impressão de relatório gerencial, percebi que o mesmo não tem as formatações de texto que encontrava no mesmo relatório com impressoras fiscais. Quanto a essa formatação no relatório gerencial há como fazê-la funcionar para impressora não fiscal? Ou é melhor utilizar o ACBRPosPrinter para isso? Muito obrig
×
×
  • Create New...