Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

consultoria_sticker.png

Conteúdo para desenvolvedores
 ao vivo de terça a quinta!
Saiba mais

dev.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


Saiba mais

beneficios.png

Denis Queiroz

Membros
  • Content Count

    87
  • Joined

  • Last visited

Community Reputation

15 Good

About Denis Queiroz

  • Rank
    Membro
  • Birthday 04/14/1991

Profile Information

  • Sexo
    Masculino
  • Location
    São Paulo

Recent Profile Visitors

918 profile views
  1. Bom dia, acabei de atualizar o componente, está tudo certo, muito obrigado.
  2. Perfeito Juliomar, obrigado, então para eu atualizar vou ter que fazer um backup do meu .PAS do banco itaú, pois como mencionei no começo do post, fiz uma outra pequena correção por causa da data de negativação mas já verifiquei e está no SVN a questão do sacador avalista, este tópico está ok, obrigado pela ajuda. Tudo certo.
  3. Obrigado Juliomar, perfeito, assim atende quem usa a opção Outros, e também quem usa a opção "Nao informado" que é o meu caso.
  4. Então Juliomar eu vi a dica do amigo, mas se você olhar no manual nota 29 (página 15) Nota 29 : TIPO DE INSCRIÇÃO DO SACADO/ SACADOR/ AVALISTA 1 = CPF 2 = CGC 0 = Não informado 9 = Outros O que está sendo feito é lançar como outros, gostaria de lançar não informado como era, pois esta empresa tem diversas filiais e contas inclusive no santander que usam o sacador avalista, antes o componente informava 0 e tudo estava perfeito. A opção 0 existe no manual e estava assim antes do refactory atual, a empresa gera remessa diariamente para o banco e como é uma remessa com mai
  5. Apenas informativo, com a correção acima, o banco validou os boletos com sucesso.
  6. Bom dia, o meu problema é o mesmo deste tópico no caso o amigo resolveu usando outros gerando o valor 9 na coluna 154, mas atualmente eu gero como 0, esta opção é válida no manual, onde assume o valor de "Não informado" e não "Outros" conforme foi sugerido, como o Juliomar mencionou no tópico criar um enumerador como nenhum seria o correto, irei fazer uma alteração no meu componente, e qualquer coisa posso anexar aqui. EDIT Anexado o novo enumerador, meu fonte do ACBR está atualizado até o dia 03/08/2020 devido a esta outra correção. ACBrBoleto.pas ACBrBoletoConversao.pas
  7. Perfeito Juliana, é apenas um detalhe, até daria para contornar isto preenchendo a data na propriedade de protesto, mas como teve este refactory, o ideal seria seguir como ocorre no layout de 240 colunas, fico no aguardo.
  8. Bom dia, ao enviar os arquivos para o banco Itaú, o mesmo me retornou uma crítica referente a negativação, na posição 392/393 estava sendo informado zeros quando na verdade deveria se informar a quantidade de dias. Na geração do arquivo no layout CNAB já está sendo feito via nova propriedade, mas esta mudança não ocorreu na geração via CNAB 400. Portanto apenas mudei o IFTHEN da linha 794 para usar a DataProtestoNegativacao Pois o componente teve uma refatoração e agora a data de protesto e negativação estão em propriedades separadas. Não olhei os demais bancos, mas segue a
  9. Um teste mais aprofundado, o problema está na Lib de assinatura. Capicom funciona também desde que deixe de usar xsMsXmlCapicom na propriedade SSLXmlSignLib, estou usando xsMsXml tanto para Wincrypt quanto para Capicom e agora está funcionando... A config no meu sistema ficou da seguinte forma... if dm.SQLParametrosNFELIB.AsInteger = 0 then Begin dm.ACBrNFe1.Configuracoes.Geral.SSLCryptLib := cryCapicom; dm.ACBrNFe1.Configuracoes.Geral.SSLLib := libCapicomDelphiSoap; dm.ACBrNFe1.Configuracoes.Geral.SSLHttpLib := httpIndy; dm.ACBrNFe1.Con
  10. Bom como não posso editar a mensagem vai um pequeno flood mas com a solução paliativa, pois realmente Capicom parou de funcionar.mas o WinCrypt está funcionando. Basta configurar o componente para usar Wincrypt com SSLType configurado para LT_TLSv1_2 pode-se passar da seguinte forma: ACBrNFe1.SSL.SSLType := LT_TLSv1_2;
  11. Estou com o mesmo problema nesta nova versão do ACBR, a versão antiga funciona perfeitamente(A1 e A3), mas esta nova versão não funciona com certificados A3, A1 está funcionando normalmente. O engraçado é que consultas no webservice estão funcionando com o A3, mas ao chamar o método assinar dá esta mensagem do tópico. Acho que como eu, o amigo deve estar usando Capicom ao invés do WinCrypt, usava WinCrypt antigamente mas em algumas atualizações tinha parado de funcionar e voltei pro antigo Capicom.
  12. Ok muito obrigado pelo Feedback, fico no aguardo então... A correção realmente foi mínima, apenas um IFTHEN para tratar casos de emissão via banco(O campo nosso numero deve ir zerado, pois será gerado pelo banco).
  13. Bom como não tem o botão editar... O arquivo foi validado e já está em uso em produção com a nova correção mencionada acima, portanto para emissões via banco, o campo nosso número deve estar totalmente zerado.
  14. @Juliana Tamizou @José M. S. Junior Bom dia, referente a esta correção está tudo OK, está funcionando em produção, agora precisei fazer uma integração em outra empresa, no caso desta segunda, a emissão dos boletos ficam por conta do banco, portanto eles exigiram que o campo nosso número Seja Preenchido com Zeros conforme a imagem em anexo. portanto poderiam subir esta pequena correção? Pois da maneira atual ele está calculando o digito verificador quando informado zeros, foi adicionado apenas um IFTHEN para informar corretamente o campo nosso número. ACBrBancoS
×
×
  • Create New...