Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

consultoria_sticker.png

Conteúdo para desenvolvedores
 ao vivo de terça a quinta!
Saiba mais

dev.png

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


Saiba mais

beneficios.png

rdxdt

Membros
  • Content Count

    88
  • Joined

  • Last visited

  • Days Won

    1

rdxdt last won the day on December 11 2016

rdxdt had the most liked content!

Community Reputation

5 Neutral

About rdxdt

  • Rank
    Membro

Profile Information

  • Sexo
    Masculino
  • Location
    São Paulo

Recent Profile Visitors

1,329 profile views
  1. Fiz uma busca anteriormente no fórum com os termos que estão no título desse tópico e a busca retornou vazia, portanto criei esse tópico Copiei a função EXATAMENTE do exemplo do ACBrNFe mas no meu sistema sempre que tento imprimir um XML eu recebo esse erro Estou usando o ACBrNFeDANFERL como DANFe, será que estou esquecendo de configurar algo no componente? if odXML.Execute then begin ACBrNFe1.NotasFiscais.Clear; ACBrNFe1.NotasFiscais.LoadFromFile(odXML.FileName,False); ACBrNFe1.NotasFiscais.ImprimirPDF; end;
  2. Interessante o que será que foi alterado entre essas versões que fez com que essa dll "faltando" se tornasse necessária?
  3. Tentei novamente mas agora em uma maquina virtual com Windows 10 64 bits e funcionou, a outra maquina virtual que eu utilizei era um Windows 7 32 bits
  4. tem o .net(tanto que o instalador do MySQL funcionou normalmente assim como o Workbench), tem administrador e sobre o log Caminho: C:\ACBr\ Versão do delphi: Delphi 10.2 Tokyo (0) Plataforma: Win32(0) esse é o conteúdo do log. Lembrando que consegui instalar utilizando a versão anterior a que está no SVN, está tudo funcionando para mim, só reportei o erro porque achei estranho.
  5. Sim, foi usado do SVN agora, no meu computador antigo eu tenho ainda uma copia do instalador antigo, mas o que eu testei foi a que esta no SVN agora, segue o print Edit: tentei agora usar o instalador versão 1.0.0.1 e instalou normal, o erro aparentemente está na versão 1.2.0.1 do instalador
  6. Ola fui instalar o ACBr no meu novo laptop e ao selecionar os componentes e ir para a próxima pagina e clicar em instalar eu recebo uma mensagem "Não Implementado", se eu pegar a copia antiga que eu tenho do instalador vai funcionar?
  7. O que aconteceu com o usuário foi exatamente o que aconteceu comigo, eu mudei os parâmetros e ai funcionou, obrigado por indicar o tópico.
  8. Em uma atualização recente que fiz do meu sistema automáticamente a impressão de etiquetas "quebrou", nesse meio tempo a unica parte que mudou creio que foi apenas o componente(pois foi logo depois de eu atualizar para a ultima revision). Algo mudou recentemente(nos ultimos meses de 2018) no ACBrETQ? As etiquetas que antes funcionavam estão todas mal formatadas.
  9. Ao não informar elas são substituidas pelo texto Projeto ACBr e a url do site, pelo menos na revision que estou usando.
  10. Quanto ao rodapé infelizmente não tem como tirar, como não faço parte do time de desenvolvedores não sei se tem como eu fazer o commit de uma alteração que fiz, apenas uma propriedade boolean para que seja configurável a exibição do nome + site da SW house no rodapé. Caso alguém dos desenvolvedores tenham interesse nisso.
  11. Por um tempo eu ignorei isso mas agora muitos clientes meus estão com as ECF vencendo e trocando pelo SAT e é unânime a reclamação que eles fazem para mim, o extrato é ENORME. No caso do cupom que vou usar para ilustrar saiu em uma MP-4200 TH, com a exceção do cabeçalho que é configurável pelo utilitário da bematech tem muitas coisas que eu não sei se seria configuração da impressora ou do componente em si. Aonde eu coloquei em vermelho são espaços que eu queria remover que creio que seja configuravel. E em verde são propriedades que vi no componente e gostaria de saber se eu de
  12. Eu resolvi removendo algumas units que estavam no source, agora de cabeça eu não lembro, mas creio que as necessárias para usar o ACBrNFe : ACBrBase, ACBrDFe, ACBrNFe Eu também tenho declarado as units pcnAuxiliar,pcnConversao, pcnConversaoNFe. Creio que nem os criadores do componente tenham ideia do que é esse problema mas foi assim que eu solucionei o meu.
  13. Estou migrando um módulo de NFe que inicialmente foi feito no Delphi 7 (e uma versão bem desatualizada da suite de componentes ACBr) e ao tentar compilar eu estou recendo esse erro e aponta para a unit ACBrCAPICOM_TLB uses Windows, ActiveX, Classes, {$IFDEF FMX} FMX.OleServer, {$ELSE} OleServer, {$ENDIF} {$IFNDEF FPC} StdVCL, {$ENDIF} Variants; Estou agora no Delphi XE7 usando a revisão 12821 da suite ACBr. [dcc32 Fatal Error] ACBrCAPICOM_TLB.pas(65): F1026 File not found: 'X:\Sources\Ferramentas\XMLMonitor\DBUpdater\OleServer.dcu'
  14. Com certificado A1 eu tive sucesso enviando o arquivo do certificado(que a AC te enviou). Com o A3 eu exportei ele e enviei e também funcionou.
  15. Solucionei aqui desativando e ativando a porta COM virtual do SAT no gerenciador de dispositivos(devmgmt.msc). Mas que isso é um bug do driver isso é uma certeza. Obrigado ai pela dica do log da dll.
×
×
  • Create New...