Jump to content

Waldir Paim

Moderadores
  • Posts

    585
  • Joined

  • Last visited

  • Days Won

    4

Everything posted by Waldir Paim

  1. Oi @ANDERSON JUNIOR GADO DA SILVA Tem uma orientação interna de que não devemos interagir diretamente com os usuários em questões fiscais por receio de que recaia algum tipo de responsabilizabilidade quanto aos dados gerados! Então nesse caso você deveria procurar alguma consultoria especializada para que consiga garantir a qualidade dos dados entregue a seu cliente! Foi fechar o tópico!
  2. Se o regime é Cumulativo como descrito em outro tópico! Não deve ser informado os registros de entrada! No regime cumulativo só devem ser informados os registros de saída!
  3. Qual o regime tributário você está apurando: Cumulativo ou Não Cumulativo? Tirei esse texto daqui: https://meccah.com.br/pis-cofins-cumulativo-nao-cumulativo/
  4. Voltei a alteração para ela ficar sem essa alteração dos parâmetros adicionais! Você testa com ela! se funcionar a gente volta para essa alteração em seguida testamos melhor. ACBrTEFDCliSiTef.pas Essa ai agora tá sem as alterações que causaram problema ai! Testa pra gente fazendo um favor!
  5. Você conseguiria testar com essa unit? Fiz um ajuste para para não por os colchetes case os parâmetros adicionais não sejam informados! ACBrTEFDCliSiTef.pas
  6. Que top! Agora fica fácil de corrigir! Parabéns pela resiliência!
  7. Como te disse! eu uso essa ultima versão do repositório! e funciona normal! Não acredito que seja no código do componente! mas para tirar essa sua duvida! volte para uma versão mais antiga! exemplo: uns 30 dias antes! Dessa forma pode verificar que não tem alterações que possam causar esses conflitos que você esta relatando!
  8. Veja no LOG de atualização no SVN e vá voltando revisão a revisão onde tem alterações nos fontes das units do CliSitef! Verifique se realmente é uma alteração nos fontes e aponte aqui onde começou a apresentar esse problema! Ficar só dizendo que é um erro na atualização mas não apontar onde! Não ajuda em nada e dificulta mais ainda em tentar te ajudar! Esqueci aqui de dizer que eu USO o componente ACBrTEF com as ultimas atualizações e aqui funciona 100%!
  9. Foi movido alguns enumeradores para a unit ACBrETQClass.pas Declara ela no seu projeto!
  10. O Pessoal da pre-homologação da SkyTef identificou um problema na geração dos dados do campo ParametrosAdicionais Disseram que tem um par de chaves extras no campo! Fiz um ajuste na unit para tentar corrigir o problema indicado! Anexei uma imagem enviado por eles para ajudar na analise! ACBrTEFDCliSiTef.pas
  11. Você não aplicou as alterações que te indiquei! Faça os ajustes que esses 1069 dependendo das units utilizadas no seu projeto! deve despencar para menos de uma dezena!
  12. Não! Aqui quer dizer! Delphi X2 ou inferior! {$IFNDEF DELPHIXE2_UP} <<esse N em destaque ali é uma negativa! quer dizer se não for XE2_UP Up aqui quer dizer Maior
  13. No primeiro bloco: {$DEFINE REMOVE_CAST_WARN} tira o ponto do inicio! isso ativa a diretiva No segundo bloco: {.$UNDEF REMOVE_CAST_WARN} você desativa ele com um ponto no inicio No terceiro bloco: {.$WARN SYMBOL_DEPRECATED OFF} remove o ponto do inicio
  14. Configura no ACBr.inc Dá uma olha nesses blocos! Observe onde anotei a expressão: <<<=aqui Isso vai limpar seu log de hints e warnigs.
  15. Mas como eles conseguiram o CSC? Tiveram acesso a SEFAZ também?
  16. Você precisa mandar algum comando no Evento OnKeyPress ou OnKeyDown do seu form. Esse evento que deve informar o que ESC foi acionando! sem um evento desses o loop não tem como saber que a tecla foi pressionada.
  17. Nesse evento onde captura o pressionamento da tecla ESC que código tem nele? Ele insere alguma informação para interromper o loop?
  18. Poe um sleep(100)! ele precisa de um tempinho de processamento livre! Se o loop for muito severo! ele não consegue processar os outros eventos.
  19. Será que não falta um Application.ProcessMessage e um Sleep de alguns milissegundos para o Windows conseguir tratar o evento?
  20. @sistemp Temos uma ferramenta que pode te ajudar nisso!
  21. Na sua Query e ou na sua conexão Use: FetchOptions.AssignedValues := [evRowsetSize];
  22. Você precisa redirecionar no TS Client a porta serial onde já conectado a balança. Deve funcionar um pouco mais lento mas acredito que funcione a contento.
  23. Se o protocolo for PPLA d[a uma olhada aqui: https://www.projetoacbr.com.br/forum/topic/58302-argox-não-imprimindo/?tab=comments#comment-382274
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.