Jump to content

dev botao
  • Este tópico foi criado há 3819 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Eu sei que aqui é o lugar do CT-e, mas nao achei lugar especifico para o MDFe.

 

Atualizei todos os componentes ontem e ao gerar o MDFe, nao consegui transmitir com o schema atualizado.

Consegui transmitir usando o schema PL_MDFe_100_NT2013002.zip.

 

Depois disso, ao mandar para o sefaz, ele responde com "Falha no Schema XML especifico para o modal".

Ao usar um schema mais novo, ele da erro "veicTracao' is incomplete according to the DTD/Schema."

 

Segue o trecho do meu codigo para os srs analisarem : 

 

      rodo.RNTRC := Empresa.ANTT_RNTRC;
      rodo.CIOT := '';
      rodo.veicTracao.cInt := '001';
      rodo.veicTracao.placa := Somente_Letras_Numeros(Query_Viagem_MDFeVeiculo_Contratado.AsString);
      rodo.veicTracao.tara := Query_Viagem_MDFeVeiculo_Tara.AsInteger;
      rodo.veicTracao.capKG := Query_Viagem_MDFeVeiculo_Capacidade.AsInteger;
      rodo.veicTracao.capM3 := Query_Viagem_MDFeVeiculo_Cap_M3.AsInteger;
      With rodo.veicTracao.condutor.Add Do
      Begin
         xNome := Query_Viagem_MDFeMotorista.AsString;
         CPF := SomenteNumeros(Query_Viagem_MDFeMotorista_Contratado.AsString);
      End;
      If Query_Viagem_MDFeSegunda_Placa.AsString <> '' Then
      Begin
         With rodo.veicReboque.Add Do
         Begin
            cInt := '002';
            placa := Somente_Letras_Numeros(Query_Viagem_MDFeSegunda_Placa.AsString);
            tara := Query_Viagem_MDFeReboque_Tara.AsInteger;
            capKG := Query_Viagem_MDFeReboque_Capacidade.AsInteger;
            capM3 := Query_Viagem_MDFeReboque_Cap_M3.AsInteger;
         End;
      End;
 
 
Segue o XML gerado.
 

 

 

Obrigado

 

 

Rene Melo

Link to comment
Share on other sites

  • Consultores

Bom dia Rene,

 

Primeiramente você esta utilizando o schema errado:

 

Dentro da pasta: ...\Exemplos\ACBrMDFe\Delphi\Schemas\V100 temos a útima versão

 

PL_MDFe_100a_NT012014

 

Segundo, você configurou o componente para gerar o XML segundo a versão ve100a?

Consultor SAC ACBr

Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Araraquara - A era dos Trólebus

Link to comment
Share on other sites

  • Membros Pro

Bom dia, Italo..

 

Realmente, nao tinha configurado o componente para usar a versao mais nova.

Vou dar uma olhada nas modificaoes que isso implica e retorno para informar o resultado.

 

Obrigado pela rapida resposta.

Rene Melo

Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.

The popup will be closed in 10 seconds...