Jump to content

Assista click.png tectoy.png

C6 chamada_c6.png botao.png

Sefaz Am: Rejeição Erro Não Catalogado


Go to solution Solved by José Nilton Pace,
  • Este tópico foi criado há 2785 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Senhores, boa noite!

 

A cerca de 2 meses fiz alguns testes usando o ACBrNFe2Demo e consegui emitir alguns NFCe's utilizando o SEFAZ AM (homologação).

 

Passei algum tempo mexendo em outra coisa (PAF-ECF maldito :P), e hoje voltei a brincar com NFCe (fiz o update no repositório do ACBr via SVN, recompilei packages, etc.).

 

Compilei novamente o ACBrNFe2Demo, usei um certificado aqui do RN, configurei os campos, mas informei a UF como "AM" (lembro que precisava disso), em seguida informei uma IE de 9 dígitos e um código IBGE do estado do AM como orientado em outros tópicos, no entanto ao tentar emitir o NFCe surge a mensagem: "Rejeição: Erro não catalogado".

 

Pelo que vi no portal do SEFAZ AM mudaram o esquema para configurar o token (que agora chamam de CSC):

Usuários do ambiente de desenvolvedores deverão utilizar o valor fixo “0123456789” para o CSC e o identificador “000001”.
 
Configurei esses valores na propriedade Token e IdToken respectivamente, mas o erro persiste.
 
Estou fazendo algo errado ou o SEFAZ AM está com problemas hoje?

WRMedeiros

Focus

Link to comment
Share on other sites

Antes de criar o tópico fiz várias buscas no fórum, e a recomendação é entrar em contato com o SEFAZ já que a mensagem é genérica (com certeza não teremos resposta no fim de semana rsrs).

 

O tópico em questão é esse (espero que os moderadores não reclamem de duplicidade, pois no tópico fala sobre MT e não AM):

 

Li em algum lugar recomendando aos estados que quando for retornado o erro 999 (não catalogado), o campo xMotivo deveria exibir o exception (CEP inválido, IE inválida, etc.), mas isso não está ocorrendo no AM.

WRMedeiros

Focus

Link to comment
Share on other sites

  • Moderadores

Este erro aconteceu comigo a um tempo atrás e era problema de validação dos dados, aqui eu estou usando os dados normais da empresa e configurando somente o webservice como AM, tem funcionado para testes normalmente.

Esse erro não catalogado quando ocorreu comigo, enviei o XML para o suporte de NFC-e do AM e eles me retornaram o problema.

Equipe ACBr

Régys Borges da Silveira

http://www.regys.com.br

certificacao delphicertificacao delphi
Link to comment
Share on other sites

Nilton,

 

Testei com as 3 versões, não consigo.

 

Até mesmo um "Status do Serviço" falha, veja:

https://www.dropbox.com/s/gu7eomij68rnp7j/ACBr_NFCe1.png?dl=0

 

Configuração da versão:

https://www.dropbox.com/s/4b5qsouulm70vfg/ACBr_NFCe2.png?dl=0

 

Acredito que pode ser algo no cadastro (algum dado do Emitente que não está sendo aceito no SEFAZ AM).

 

Régys, você poderia mandar um print da sua tela de cadastro de emitente do ACBrNFe2Demo? (troco apenas o CNPJ para ficar igual ao do meu certificado e envio para ver se vai ser aceito). Se for, testo campo a campo até descobrir o motivo da negação.

 

Conferi o certificado, está válido. Ontem atualizei a cadeia de certificados, etc. 

 

O engraçado é que via UniNFE eu testo o "Status do serviço" em Homologação e recebo o aviso de "Erro não catalogado". Em seguida mudo para "Produção", e o UniNFE mostra "Serviço em Operação".

WRMedeiros

Focus

Link to comment
Share on other sites

Acredito ser algo no webservice do ambiente de homologação.

 

Troquei o ambiente para "Produção" (meu CNPJ não é do AM, na pior hipótese receberia um aviso de CNPJ inválido, e foi o que aconteceu):

https://www.dropbox.com/s/vvyksbdnx4hi6do/ACBr_NFCe3.png?dl=0

 

Alguém HOJE está conseguindo emitir via SEFAZ-AM no ambiente de homologação usando o demo do ACBr?

WRMedeiros

Focus

Link to comment
Share on other sites

Show Nilton, muito obrigado, deu certo:

https://www.dropbox.com/s/8doerx7e66xt5sh/ACBr_NFCe4.png?dl=0

 

O estranho é que no site do SEFAZ diz que essa forma de configurar o token foi descontinuada, e que agora deve ser informado “0123456789” para o CSC e o identificador “000001”.

 

A hora do SEFAZ-AM está 1h atrasada (alguma coisa de fuso ,acredito). Tive que fazer um pequeno ajuste no GerarNFCe:

var
   D, M, Y, H, MM, S, MS:Word;
   cDataHora:TDateTime;
begin
   DecodeDateTime(Now, Y, M, D, H, MM, S, MS);
   H := H - 1;
   cDataHora := EncodeDateTime( Y, M, D, H, MM, S, MS);

   ...
   Ide.dEmi      := cDataHora;
 

WRMedeiros

Focus

Link to comment
Share on other sites

  • Este tópico foi criado há 2785 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.