Jump to content

Assista click.png tectoy.png

C6 chamada_c6.png botao.png

Daruma DR800


Go to solution Solved by moacirg,
  • Este tópico foi criado há 1269 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Moderadores

Alguém tem experiência com essa impressora na emissão do DANFE NFC-e via ESCPos?

Não tinha conhecimento desse modelo novo da Daruma, e um cliente adquiriu.

Quando tenta emitir a NFC-e, o QR-Code não imprime, e quando vai imprimir a próxima nota, ele sai.

Estou tentando conseguir uma para testes, se alguém já tiver impresso NFC-e nesse modelo e puder dar alguma dica, agradeço.IMG-20151215-WA0001.thumb.jpg.d5598bd82e

Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

  • Moderadores

Você instalou o driver da DR800, é um driver diferente, se instalar o da DR700 não vai funcionar corretamente, peça ao pessoa da Daruma o driver da DR800 que vai funcionar.

Lembre-se que ao instalar o novo driver você deve remove o antigo primeiro.

Equipe ACBr

Régys Borges da Silveira

http://www.regys.com.br

certificacao delphicertificacao delphi
Link to comment
Share on other sites

  • Moderadores
Em 16/12/2015 at 09:06, Régys Silveira disse:

Você instalou o driver da DR800, é um driver diferente, se instalar o da DR700 não vai funcionar corretamente, peça ao pessoa da Daruma o driver da DR800 que vai funcionar.

Lembre-se que ao instalar o novo driver você deve remove o antigo primeiro.

Régys,

O problema acontece se a propriedade "ControlePorta" do PosPrinter estiver marcada.

No meu programa essa opção está sempre ativada, então quando testei a impressão pelo demo do ACBr e imprimiu normal, consegui isolar o problema.

Deslize meu não ter testado o demo antes, desculpem.

Em todo caso, eu havia ativado a propriedade para não precisar abrir e fechar a porta serial da impressora sempre que fosse emitir algum relatorio, ou mesmo NFC-e, e desativando continuou a emitir normal, mas não tenho como testar em outros modelos de impressora. A ControlePorta ainda é necessária? 

Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

  • Moderadores
22 horas atrás, BigWings disse:

Régys,

O problema acontece se a propriedade "ControlePorta" do PosPrinter estiver marcada.

No meu programa essa opção está sempre ativada, então quando testei a impressão pelo demo do ACBr e imprimiu normal, consegui isolar o problema.

Deslize meu não ter testado o demo antes, desculpem.

Em todo caso, eu havia ativado a propriedade para não precisar abrir e fechar a porta serial da impressora sempre que fosse emitir algum relatorio, ou mesmo NFC-e, e desativando continuou a emitir normal, mas não tenho como testar em outros modelos de impressora. A ControlePorta ainda é necessária? 

Estranho, eu deixo o controleporta como True por padrão é nunca tive problemas.

5 horas atrás, Pr Genilson Soares disse:

Como fazer a comunicação com impressora através de IP ao invés de porta serial???

você pode compartilhar a impressora na rede é usar o caminho do compartilhamento ou seguir o padrão

 

TCP:IP

Equipe ACBr

Régys Borges da Silveira

http://www.regys.com.br

certificacao delphicertificacao delphi
Link to comment
Share on other sites

  • Moderadores
1 hora atrás, Régys Silveira disse:

Estranho, eu deixo o controleporta como True por padrão é nunca tive problemas.

Testei em outro PC onde a impressão funcionou, mesmo com o ControlePorta ativado.

Você disse pra remover o driver antigo, da DR700, mas não encontrei como. Apenas removi a porta virtual e instalei o driver fornecido pela Daruma. Tem algo mais que devo fazer pra remover os drivers DR700 e DR800 que instalei anteriormente?

Outra coisa, você testou em Windows 8/8.1?

Enquanto isso vou vendo com o pessoal da Daruma.

Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

  • 2 weeks later...

Estou com o mesmo problema, deixo o controle da porta ativo e não imprime o QRCODE, ele para logo depois de imprimir o barras do cupom.

Pior que ao desativar o controle da porta, funciona, porem prejudica os relatórios.

Como conseguiram solucionar ? Podem me ajudar, por favor ?

Obrigado

Link to comment
Share on other sites

  • Moderadores

Ainda não resolvi.

Instalei o driver correto com a ajuda do suporte da Daruma (tem que aparecer no driver o signatário Daruma e não Microsoft), e fiz os testes com os aplicativos deles e funcionou sem problemas.

Já no ACBr só funciona se desativar o ControlePorta.

Por enquanto não estou recomendando esse modelo.

Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

18 horas atrás, BigWings disse:

Ainda não resolvi.

Instalei o driver correto com a ajuda do suporte da Daruma (tem que aparecer no driver o signatário Daruma e não Microsoft), e fiz os testes com os aplicativos deles e funcionou sem problemas.

Já no ACBr só funciona se desativar o ControlePorta.

Por enquanto não estou recomendando esse modelo.

Encontrei uma solução totalmente na gambiarra, mas funcionou comigo.

Eu percebi que ao rodar o POSPRINTER em modo de DEBUG o QRCode acabava saindo normal. Então deduzi que a impressora não estava conseguindo interpretar as informações tão rápidas quanto recebe.

Por isso coloquei um Sleep(1000) na funcão que desativa a porta da Unit AcbrPosPrinter, ficando assim :

 

procedure TACBrPosPrinter.DesativarPorta;
begin
  sleep(1000);   // --> Só fiz isso e rodou tudo normal  o QRCode
  if FDevice.Ativo then
  begin
    GravarLog('Desativando a porta: ' + FDevice.Porta);
    FDevice.Desativar;

    if not FDevice.IsSerialPort then
      FInicializada := False;
  end;
end;

Posso estar falando falando uma grande besteira, até peço desculpas, mas deu certo isso comigo.

Ps: Precisei desligar e ligar a impressora para zerar as configurações da mesma.

Se tiver tempo, faça o teste e depois retorna,

Abraço.

Edited by moacirg
  • Like 1
Link to comment
Share on other sites

  • Moderadores

Provavelmente é o buffer de recepção da sua porta virtual então que está com problemas, tente mudar a configuração do buffer da porta virtual, diminuindo ou aumentando ele até que imprima normalmente, na grande maioria dos computadores não é necessário alterar isso, mas alguns sim.

Equipe ACBr

Régys Borges da Silveira

http://www.regys.com.br

certificacao delphicertificacao delphi
Link to comment
Share on other sites

  • Solution
23 horas atrás, Régys Silveira disse:

Provavelmente é o buffer de recepção da sua porta virtual então que está com problemas, tente mudar a configuração do buffer da porta virtual, diminuindo ou aumentando ele até que imprima normalmente, na grande maioria dos computadores não é necessário alterar isso, mas alguns sim.

Apenas a nível de curiosidade, alterei para todos as velocidades o buffer da porta virtual e nada alterou.

De qualquer forma, obrigado pelo retorno.

 

Link to comment
Share on other sites

  • Moderadores

Você alterou a velocidade? Eu falei do buffer de recepção e transmissão e não velocidade.

Uma outra coisa, você usou o driver da DR800? Porque existe um driver específico para ela, apesar dela funcionar com o driver da DR700 ele não controla como deve, então o correto é remover o da DR700 se houver um instalado (clicando com botão direito no driver no gerenciador de dispositivos e clicando em remover) e instalar o novo correto da DR800.

Tenho DR800 e funciona perfeitamente, já coloquei em clientes também e não tive problemas.

Equipe ACBr

Régys Borges da Silveira

http://www.regys.com.br

certificacao delphicertificacao delphi
Link to comment
Share on other sites

Sim Régys, cheguei a deixar a velocidade do buffer em Baixa e fui testando de em todas as velocidades de porta, mesmo assim não obtive sucesso.

O driver estou usando o da DR 800 USB, fornecido no site da Daruma.

Testei em outras maquinas tmb e o problema persiste, a impressão é interrompida bem no inicio do QRCODE e só imprime no cupom seguinte.

Apenas utilizando sleep(1000) deu certo.

 

Link to comment
Share on other sites

Eu entendo e compreendo, mas como pode ver no post acima, nosso amigo BigWings esta com o mesmo problema, apenas desativando o controle da porta que consegue resolver, o que torna inviável, pois a porta fica reservada. Mas enfim, resolvido com o sleep.

Muito obrigado pela atenção.

Link to comment
Share on other sites

  • Moderadores
Em 31/12/2015 at 12:21, moacirg disse:

Encontrei uma solução totalmente na gambiarra, mas funcionou comigo.

Eu percebi que ao rodar o POSPRINTER em modo de DEBUG o QRCode acabava saindo normal. Então deduzi que a impressora não estava conseguindo interpretar as informações tão rápidas quanto recebe.

Por isso coloquei um Sleep(1000) na funcão que desativa a porta da Unit AcbrPosPrinter, ficando assim :

 

procedure TACBrPosPrinter.DesativarPorta;
begin
  sleep(1000);   // --> Só fiz isso e rodou tudo normal  o QRCode
  if FDevice.Ativo then
  begin
    GravarLog('Desativando a porta: ' + FDevice.Porta);
    FDevice.Desativar;

    if not FDevice.IsSerialPort then
      FInicializada := False;
  end;
end;

Posso estar falando falando uma grande besteira, até peço desculpas, mas deu certo isso comigo.

Ps: Precisei desligar e ligar a impressora para zerar as configurações da mesma.

Se tiver tempo, faça o teste e depois retorna,

Abraço.

Testei dessa forma e resolveu o problema. Mesmo reduzindo para Sleep(50) imprimiu normalmente.

Obrigado.

 

Em 01/01/2016 at 12:41, Régys Silveira disse:

Provavelmente é o buffer de recepção da sua porta virtual então que está com problemas, tente mudar a configuração do buffer da porta virtual, diminuindo ou aumentando ele até que imprima normalmente, na grande maioria dos computadores não é necessário alterar isso, mas alguns sim.

O buffer da porta estava no máximo, tentei várias configurações de buffer e não surtiu nenhum efeito.

  • Like 1
Equipe ACBr BigWings
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

 

 

Link to comment
Share on other sites

7 minutos atrás, kohzito disse:

Comigo aconteceu exatamente igual.

Sem o Sleep ele imprime o Qr Code apenas na proxima impressão, mas colocando o salvador sleep funciona perfeitamente

Outra forma que vc vai perceber que funciona é depurando o código durante a impressão, rodando linha a linha. Ae vai funcionar. Foi assim que descobri o Sleep. Não sei porque, mas parece que a impressora precisa de um tempo para processar antes de receber mais comandos, ou algo assim. Coisa de loco essa Dr 800.

 

Link to comment
Share on other sites

Em 15/01/2016 at 16:37, moacirg disse:

Outra forma que vc vai perceber que funciona é depurando o código durante a impressão, rodando linha a linha. Ae vai funcionar. Foi assim que descobri o Sleep. Não sei porque, mas parece que a impressora precisa de um tempo para processar antes de receber mais comandos, ou algo assim. Coisa de loco essa Dr 800.

 

Imagine, como tinha que fazer algo rapido nem fiz varios testes, aproveitei os testes feitos aqui.

Há um tempo eu tinha um codigo parecido que não funcionava diretamente e no debug não dava pau e foi solucionado com um sleep (3000).

O engraçado é que em algumas maquinas como foi constatado aqui, funciona sem a necessidade do sleep.

Link to comment
Share on other sites

  • 4 weeks later...
  • 2 weeks later...

Tentei em todas as possíveis velocidades do Buffer de Recepção, mas o erro persiste!

Enfim, também tive que acrescentar um Sleep (100) na procedure TACBrPosPrinter.DesativarPorta;
E daí o QRcode imprimiu normalmente na DR800.

Sendo assim, para o pessoal que usará DR800, não haveria como o pessoal do ACBr colocar uma tag no componente, um valor inteiro que quando maior que zero indicaria que haverá um Sleep na função?

Link to comment
Share on other sites

Liguei no suporte da Daruma, ainda não fiz os testes porque minha DR800 não esta comigo hoje.

Na conversa com o Regys nos posts acima, ele disse que não teve nenhum problema com a impressora. Já todos nós, estamos aqui apanhando.

No meu caso,  estava usando a impressora na porta serial, e ao plugar o cabo atrás dela, aparece a opção Configurar Velocidade Porta Serial no menu do Firmware da impressora. Esta opção aparece quando o cabo serial é conectado atrás ou se nenhum cabo estiver conectado. Se colocar cabo USB essa opçao nao aparece.

Pra aparecer o menu do Firmware é preciso Desligar a impressora, e ligar novamente com o botão Avanço pressionado.

Na DR 700, tinhamos o Daruma Tool pra configurar a Velocidade da Porta.

Já na Dr 800, esse menu esta na propria impressora.

As vezes pode ser isso que o Régys conseguiu imprimir sem problemas e nós estamos aqui quebrando a cabeça.

Ela vem de Fabrica com o Baud de 9600.

Testem e postem galera !!!!!

Link to comment
Share on other sites

  • Este tópico foi criado há 1269 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.
Guest
This topic is now closed to further replies.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.