Jump to content

Delphi chamada_delphi.png acbr.png

C6 chamada_c6.png botao.png

Grupo ICMSUFDest - homologação para RN


  • Este tópico foi criado há 2260 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Boa tarde

com trunk2 - ao enviar com as tags do difal, como abaixo:

<ICMSUFDest>

  <vBCUFDest>2890.00</vBCUFDest>
  <pFCPUFDest>2.0000</pFCPUFDest>
  <pICMSUFDest>17.0000</pICMSUFDest>
  <pICMSInter>7.00</pICMSInter>
  <pICMSInterPart>10.0000</pICMSInterPart>
  <vFCPUFDest>57.80</vFCPUFDest>
  <vICMSUFDest>115.60</vICMSUFDest>
  <vICMSUFRemet>173.40</vICMSUFRemet>
  </ICMSUFDest>
 
destino: RN.
ao enviar para sefaz, dá um erro e não mostra sequer qual o erro. tem apenas um item na NF, conforme tela anexada:
atualizei o ACBR, e fiz o instal novamente para recompilar. mas continua o erro.

 

acbrnfe erro.jpg

Link to comment
Share on other sites

pelo que entendi, analisando os fontes do Acbr, o erro acima vem da Sefaz. mas vem sem a descrição. e fica impossível descobrir o motivo. e só gera este erro quando se calcula a tag da difal: ICMSUFdest. abaixo, as tags do item. a nf tem um item apenas:

<det nItem="1">

- <prod>
  <cProd>0304024</cProd>
  <cEAN />
  <xProd>FICHARIO REVESTIDO 6CM 2 ARGOLAS A4 BRANCO</xProd>
  <NCM>42021210</NCM>
  <CFOP>6102</CFOP>
  <uCom>UN</uCom>
  <qCom>100.0000</qCom>
  <vUnCom>28.9000000000</vUnCom>
  <vProd>2890.00</vProd>
  <cEANTrib />
  <uTrib>UN</uTrib>
  <qTrib>100.0000</qTrib>
  <vUnTrib>28.9000000000</vUnTrib>
  <indTot>1</indTot>
  </prod>
- <imposto>
- <ICMS>
- <ICMS00>
  <orig>0</orig>
  <CST>00</CST>
  <modBC>2</modBC>
  <vBC>2890.00</vBC>
  <pICMS>7.0000</pICMS>
  <vICMS>202.30</vICMS>
  </ICMS00>
  </ICMS>
- <PIS>
- <PISAliq>
  <CST>01</CST>
  <vBC>0.00</vBC>
  <pPIS>0.0000</pPIS>
  <vPIS>0.00</vPIS>
  </PISAliq>
  </PIS>
- <COFINS>
- <COFINSAliq>
  <CST>01</CST>
  <vBC>0.00</vBC>
  <pCOFINS>0.0000</pCOFINS>
  <vCOFINS>0.00</vCOFINS>
  </COFINSAliq>
  </COFINS>
- <ICMSUFDest>
  <vBCUFDest>2890.00</vBCUFDest>
  <pFCPUFDest>0.0000</pFCPUFDest>
  <pICMSUFDest>17.0000</pICMSUFDest>
  <pICMSInter>7.00</pICMSInter>
  <pICMSInterPart>10.0000</pICMSInterPart>
  <vFCPUFDest>0.00</vFCPUFDest>
  <vICMSUFDest>115.60</vICMSUFDest>
  <vICMSUFRemet>173.40</vICMSUFRemet>
  </ICMSUFDest>
  </imposto>
  </det>
 
se puderem me ajudar. agradeço. Hércules.
anexado, o xml completo.

33160207296482000118550010009099281001634179-NFe.xml

Link to comment
Share on other sites

fiz um teste enviando a mesma NFe, mas: consumidor final=não. contribuinte ICMS=não. assim, não foi enviado o bloco ICMSUFdest.

e em homologação, passou. consegue enviar.

o problema é quando insere o bloco ICMSUFdest.

uma curiosidade é que a empresa destino, na sefaz RN, ´tem inscrição estadual, mas está baixada.

Link to comment
Share on other sites

apenas para documentar, para quem interessar possa.

descobri o problema, usando uma versão do sistema compilada com o trunk2 de Nov/2016. nesta versão antiga, mostra a descrição normal do erro, e descobri que era a alíquota do ICMS (ICMSInter) que está errada (só pode ser 4,7,12).

com o trunk2 de Fevereiro/16, dá o erro mas não mostra a descrição da rejeição. apenas: ...[item:1]

ao invés de nov/2016, leia-se: nov/2015, obviamente.

Link to comment
Share on other sites

  • Consultores

e se você atualizou ontem ele depois das 18 horas vai ver que o erro parou de ocorrer! só pra documentar também

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

 Olá pessoal, estou com problemas para autorizar NFC-e homologação Trunk2, aparece erro no gurpo  ICMSUFDest.

Li aqui no forum que basta atualizar a pasta Schemas copiando da pasta exemplo do ACBR, porém fazendo isso o sistema não localiza a pasta Schema (acho que falta arquivo no demo), Testando pelo Demo também não localiza a pasta ver anexo 2. 

Captura de tela 2016-02-25 12.10.32.png

Captura de tela 2016-02-25 12.21.20.png

Edited by FLEXNET

Ricardo

Flexnet Sistemas

Link to comment
Share on other sites

Na NFCe, não pode mesmo ter este bloco ICMSUFdest.

este bloco é exclusivo para consumidor final, fora da UF do emitente.

e NFCe NÃo permite emitir NFCe para fora da UF. ou seja, é apenas para dentro da própria UF do emitente.

Então programe para que este bloco não seja inserido na NFCe.

  • Like 1
Link to comment
Share on other sites

Em 25/02/2016 at 13:17, Hrsoft Brasil disse:

Na NFCe, não pode mesmo ter este bloco ICMSUFdest.

este bloco é exclusivo para consumidor final, fora da UF do emitente.

e NFCe NÃo permite emitir NFCe para fora da UF. ou seja, é apenas para dentro da própria UF do emitente.

Então programe para que este bloco não seja inserido na NFCe.

Mesmo não informando o bloco aparece a mensagem, acredito que seja os arquivos de Schemas (XSD), já tentei com XSD do Demostração e aprece o erro "Arquivo Schema não Especificado". Conforme citado anteriormente.

 

Edited by FLEXNET

Ricardo

Flexnet Sistemas

Link to comment
Share on other sites

Em 25/02/2016 at 13:17, Hrsoft Brasil disse:

Na NFCe, não pode mesmo ter este bloco ICMSUFdest.

este bloco é exclusivo para consumidor final, fora da UF do emitente.

e NFCe NÃo permite emitir NFCe para fora da UF. ou seja, é apenas para dentro da própria UF do emitente.

Então programe para que este bloco não seja inserido na NFCe.

Olá Hrsoft, percebi hoje que o componente Acbr esta montando este bloco ICMSSUFdest no XML, mesmo não informando bloco no código,  sabe dizer como fazer para não informar este bloco ?

 

 

Ricardo

Flexnet Sistemas

Link to comment
Share on other sites

  • Moderadores
9 horas atrás, FLEXNET disse:

Olá Hrsoft, percebi hoje que o componente Acbr esta montando este bloco ICMSSUFdest no XML, mesmo não informando bloco no código,  sabe dizer como fazer para não informar este bloco ?

 

 

Você provavelmente está desatualizado, atualize o ACBr.

Outra coisa ele vai gera o bloco somente quando o valor do percentual de partilha for informado, ou seja, quando "Imposto.ICMSUFDest.pICMSInterPart" for maior que zero.

Equipe ACBr

Régys Borges da Silveira

http://www.regys.com.br

certificacao delphicertificacao delphi
Link to comment
Share on other sites

14 horas atrás, Régys Silveira disse:

Você provavelmente está desatualizado, atualize o ACBr.

Outra coisa ele vai gera o bloco somente quando o valor do percentual de partilha for informado, ou seja, quando "Imposto.ICMSUFDest.pICMSInterPart" for maior que zero.

Obrigado Regys, atualizei com componentes, recompilei com build, não esta aparecendo mais o bloco  ICMSSUFdest,   porém esta com falha na validação do XML:

ico_menos.giferro.pngNF-e

  • erro.pngProcessamento do Lote
    • bullet_black.png 239 - Rejeicao: Versao do arquivo XML nao suportada

Ricardo

Flexnet Sistemas

Link to comment
Share on other sites

Em 05/03/2016 at 10:01, Régys Silveira disse:

Você provavelmente está desatualizado, atualize o ACBr.

Outra coisa ele vai gera o bloco somente quando o valor do percentual de partilha for informado, ou seja, quando "Imposto.ICMSUFDest.pICMSInterPart" for maior que zero.

Regys, anexo XML, esta gerando com versão infNFe versao="3.00", já setei no componente e também via codigo para ve310, mas sempre sai 3.00

51160300169060000132650010000000021000000025-nfe.xml

Ricardo

Flexnet Sistemas

Link to comment
Share on other sites

21 horas atrás, Italo Jurisato Junior disse:

Boa tarde Ricardo,

E ao alimentar o componente, qual é o valor que você esta passando para a propriedade versao?

Ítalo, não encontrei a propriedade "Versão" somente desta forma:

   ACBrNFe1.Configuracoes.Geral.ModeloDF := moNFCe;
   ACBrNFe1.Configuracoes.Geral.VersaoDF := ve310;

Edited by FLEXNET

Ricardo

Flexnet Sistemas

Link to comment
Share on other sites

Em 07/03/2016 at 17:42, Italo Jurisato Junior disse:

Boa tarde Ricardo,

Se não me falha a memória já respondi em outro tópico seu sobre o mesmo assunto.

 Sim já respondeu obrigado.

Em 05/03/2016 at 10:01, Régys Silveira disse:

Você provavelmente está desatualizado, atualize o ACBr.

Outra coisa ele vai gera o bloco somente quando o valor do percentual de partilha for informado, ou seja, quando "Imposto.ICMSUFDest.pICMSInterPart" for maior que zero.

Feedback... atualizei e reeinstalei os componentes, depois mais alguns ajustes aqui com ajuda do Italo, deu tudo certo.

Obrigado.

 

 

Ricardo

Flexnet Sistemas

Link to comment
Share on other sites

  • Este tópico foi criado há 2260 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.