Jump to content

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png click.png click.png

Problemas de conexão SEFAZ - RS


  • Este tópico foi criado há 1744 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Boa tarde

Pessoal, esse post tem por objetivo fazer uma pesquisa entre os usuários do ACBR que fazem envio de NFCe para a SEFAZ - RS

Eu estou enfrentando um problema de ocorrer com muita frequência falha de comunicação ao tentar enviar uma NFCe  ("erro interno 10060 HTTP:0 ou Erro interno 10091 HTTP:500)"

Além de estar ocorrendo com muita frequencia em todos os clientes, em alguns casos em que ha uma demora excessiva para retonrar o erro ( até 3 Min, em alguns casos)

A internet do Cliente já foi testada e está super estável. A SEFAZ-RS diz que está autorizando e retornando a resposta em menos de 1 seg.

Já tratei o assunto com os mestres aqui do ACBR e eles chegaram a conclusão que não ha o que fazer por parte do componente para resolver o problema.

Sendo assim, gostaria de saber se tem mais alguém enfrentando esse problema .

Obrigado.

Link to comment
Share on other sites

  • Membros Pro
1 hora atrás, claudiomiguelmuller disse:

Tenho um caixa apenas, mas ele não tem tido problemas. 100 notas por dia, 1 ou 2 em contingência, mas ali entra erros de internet mesmo, NCM, etc.

Vc usa como OpensSSL ?  Modo Síncrono ?

Quando foi a última vez que vc atualizou o ACBR ?

 

Edited by Dércio Luis Zanatta
Link to comment
Share on other sites

  • 2 weeks later...

Tive/tenho o mesmo problema aqui, com envio sincrono + openssl. Tentei várias versões do openssl, monitorei internet, etc. Abandonei o openssl e estou usando capicom sem nenhum problema. Aqui acontece exatamente como você relatou em uns 5% das notas. Se descobrir alguma informação adicional avise!

Link to comment
Share on other sites

  • Membros Pro
10 minutos atrás, virtualsys disse:

Tive/tenho o mesmo problema aqui, com envio sincrono + openssl. Tentei várias versões do openssl, monitorei internet, etc. Abandonei o openssl e estou usando capicom sem nenhum problema. Aqui acontece exatamente como você relatou em uns 5% das notas. Se descobrir alguma informação adicional avise!

Ola amigo...

Muito obrigado por responder..  De alguma forma fico mais tranquilo em saber que não sou somente que estou com tal problema.

No meu caso fica complicado de usar como Capicom, pois dessa forma teria que instalar o certificado em cada caixa do mercado refazer essa instalação uma vez por ano..

São 12 caixa em média para cada mercado (uns 30 mercados)

De qualquer forma, vou fazer o teste em um outro cliente que tem um caixa somente e que ocorre o problema também, só para tirar a dúvida...

Posto o resultado aqui depois..

 

Link to comment
Share on other sites

  • Membros Pro

Boa tarde

Está confirmado.. O problema de falha de comunicação ocorre somente utilizando OPENSSL.  

Fiz o teste. Em um cliente meu onde ocorria bastante problema de entrar em contingência por falha de comunicação. Instalei o certificado A1 no windows e passei a usar como Capicom, passando o número de série do certificado..

Fiz isso hj as 7 horas da manhã.. Até agora nenhuma nota deu problema de conexão.

Sendo assim, o problema não parece ter relação com a Rede, internet ou WS da Sefaz, mas sim quando se configura o componente como OpenSSL.

Espero que esse problema tenha solução, pois vai ficar inviável ter que instalar o certificado em cada terminal de venda !!

Alguém tem alguma idéia do que pode ser feito para não dar o problema como OpenSSL ?

 

Link to comment
Share on other sites

  • Membros Pro
Em 01/12/2016 at 16:19, virtualsys disse:

Tive/tenho o mesmo problema aqui, com envio sincrono + openssl. Tentei várias versões do openssl, monitorei internet, etc. Abandonei o openssl e estou usando capicom sem nenhum problema. Aqui acontece exatamente como você relatou em uns 5% das notas. Se descobrir alguma informação adicional avise!

Boa tarde

Fiz uma alteração aqui que resolveu o problema:

Eu estava utilizando o Componente ACBR dentro de um DataModule carregado na memória. O que fiz foi colocar o Componente em outro Formulário que não fica carregado em memória. Antes de usar o componente faço o carregamento do formulário (Application.CreateForm(TFrmNFce,FrmNFCe) , no final de tudo, depois de enviar, imprimir danfe, enviar e-mail etc... eu dou um Free no fromulário (FrmNFCe.Free).

Dessa forma não entra mais nenhuma NFCe em Contingência OFF Line, todas são autorizadas normalmente Utilizando OpensSSL + modo Síncrono.

Espero que funcione para você também !

Abraço.

 

Link to comment
Share on other sites

  • Este tópico foi criado há 1744 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.