Jump to content

botao.pngbotao.png

PARA DEVS E SW. HOUSES
Novos Palestrantes e Patrocinadores confirmados!

dia-do-acbr-online.png  

Saiba Mais

botao.pngbotao.png

botao.pngbotao.png

Ofertas Embarcadero
Descontos de até 35%

Saiba Mais

logo_acbr_paygo.png

TEF ACBr PayGo
Seja um revendedor e ofereça uma solução completa para seu cliente.


botao.png

beneficios.png

provedor de criptografia


Go to solution Solved by volmir,
  • Este tópico foi criado há 1181 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

depois que atualizei o sistema e configurei com A3, esta retronando a mensagem de "Provedor de Criptografia não encontrado".

imagem em anexo, o erro ocorreu ao clicar no botao pra retornar a validade do certificado

erroDemo.png

Link to post
Share on other sites
  • Solution

bom dia,

descobri o que ocasionava este erro.

meu certificado é um A3 e estava com problema de comunicacao retirei o cabo e conectei novamente ai voltou a funcionar

Link to post
Share on other sites

Boa tarde! 

Então, fiz a atualização da trunck2 ontem a noite, desabilitei e removi tudo o que era CAPICOM, descomentei a MINGW,  recompilei projeto e componente, enfim, segui todos os roteiros indicados aqui no fórum... Utilizando o demo AcbrNFe - Para certificados A1 tudo funcionando perfeito com OpenSSL, porém para certificados do tipo A3 usando WinCrypt o erro acontece exatamente como descrito acima... Até vi uma citação do @Daniel Simoes onde diz que poderia ser problema com o hardware mas observando o Administrador do Token o mesmo encontra-se presente e usando o mesmo certificado digital consigo acessar por exemplo o site do eCAC da Receita Federal sem problemas, então não sei onde estaria o problema e se possível necessito da ajuda de vocês.

Desde já agradeço antecipadamente.

Link to post
Share on other sites
  • Fundadores

Pode ser que o driver desse fabricante não possua interface com a WinCrypt...

Infelizmente não tenho como investigar, sem o hardware...

Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to post
Share on other sites

Vejam só... dando erro em todas as tentativas que eu havia feito até sair da empresa e vir pra casa. Chegando em casa liguei novamente o note fiz o teste e Pah! Funcionou como um milagre... Alguma coisa sinistra que ocorre no Windows 10 em equipamentos com HD SSD?... Será isso? O fato de desligar o equipamento e religa-lo novamente por incrível que possa parecer resolveu. Ou seja trunk2 100% validada A1 e A3 (pelo menos pra mim). De qualquer forma grato pelo retorno.

Abraço!

Link to post
Share on other sites
  • 2 weeks later...
  • Usuários SAC

Bom dia,

Fiz alguns testes e realmente, ao desconectar o hardware, ocorre esse erro.

Gostaria de solicitar que seja corrigida a palavra cripotografia. Ela aparece 3 vezes na unit function MsgErroGetCryptProvider: String, linha 125 da ACBrDFeWinCrypt.pas.

Pode parecer pouca coisa essa letra, mas, no meu caso, onde trato os erros pelo texto (e.message) para poder dar uma mensagem mais transparente ao usuário, seu eu buscar por criptografia no erro, não localizaria criptografia.

Obrigado!

  • Like 1

Valdir Dill

Rio de Janeiro - RJ

 

 

Link to post
Share on other sites

Boa tarde,

Esse problema aconteceu comigo, mas utilizando certificado A1 (arquivo).

Testei uns 3 certificados e acontecia o mesmo problema, porém na DEMOS funcionava.

Então ajustei todos os parâmetros do componente conforme a demo.

Depois que mudei Webservice.TimeOut := 20000 o problema foi sanado.

Acredito que isso possa ajudar, não custa tentar.

Dercide.

Link to post
Share on other sites
55 minutos atrás, Dercide Alvarez disse:

Boa tarde,

Esse problema aconteceu comigo, mas utilizando certificado A1 (arquivo).

Testei uns 3 certificados e acontecia o mesmo problema, porém na DEMOS funcionava.

Então ajustei todos os parâmetros do componente conforme a demo.

Depois que mudei Webservice.TimeOut := 20000 o problema foi sanado.

Acredito que isso possa ajudar, não custa tentar.

Dercide.

Acredito que tenha sido alguma outra propriedade modificada ao mesmo tempo, pois estes erros estão acontecendo na assinatura do arquivo, antes mesmo do envio para o webservice...

  • Like 1
Link to post
Share on other sites
  • Fundadores
9 horas atrás, valdirdill disse:

Bom dia,

Fiz alguns testes e realmente, ao desconectar o hardware, ocorre esse erro.

Gostaria de solicitar que seja corrigida a palavra cripotografia. Ela aparece 3 vezes na unit function MsgErroGetCryptProvider: String, linha 125 da ACBrDFeWinCrypt.pas.

Pode parecer pouca coisa essa letra, mas, no meu caso, onde trato os erros pelo texto (e.message) para poder dar uma mensagem mais transparente ao usuário, seu eu buscar por criptografia no erro, não localizaria criptografia.

Obrigado!

Corrigido....

5 horas atrás, Gabriel Bonzanini disse:

Estou tendo o mesmo problema... Tentei reinstalar o certificado digital, removê-lo e plugá-lo novamente e reiniciar o computador, mas o erro persiste... Passou a ocorrer depois da última atualização dos componentes.

Se você não passar um passo a passo, detalhado, de como configurar o Demo do ABCrNFe, e quais ações até a execução do problema... Nenhuma atitude será realizada pela equipe de desenvolvimento..

  • Like 1
Consultor SAC ACBr

Daniel Simões de Almeida
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to post
Share on other sites
  • 2 months later...

Tive este problema de provedor de criptografia e consegui resolver com este procedimento no windows.

 

Para especificar um provedor de serviços de criptografia usando a interface do Windows

  1. Para abrir o console de Configuração do Cliente NAP, clique em Iniciar, em Todos os Programas, em Acessórios e em Executar, digite NAPCLCFG.MSC e clique em OK.

  2. Abra Config. do Registro de Integridade e clique em Diretiva de Solicitação.

  3. Clique com o botão direito do mouse em Provedor de Serviços de Criptografia e clique em Propriedades.

  4. Na caixa de diálogo Propriedades de Provedor de Serviços de Criptografia, clique em Específico e no provedor de serviços de criptografia que deseja usar.

Edited by oguiadacidade
Link to post
Share on other sites
  • Este tópico foi criado há 1181 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...