Jump to content

Delphi chamada_delphi.png acbr.png

C6 chamada_c6.png botao.png

  • Este tópico foi criado há 1765 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

Bom dia!

A Sefaz BA, Informa que já está com o ambiente de Homologação NFe 4.00 em funcionamento mas não conseguindo fazer comunicação, 
Porem consigo com outros Estados. 

Modifiquei o arquivo “ACBrNFeServicos.ini”, acrescentando os endereços que me enviaram, 
em seguida executei a bat “Compila_RES.BAT” e depois compilei o projeto. Mais ainda não consigo obter retorno do “Status de Serviço”.


Segue modificação feitas em “ACBrNFeServicos.ini”:

[NFe_BA_H]
NfeRecepcao_2.00=https://hnfe.sefaz.ba.gov.br/webservices/nfenw/NfeRecepcao2.asmx
NfeRetRecepcao_2.00=https://hnfe.sefaz.ba.gov.br/webservices/nfenw/NfeRetRecepcao2.asmx
NfeInutilizacao_2.00=https://hnfe.sefaz.ba.gov.br/webservices/nfenw/nfeinutilizacao2.asmx
NfeConsultaProtocolo_2.00=https://hnfe.sefaz.ba.gov.br/webservices/nfenw/nfeconsulta2.asmx
NfeStatusServico_2.00=https://hnfe.sefaz.ba.gov.br/webservices/nfenw/NfeStatusServico2.asmx
NfeConsultaCadastro_2.00=https://hnfe.sefaz.ba.gov.br/webservices/nfenw/CadConsultaCadastro2.asmx
RecepcaoEvento_1.00=https://hnfe.sefaz.ba.gov.br/webservices/sre/recepcaoevento.asmx
NfeInutilizacao_3.10=https://hnfe.sefaz.ba.gov.br/webservices/NfeInutilizacao/NfeInutilizacao.asmx
NfeConsultaProtocolo_3.10=https://hnfe.sefaz.ba.gov.br/webservices/NfeConsulta/NfeConsulta.asmx
NfeStatusServico_3.10=https://hnfe.sefaz.ba.gov.br/webservices/NfeStatusServico/NfeStatusServico.asmx
NfeAutorizacao_3.10=https://hnfe.sefaz.ba.gov.br/webservices/NfeAutorizacao/NfeAutorizacao.asmx
NFeRetAutorizacao_3.10=https://hnfe.sefaz.ba.gov.br/webservices/NfeRetAutorizacao/NfeRetAutorizacao.asmx

NfeInutilizacao_4.00=https://hnfe.sefaz.ba.gov.br/webservices/NFeInutilizacao4/NFeInutilizacao4.asmx
NfeConsultaProtocolo_4.00=https://hnfe.sefaz.ba.gov.br/webservices/NFeConsultaProtocolo4/NFeConsultaProtocolo4.asmx
NFeStatusServico_4.00=https://hnfe.sefaz.ba.gov.br/webservices/NFeStatusServico4/NFeStatusServico4.asmx
NfeAutorizacao_4.00=https://hnfe.sefaz.ba.gov.br/webservices/NFeAutorizacao4/NFeAutorizacao4.asmx
NFeRetAutorizacao_4.00=https://hnfe.sefaz.ba.gov.br/webservices/NFeRetAutorizacao4/NFeRetAutorizacao4.asmx
 

Link to comment
Share on other sites

Fiz o envio de uma NFe usando a lib " libCapicom" e me retornou o seguinte erro:

CNPJ do transmissor do lote difere do CNPJ do transmissor da consulta.

outra situação é quando uso a lib: "libWinCrypt" no Status de Serviço me retorno erro:

12175 - Um ou mais erros foram encontrados no certificado mas para outros estados não da erro.

quando uso "OpenSSL" me retorna erro de validação no campo unidade do produto. 

Link to comment
Share on other sites

  • Consultores

Boa tarde Vagner,

No caso do OpenSSL, veja na pasta de Schemas que existe um XSD que devemos usar em substituição a outro, exemplo:

tiposBasico_v3.10

tiposBasico_v3.10_OPENSSL

Para que usa o OpenSSL devemos usar o segundo arquivo, obviamente renomeado para tiposBasico_v3.10, caso contrario vai ocorrer erros com o campo Unidade do Produto.

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • Consultores

Vagner,

Se o problema se encontra apenas na versão 4.00, você chegou a atualizar os fontes?

Pois ontem e hoje houve vários ajustes e alguns deles referente a versão 4.00

Agora se esta com os fontes em dia, lembre-se que o problema pode ser na SEFAZ em função da liberação do ambiente de homologação para a versão 4.00

A SEFAZ nem sempre consegue liberar sem nenhum erro, sempre tem que fazerem correções nos Web Services.

Consultor SAC ACBr Italo Giurizzato Junior
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

Analista de Sistemas / e-mail: [email protected] / Fone: (16) 9-9701-5030 / Araraquara-SP

Link to comment
Share on other sites

  • Fundadores

OpenSSL... parece haver algo errado no servidor da Bahia, onde o TLS 1.2 não funciona...

Citar

Em 13/07/2017, à(s) 15:28, André Ferreira de Moraes - DJSystem escreveu:
> se eu comento essa linha:

  if FPConfiguracoesNFe.Geral.VersaoDF >= ve400 then
  begin
   // FPDFeOwner.SSL.SSLType := LT_TLSv1_2;

Em 13/07/2017, à(s) 15:28, André Ferreira de Moraes - DJSystem escreveu:
> ae funciona

Em 13/07/2017, à(s) 15:28, André Ferreira de Moraes - DJSystem escreveu:
> aparentemente os servidores não estão preparados pro TLS 1.2

 

 

Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

  • Consultores
1 minuto atrás, Daniel Simoes disse:

OpenSSL... parece haver algo errado no servidor da Bahia, onde o TLS 1.2 não funciona...

 

Sim Daniel estou com um certificado para testar pois está mesmo dando erro

mas é o cabeçalho do xml me parece que está com erro.

Consultor SAC ACBr Juliomar Marchetti
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr

skype: juliomar
telegram: juliomar
e-mail: [email protected]
http://www.juliomarmarchetti.com.br
MVP_NewLogo_100x100_Black-02.png
Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil

 

Link to comment
Share on other sites

  • Fundadores

Em relação ao meu Post anterior, notei que o André comentou as linhas indicadas, (já no SVN)... com isso o OpenSSL usará o que estiver configurado em DFeSSL.SSLType... LT_all (default), tentará estabelecer conexões usando o protocolo mais seguro (TLS 1.2) para o menos seguro (SSL 2)...

Consultor SAC ACBr

Daniel Simões de Almeida
O melhor TEF, é com o Projeto ACBr - Clique e Conheça
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.

Link to comment
Share on other sites

1 hora atrás, Vagner Santos disse:

Bom dia Pessoal!

Quando emito uma NFCe na versão 4.0 o cabeçalho do XML ta saindo com a versão 3.01 não serie 4.0?

Desculpem não tinha  percebido alinha abaixo;

  ACBrNFe1.Configuracoes.Geral.VersaoDF := ve310;

  • Thanks 1
Link to comment
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.