Jump to content

chamada diadoacbr

Assista tectoy.png

acbrnfe 4.0 tls 1.2 e consulta


tiagopassarella
Go to solution Solved by Agnaldo Prates,
  • Este tópico foi criado há 1703 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Recommended Posts

  • Membros Pro

Bom Dia amigos tudo bem ?

estou com um problema que é o seguinte...

eu fiz todas alterações para uso da NFe 4.0 e estou com alguns problemas e espero qeu possam me ajudar.

 

1 - se eu ajustar para apenas tls 1.2 so retorna como inativo ou inoperante e nao consigo fazer nenhum tipo de operação... estando a sslib como capicom.. se eu mudar a sslib para openSSL ele da erro de arquivo PFX que seria o certificado mas como alimentar o caminho se é um certificado a3 ?, lembrando qeu se eu deixar as configurações sslib capicom usando o tls e ssl consigo emitir nfe 4.0 normalmente... entao na verdade como devo proceder ?

 

2 - quando faço uma consulta plea chave com nfe 3.10 eu consigo obter o xml da sefaz com num de protocolo e tudo mais... porem quando muda para 4.0 nao alimenta mais essas tags... existe algum procedimento ?

 

atualizei o meu acbr ontem... ja para evitar problemas...

 

espero que possam me ajudar...

 

att

Tiago Passarella

 

Link to comment
Share on other sites

  • Solution
20 minutos atrás, tiagopassarella disse:

1 - se eu ajustar para apenas tls 1.2 so retorna como inativo ou inoperante e nao consigo fazer nenhum tipo de operação... estando a sslib como capicom.. se eu mudar a sslib para openSSL ele da erro de arquivo PFX que seria o certificado mas como alimentar o caminho se é um certificado a3 ?, lembrando qeu se eu deixar as configurações sslib capicom usando o tls e ssl consigo emitir nfe 4.0 normalmente... entao na verdade como devo proceder ?

Configuração que uso para A3

if ACBrNFe1.Configuracoes.Certificados.NumeroSerie='' then
ACBrNFe1.Configuracoes.Certificados.NumeroSerie := ACBrNFe1.NFE.SSL.SelecionarCertificado;

NFe.Configuracoes.Geral.SSLLib:=  libWinCrypt;
NFe.Configuracoes.Geral.SSLCryptLib   := cryWinCrypt;
NFe.Configuracoes.Geral.SSLHttpLib    := httpWinHttp;
NFe.Configuracoes.Geral.SSLXmlSignLib := xsMsXml;

 

_____________

Prates, Agnaldo

Link to comment
Share on other sites

  • Membros Pro
4 minutos atrás, Agnaldo Prates disse:

Configuração que uso para A3

if ACBrNFe1.Configuracoes.Certificados.NumeroSerie='' then
ACBrNFe1.Configuracoes.Certificados.NumeroSerie := ACBrNFe1.NFE.SSL.SelecionarCertificado;

NFe.Configuracoes.Geral.SSLLib:=  libWinCrypt;
NFe.Configuracoes.Geral.SSLCryptLib   := cryWinCrypt;
NFe.Configuracoes.Geral.SSLHttpLib    := httpWinHttp;
NFe.Configuracoes.Geral.SSLXmlSignLib := xsMsXml;

 

muito obrigado Agnaldo com essas configurações funcionou tanto para o A3 quanto para o A1.... a primeira parte de meu problema esta resolvido... e quanto a 2 alguma sugestao ?

Edited by tiagopassarella
Link to comment
Share on other sites

  • Este tópico foi criado há 1703 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.