Jump to content
Notícias do ACBr

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

click.png

logos

Texto.png

p200

click.png

click.png

click.png

Certificado A3 pedindo senha mesmo quando é informado


  • Este tópico foi criado há 891 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui

Recommended Posts

Olá pessoa, usamos os componente do ACBr para emitir nota fiscal aqui na empresa e está acontecendo uma coisa chata e não encontramos nada no fórum que solucione esse problema.

Alguns clientes tem certificado A3 e os mesmos pedem para o usuário digitar a senha mesmo quando a senha está informada no componente do TACBrNFe, debugando o código do percebi que essa senha é solicitada pelas dlls que fazem a requisição a SEFAZ.

Segue o código onde é realizada a configuração:

NFe.Configuracoes.Certificados.ArquivoPFX  := iniMonitor.ReadString('Certificado' ,'Caminho' ,'')
NFe.Configuracoes.Certificados.NumeroSerie := iniMonitor.ReadString('Certificado' ,'NumSerie','');
NFe.Configuracoes.Certificados.Senha       := Crypto(iniMonitor.ReadString('Certificado' ,'Senha',''));
NFe.SSL.DescarregarCertificado;

NFe.Configuracoes.Geral.SSLLib           := TSSLLib(iniMonitor.ReadInteger('Certificado', 'SSLLib', 2));

Importante

Testamos com dois certificados de duas marcas diferentes e ocorreu o mesmo problema

O que eu já tentei fazer?

Tentamos carregar o certificado antes de executar as requisições.

O que podemos estar fazendo de errado?

Link to post
Share on other sites
  • 1 month later...

Estou enfrentando o mesmo problema relatado aqui. Já e o terceiro cliente que me reclama dessa senha. Hoje fiquei a manhã toda conectado junto ao pessoal da SOLUTI e não conseguir resolver o problema. O certificado está instalado normalmente. Como minha aplicação estava pedindo a senha fui para o demo testar o mesmo. Configurei com wincrypt utilizando A3. Coloquei a senha no campo senha do camponente para não ser solicitado e mesmo assim ele pede. Deixei em branco para pedir somente uma vez e todo o serviço que vai executar ele solicita a senha. Emitir 10 notas e me pediu 10 vezes para enviar e 10 para consultar o lote. Eu rodei o forum pesquisando sobre o problema e achei algumas coisas.

 

Tipo. Reinstalar tudo. Tirei tudo e reiniciei a maquina. Liguei para o suporte da SOLUTI perguntando se tinha alguma versão atualizada do certificado e eles conectou na maquina do cliente e fez a instalação em seguinda testando no ECAC. Depois disso tudo ainda continua o mesmo problema. Solicita a senha toda vez. Coloquei em outra maquia do cliente que tem o windows 7 atualizado para emissão da 4.0 e o mesmo caso novamente. A maquina anterior era o windows 10.

Link to post
Share on other sites
  • 1 month later...

Bom dia.

Tópico será fechado por estar inativo a algum tempo, caso necessário, por favo crie um novo tópico.

Att.

Consultora SAC ACBr

Juliana Tamizou
Ajude o Projeto ACBr crescer - Assine o SAC

Projeto ACBr     Telefone:(15) 2105-0750 WhatsApp(15)99790-2976.  Discord

Projeto ACBr - A maior comunidade Open Source de Automação Comercial do Brasil


Participe de nosso canal no Discord e fique ainda mais próximo da Comunidade !!

Link to post
Share on other sites
  • Este tópico foi criado há 891 dias atrás.
  • Talvez seja melhor você criar um NOVO TÓPICO do que postar uma resposta aqui
Guest
This topic is now closed to further replies.
×
×
  • Create New...